Varioskin 4 - der Power-Skin für Gopal 3

  • Kann aber auch am Alter liegen: Früher habe ich IKEA-Anleitungen auch besser verstanden


    oder doch an der Anleitung


    Wenn ich mal rumprobiere und ganz lange drücke, endet das meist im Chaos.
    Irgendwie fehlt da noch die jeweilige Ansage für den Modus, oder so was ähnliches.


    ganz lange sollte aber im Fahrradmodus enden nicht im Chaos.
    leider gibt es mit meinen jetzigen Programmierkenntnissen keine Lösung für eine Ansage während dem Drücken, wo man rausgekommen ist das sollte möglich sein, wenn ich halt mal dazukomme.


  • hallo sokobana,
    ich behaupte 'mal, dass Du die Hintergrundhelligkeit unter "Tools"-"Helligkeit/LED" entweder auf "Maximum" oder "Mittelwert" eingestellt hast ;) ,
    stell' doch bitte 'mal die Helligkeit versuchsweise auf "Minimum" und drücke dann nach einem Softreset im Hauptmenü erst den "LED aus-Button" und dann die "Fähnchentaste" :P
    Aufgefallen ist mir das während des "Herumprobierens", wenn die Fähnchentaste funktioniert, wird die Helligkeit langsam abgeblendet (Dimmeffekt), funktioniert's nicht, wird das Display "schlagartig" dunkel!


    Du wirst doch nicht zuviel Eierlikör getankt haben, randharzer? :lachen : drink


    :D eher zu wenig :sleeping:


    übrigens: NWP-Funktion wieder funktionsfähig :sonne

    Einmal editiert, zuletzt von der randharzer ()

  • Hallo Sokobana


    Ich nutze den Vario-Skin V4 auf ein Nicht GoPal 3 Navi , diese haben meines Wissens mit ein paar ausnahmen alle eine GPS-Baudrate von 57600 , die ganzneuen Navis sowieso .


    Dieser Beitrag betrifft nur Navis die eine höhere Baudrate als 4800 haben , also Navis die eine 57600 Baud haben , so wie mein E4430 , Navis mit 4800 Baud brauchen und sollen möglichtst nichts an der Baud umstellen , wozu auch .


    Euer Vario-Skin V4.01 läuft , soviel schon mal vorweg , danke für die viele Arbeit die ihr euch für uns macht .


    Der VideoServer ist mal wieder platt deswegen stelle ich die zwei Videos zum downloaden rein , ist auch eine bessere Qualität als das was der VideoServer mir bietet .


    Bei der ersten GP3.1 mit VarioSkin V4 neue Installation bekam ich direkt am Anfang eine Meldung ( Fehlermeldung ? ) siehe Video 1-Install_Vario_Skin_V4-01.avi über MortScript , hat aber alles funktioniert nur fand er keine Satteliten obwohl alles auf grün war , hatte aber mit dem anderem Navi an der selben Fensterstelle auch schlechte bis gar keine HDOP Werte und das 21 Zoll Navi jetzt mit VarioSkin hatte schon immer einen schlechteren GPS-Empfang .


    Bei der zweiten neu Installation GP3.1 mit VarioSkin V4 neu aufgesetzt wie beim erstenmal blieb die Meldung von MortScript aus und alles funktioniere , auch die Baud Umschaltung auf 4800 Baud , hatte vorm Neuaufsetzen den Akku gezogen damit der GPS-Chip wieder seine Originalen 57600 Baud hat , ich weis das hätte ich auch vom VarioSkin aus auf 57600 Baud stellen können aber ich wollte das Navi und vor allem den GPS-Chip erst mal im Originalzustand versetzen , Satteliten wurden gefunden , mehrmals um zu testen die Baud von 4800 auf 57600 und umgekehrt gestellt , die Umschaltung funktioniert tadellos bei 4800 Sat bei 57600 ohne Sat ist ja auch richtig , das GoPal 3 kannte noch keine 57600 Baud .


    Was mir noch aufgefallen ist , das in der Registry im Eintrag Sokobana der Eintrag GPS,4800 nicht existiert , der müsste doch mit RegKey=Software\sokobana\GPS,4800 aus der GPS_4800_test_Steuerung.txt geschrieben worden sein siehe Bild Regi-1.png , aber es funktioniert alles .


    Und es gibt in der Registry noch ein Eintrag der nach der Umschaltung auf 4800 Baud noch auf 57600 Baud steht siehe Bild Regi-2.png , wird wohl von GoPal 3 nicht genutzt oder noch nicht , vielleicht sollte man diesen Wert 57600 nach der Umschaltung von VarioSkin auf 4800 Baud auch auf 4800 setzen , aber das ist auch früh genug wenn es irgend welche Auswirkungen haben sollte .


    Gruß Manni

  • Hallo Manni,
    schreib doch mal ganz oben in Deinen Beitrag dick rein, dass Du den Varioskin auf einem Nicht-Gopal-3-Navi nutzt. Sonst werden andere User eventuell verunsichert und glauben, sie müssten am GPS-Port rumfummeln. :)


    Die Installation, die man im ersten Video sieht, ist bei Dir eindeutig fehlerhaft gelaufen. Er startet ja statt mit des Varioskin den original Gopal-Skin. Der Hintergrunddienst ist dadurch auch nicht aktiv.


    Was mir sonst noch auffiel: Kein COM-Port-Splitter aktiviert. So würde ich den Vario 4 auf keinen Fall laufen lassen. Das kann "ungeahnte" Probleme bringen. Z. B. fehlenden Sat-Empfang bei bestimmten Situationen.


    Es gibt anscheinend ein TMC-Problem. Muss man bei Deinem Navi da auch an den Ports schrauben? Oder geht das gar nicht zu aktivieren?


    Deine Frage nach dem Registy-Eintrag kann ich so aus dem Stehgreif nicht beantworten. Dazu müsste ich mir jetzt die Scripte noch mal genau vornehmen. Habe aber bis zum WE keine Zeit dafür. Vielleicht ist das von Dir genannte Script gar nicht wirklich im Gebrauch, sondern nur eine "Karteileiche"?


    Gruß sokobana

  • Hi Sokobana


    TMC geht , meine Antenne war bis unters Fenster gerutscht , sie muss schon wie auch im Auto ordentlich verlegt sein , TMC COM und BAUD sind glaube ich auf Medion Navis gleich geblieben .


    Am COM- Port – Splitter habe ich mich noch nicht rangemacht , mach ich aber noch .


    Gruß Manni

  • Der Serilot-Splitter geht auch siehe Sonnenkompass im Bild 3 , den VirtComm-Splitter habe ich noch nicht getestet , wird wohl gehen , ich möchte nicht alles durcheinander hauen , es läuft grad so schön . :D


    Gruß Manni

  • Hallo Sokobana und Team,


    konnte bereits über 600 km den Vario4.01 testen und es gab keinerlei Probleme.
    Hatte leider nicht die Möglichkeit, eine Stauumfahrung im Echtbetrieb zu testen (keinen Stau bei 500 km Autobahn, wo gibt es denn so was?).


    Zwei Dinge würden für mich noch das "i-Tüpfelchen" bilden:


    1. Wenn der Einstellwert für die Sonnenbrille mit gespeichert würde


    2. Wenn bei den Staumeldungen immer die tatsächlich zu erwartende Verzögerung angegeben würde, zumindest aber der Faktor, mit dem die Verzögerung GoPal vorgegaukelt wird.


    Nochmals besten Dank an alle Mitwirkenden für diesen erstklassigen Skin!


    Gruß paulinamarie2

  • Zwei Dinge würden für mich noch das "i-Tüpfelchen" bilden:


    1. Wenn der Einstellwert für die Sonnenbrille mit gespeichert würde


    Der Einstellwert wird in der Datei PFDefines.skn im Verzeichnis MFD | navigation | Skin480x272 dauerhaft gespeichert, übersteht also auch einen Hardreset.


    Die Zeile sieht etwa so aus:
    NightDay: 0,0,0,104; // Nachtabdunkelung: höherer Wert bedeutet dunkler


    Was seit ewigen Zeiten nicht funktioniert, ist die Anzeige(!) des aktuellen Werts nach einem Hardreset. Das kann ich aus Zeitgründen vorläufig nicht ändern.


    Zitat

    2. Wenn bei den Staumeldungen immer die tatsächlich zu erwartende Verzögerung angegeben würde, zumindest aber der Faktor, mit dem die Verzögerung GoPal vorgegaukelt wird.


    Das geht leider auch nicht. Wir können zu wenig Einfluss nehmen.
    Was Du aber tun kannst: Du kannst Dir die hinterlegte Durchfahrtverzögerung in den verschiedenen Modi anschauen. Ich hatte mal ein Tutorial zu diesem Thema geschrieben (TMC-Parameter manipulieren). Das findest Du ganz unten auf dieser Seite . Wenn Du willst, kannst Du Dir anhand der Infos eine eigene Datei basteln. :)




    Gruß sokobana

  • Komme gerade aus einem Urlaub:
    Vielen Dank an das Team Sokabana für den tollen Skin. :thumbsup: :thumbsup: :thumbsup:
    bandrian


    Vielen Dank an Dich und alle anderen Gratulanten! :rolleyes:
    Gruß sokobana

  • Der Serilot-Splitter geht auch siehe Sonnenkompass im Bild 3 , den VirtComm-Splitter habe ich noch nicht getestet , wird wohl gehen , ich möchte nicht alles durcheinander hauen , es läuft grad so schön . :D


    Gruß Manni

    Würde ich auch nicht tun. :P
    Danke für Deine ausführlichen Infos!
    Gruß sokobana

  • hallo sokobana,
    ich behaupte 'mal, dass Du die Hintergrundhelligkeit unter "Tools"-"Helligkeit/LED" entweder auf "Maximum" oder "Mittelwert" eingestellt hast ;) ,
    stell' doch bitte 'mal die Helligkeit versuchsweise auf "Minimum" und drücke dann nach einem Softreset im Hauptmenü erst den "LED aus-Button" und dann die "Fähnchentaste" :P
    Aufgefallen ist mir das während des "Herumprobierens", wenn die Fähnchentaste funktioniert, wird die Helligkeit langsam abgeblendet (Dimmeffekt), funktioniert's nicht, wird das Display "schlagartig" dunkel!

    Hab' ich öfter gemacht: Bei mir wird es dann auch sofort dunkel.
    Das ist doch ok so. :)


    Oder habe ich Dich falsch verstanden?
    Gruß sokobana

  • oder doch an der Anleitung



    ganz lange sollte aber im Fahrradmodus enden nicht im Chaos.
    leider gibt es mit meinen jetzigen Programmierkenntnissen keine Lösung für eine Ansage während dem Drücken, wo man rausgekommen ist das sollte möglich sein, wenn ich halt mal dazukomme.


    Was sind das denn für Modi, Fahrrad-Modus und Wandern-Modus?
    Was genau soll es machen, was ist der tiefere Sinn und wie schaltet man die genau? Auch wieder aus.


    Habe nix genaues zu dem Thema gefunden. ;(


    Gruß sokobana

  • den Link dorthin wo es steht kennst Du aber, Du hast ihn oben selbst gesetzt. ;)


    Diese Funktionsweise wurde von athos hier dokumentiert (ist etwas versteckt, aber man kann es finden)



    die Fähnchentaste hat jetzt zwei Stufen für die Klicksperre


    ca. 0,5 s drücken > Dunkel wie gehabt


    ca. 1-1,5 s drücken > Wandermodus, Deaktivierung der Klicksperre für 30 s durch zügigen Klick in die linke und dann in die rechte Hälfte. So kann das Navi auch in die Tasche.


    ca. >2s drücken > Fahrradmodus, kurzer Klick macht für 10s hell



    auf dem Rad klickst Du nur mal kurz, und hast die Hände schnell wieder am Lenker, beim Wandern in der Tasche wäre das aber dann dauernd an.

  • Stimmt. :D


    Wie soll ich mir das bloß alles merken ... 8)
    Ich vermute mal, dass durch die relativ geringen Zeitunterschiede für das Drücken, bei mir schon mal was durcheinander kommt.


    Wo könnte ich das einstellen?


    Gruß sokobana