Unterschied Stromversorgung zwischen Kontaktleiste <-> Mini USB

  • Hallo,


    vieleicht kann mir mal jemand weiterhelfen, hat ein ähnliches Problem oder einen Tip:


    Seitdem ich die PE4 teste habe ich auf meiner PE3 erprobten 4410 Hardware öfters "Fehler beim Zugriff auf die Speicherkarte...".


    Ich betreibe den 4410er in einem selbstgebauten Cradle und versorge mit 5V über Pin 10-12 mit Strom.
    Zufällig ist mir beim Messen des Ladestroms aufgefallen, dass über die Kontaktleiste nur max 450mA gezogen werden, Einschalten des Gerätes ändert hier nichts.
    Bei einer Versorgung über die Mini USB Buchse zieht der 4410er diesen Ladestrom PLUS einen deutlichen Betriebsstrom (> 700 mA) bei eingeschaltetem Gerät.


    Was das mit den Lesefehlern zu tun hat?
    Bei USB Versorgung oder Akku Betrieb sind die Fehler weg!


    Ist der Unterschied normal?


    Danke und Grüße
    b-hörnchen

  • Schließe mich an ... allerdings noch keine Erfahrungen bzgl. USB-Anschluss...
    Merkwürdig, hatte es schon auf die Speicherkarte geschoben, welche auf mich einen recht minderwertigen Eindruck macht.


    Edit: Allerdings habe ich das Problem auf jeden Fall auch schon bei Akkubetrieb gehabt.


    Fällt jemandem ein, woran das liegen könnte?
    Prinzipiell gehe ich nicht von Spannungsproblemen aus - lesen von Flashspeichern dürfte prinzipiell zu keinem drastisch erhöhten Stromverbrauch führen.


    Könnte es sich um einen Bug handeln, welcher im Januar behoben werden wird?

  • Hallo,


    nach intensiven Tests habe ich folgendes Verhalten NACH einem SUSPEND->RESUME festgestellt:


    Test:
    Nach dem Start von GoPal in die Kartenansicht gehn und das Gerät auf Suspend.
    Nach dem Resume in der Karte rumzoomen oder schieben, so dass Kartendaten gelesen werden.
    Die Fehlermeldung kommt recht zügig: "Fehler beim Zugriff auf die Speicherkarte..."


    Ergebnis:
    Im Akkubetrieb:.........................Kein Problem
    5V Labornetzteil an Mini USB:.......Kein Problem
    5V Labornetzteil an Kontaktleiste:.Problem kommt nach Resume unter Spannung durch Test
    USB Port vom PC an Mini USB:......Problem kommt nach Resume unter Spannung durch Test


    Das Problem tritt nicht nach einem Start von GoPal auf, sondern nur nach dem Wiedereinschalten des laufenden GoPals.
    Scheinbar ist mein Problem durch Einschalten (Resume) ohne Spannung zu umgehen, ich werde es mal länger testen.


    Grüße
    b-hörnchen

  • Hallo b-hörnchen,


    manche USB Ports vom PC liefern zuwenig Strom, speziell wenn der "Nachbarport" noch mit einem anderen Gerät (opt. USB Maus etc) belegt ist.


    Probleme bei Resume könnte es dann bei schwachen Akku und schwacher Stromversorgung durch den Einschaltstromstoss des internen Spannungswandlers ergeben.
    Die org. MEDION SD Card ist bei mir in die Digitalkamera gewandert und verhält sich völlig problemlos.


    Auch ich betreibe das Navi an einem selbstgebauten Cradle mit 5V Versorgung.
    Der unterschiedliche Stromverbrauch zwischen unterer Kontaktleiste und USB Buchse ist mir auch aufgefallen. Auch braucht das NAVI zum aufladen im EINGESCHALTETEN Zustand ewig (mehrere Stunden).


    Irgendwie werde ich die Vermutung nicht los, dass das Orginal Cradle mehr als 5 Volt (5,5V ??) an die Kontaktleiste abgibt.


    Vielleicht findet sich ja ein User der am aktive Cradle mal die Spannung an den Kontakten nachmisst...???


    hf
    schrotty

  • Jupp Fehler ist reproduzierbar.


    An USB-Port hängen -> Standby -> Einschalten -> Rauszoomen
    => Fehler mit Speicherkarte


    Könnte evtl. ein Softwareproblem sein, denn man könnte die Software erst verzögert auf die Karte zugreifen lassen denke ich...


    Was meint ihr, wie könnte man das Ganze umgehen?

  • Aufgepasst!


    Nach etwas Forschungsarbeit will ich selbst mal Licht in die Sache bringen, und der Thread Titel ist hier wirklich Programm:


    Ich bin drauf gekommen als ich meine unterschiedlichen Tests erklären wollte - der Unterschied liegt in den Kabeln die ich verwendet habe, oder besser gesagt an der Pinblegung.


    Ein normales USB Kabel hat Plus und Minus auf Pol 1 und 5 des Mini USB Steckers. Mit so einem Kabel begrenzt der PNA die max. Stromaufnahme auf ca. 450 mA um den USB Port nicht jenseits seiner Spec zu belasten. Deshalb dauert ein Ladevorgang so sehr lange, wenn überhaupt die grüne LED mal kommt.


    Ein wirkliches PNA Ladekabel (z.B. der original KfZ Lader) hat zusätzlich Pin 4 auf Masse. Mit so einem Kabel nimmt sich der PNA was er braucht (bis 1A). Damit geht auch die Ladung recht flott von Statten.


    Als ambitionierter Cradle Bastler hatte ich bislang immer Strom über die bekannten Pins 10-12 der Kontaktleiste angelegt. Seit langem habe ich mich gewundert, warum der PNA mit der Ladung nie fertig wird. Die Stromaufnahme erklärt es: Auch hier verhält sich der Stromkonsum "USB gerecht", also < 450mA.
    Jetzt will ich Euch aber auch nicht vorenthalten, welcher Pin an der Kontaktleiste diese Drosselung aufhebt. Nachdem ich --> PIN 2 <-- kurz auf Masse gelegt hatte, lächelte micht der PNA prompt mit einer grünen Lade LED an, da er schon voll war (Juchu). Bei leerem Akku und Betrieb nimmt er jetzt auch ordentlich Strom und ist zügig vollgeladen.


    Das waren die guten Nachrichten für Bastler und meine Odyssey der Ladeforschung hat ein Ende gefunden.


    Der "Fehler beim Zugriff auf die Speicherkarte..." lässt sich jetzt zumindest ganz genau beschreiben: Er tritt immer nach einem Resume von GoPal 4 bei "USB kompatibler Stromversorgung" auf. Wer weiss wo es hier hapert, aber das betrifft ja jetzt eigentlich nur noch die Routenplanung zu Hause bei USB Anschluss.


    Mein Cradle hat jetzt jedenfalls einen Kontakt mehr!


    (Alle Angaben natürlich ohne Gewähr)


    Frohes Fest wünscht
    b-hörnchen

  • Hallo BHörnchen,
    Super, vielen Dank.
    das mit Pin 2 vom Cradle ist der Tip des Jahres, werd ich demnächst ausprobieren.
    Der Zusammenhang mit dem Pin 4 vom (USB)-Ladekabel und dass der Akku kaum voll wird macht mir nun auch klar warum ein Motorola Handy Ladegerät nicht "gescheit" funktioniert.
    hf
    Schrotty

  • hätte ich hier nicht zufällig (durch die Suche) weitergelesen hätte es wohl bald keine Speicherkarten mehr gegeben :D
    Unterschied Stromversorgung zwischen Kontaktleiste <-> Mini USB ist so Nichtssagend .
    Ich hatte auch die Probleme mit der Speicherkarte. Ich habe auch schon SD Karten aus der DigiCam genommen und gehofft die sind von einer besseren Qualität als die von Medion. Aber die Fehler traten immer wieder mal auf. Ich hätte mir am Montag eine Neue gekauft!
    Danke. Das wirds wohl gewesen sein.
    Ich kann mir vorstellen es gibt noch andere mit den gleichen Problemen. Vielleicht sollte es mit in die WIKI oder Einsteigerhilfe oder so?


    Gruß Olli

  • Hallo,


    habe seit längerem das Problem mit "Gerät neu starten - Fehler beim Zugriff auf die Speicherkarte! Das Gerät muss neu gestartet werden." regelmäßig beim Einschalten aus dem Standby.


    Ich dachte immer, das es an der 4 GByte Transcend SD Karte liegt, die ich zeitgleich mit meinem "Festeinbau" und einem abgewinkelten USB-Ladegerät bekommen habe.


    Seit einer Woche fahre ich nun mit dem Original-Ladegerät und habe _keine_ Speicherkarten-Probleme mehr.


    Frage: Habe von AMS Hagen das KFZ Ladekabel Mini USB mit abgewinkeltem Stecker (http://www.ams-hagen.de/shop/index.php?a=2748 ) hinter der Verkleidung verbaut. Hat das noch jemand unverbaut/zugänglich herumliegen um mal nachzuschauen, ob Pin 4 auf Masse liegt? Bin unlustig, die Verkleidung am Auto wieder aufzuschrauben...


    Besten Dank und Gruß
    Tante


  • ich grab das noch einmal hoch! bin nur durch zufall über einen link hierher gestolpert!
    kannst du mir noch mal aufzeigen, welche kontakte (von wo zählt man eigentlich; geht die kontaktbelegung mit null los?? :D) auf masse gelegt werden? kontakt zwei wohin legen?


    danke dir schon mal ganz herzlich.



    mfg rohoel.


  • Hi rohoel,
    das steht detailiert in der GoPal Wiki unter Active Cradle;
    und Masse = GND;


    funktioniert einwandfrei.


    hf
    Schrotty