Pimp my Z09X/Z10.X/Z20.X + Becker "Back to PmB" + Speedcam

  • Mir wurde in einem anderen Forum gerade die Lösung serviert die toll funktioniert und mir sehr viel Zeit erspart hätte


    Folgender Eintrag in die sys.txt bewirkt das die Hintergrundbeleuchtung beim Start von IGO (nicht das BeckerIGO) auf 100% gestellt wird.
    [color=#NaN4406]
    [power]
    backlight_manage_values = 1
    backlight_manage_keys = 1
    backlight_max = 8
    backlight_min = 1
    backlight_methods = 39


    Mich wunderst das diese Lösung hier so noch nicht diskutiert worden ist, da ja das Backlight bei mehreren Leuten Kofpweh verursacht hat- Trotzdem Danke, und vielleicht kann ja wer etwas anfangen damit ..


    [/color]

  • Hallo,


    um den ersten Thread von dir zu beantworten,für dich ist die Version 2.1.1 gedacht!


    Edit: Über die Shell.exe wie beim 7928 ist es nicht möglich gewesen!


    Nun zum zweiten Thread: Die Änderungen die dort im iGO in der sys.txt vorgenommen hast,haben zwar Einfluss auf das Backlight im iGO selbst, ABER eben nicht auf das PmB wenn du dieses zum ersten Mal startest! Das PmB selbst bleibt dunkel und erst wenn iGO gestartet wird und wieder geschlossen wird bleibt diese Helligkeit bestehen! Deswegen hatte ich beim Ersttstart GPS Mate starten lassen,denn dadurch bekommt auch das PmB(Zwischenmenü) volle Helligkeit! Dieses funktioniert aber leider bei den neuen Geräten nicht mehr!

  • Erst mal Dank an den erbauern der diversen Sachen.


    Ich habe da ein Problem an meinem Becker crocodile z100.


    Alles wunderbar geklappt mit der Installation PmB und Einrichtung der diversen Skins.


    Mein Problem ist das ausschalten aus den skins bzw. zurück zu PmB. Da habe ich sowohl als auch im Joshua und im Fuggel "doppelte Bilder (Buttons) drinne.


    Wie kann ich die abschalten? Die ui start habe ich an allen dreien bearbeitet so wie beschrieben.


    Siehe Fotos. 509 ist Joshua und 512 ist Fuggel

  • Hallo,


    hast du denn noch einen Ordner "ui_becker" im iGO Hauptverzeichnis erstellt! Falls ja,wenn du die Änderungen in der Skindatei durchführst,wäre dieser nicht mehr nötig,bzw. es würde zu überschneidungen kommen!
    Der Fuggel und @tomic Skin beinhaltet die Funktion des "Back to PmB" bereits! Der einige Skin den du anpassen müsstest ist der von Joshua!

  • Ich habe jetzt die ui becker im iGO8 auf Flash Disk entfernt.


    Beide skins Joshua und Fuggel frisch neu rübergeschoben und den gleichen effekt.


    Nachtrag:


    die Data zip vom Becker überspielt jetzt ist das Bild nimmer doppelt, aber Fuggel geht auch nicht mahr nach PmB zurück, werde wohl noch etwas basteln, aber das war der richtige ansatz das da etwas doppelt drin ist in der ui start

  • Hallo,


    dann hast du irgendwo noch "altlasten" rum liegen,anders ist das leider nicht zu erklären! Wie sieht denn deine "sys.txt" aus?

  • Hallo,


    ich nehme an das du das PmB mit Skin Changer installiert hast,wenn du jetzt den Fuggel Skin auswählst,ändert sich dann dieser Eintrag:


    theme="skin\Joshua1.7.zip" ,in:


    theme="skin\fuggel.....zip"


    Eines noch ,daß aktuelle Service Release (SR3) hast du,oder?

  • SR 3 ist drauf.


    Der Skinnahme ändert sich bei entsprechender Auswahl.


    Das waren doppelte Einträge in der ui start 420. ganz unten reinkopiert. (Das Problem saß wie immer vor dem Computer).


    Becker original und Joshua könen beendet werden mit back to PmB, nur bei dem Fuggel geht das nicht, habe auch hier keine doppelten einträge mehr, es erscheint auch der Button nur wenn ich drauf drücke dann machts Klack, aber es tut sich nichts sondern schaltet nach der abgelaufenen Zeit das Gerät ab.


    Werde also nochmals den Fuggel blau neu draufmachen und dann mal sehen was geht.

  • Ich glaube fuggel realisiert "Back to PmB" über MortScript! Ich schaue mal!


    Edit: Ja wird über MortScript realisiert,fand ich schon immer ein wenig unglücklich das so zu regeln,aber naja...angeblich läuft es stabiler,wobei ich auf die herkömmliche Art und Weise nie Probleme hatte!

  • Also Becker original geht wenn der ui_becker\480_272\ui in iGO8 Ordner angelegt ist.


    Die Dateien in Joshua.zip eingetragen mittels Proton funzt auch.


    Also mit den beiden, Becker ori und skin joshua komm ich dann wunderbar wieder auf das PmB.


    Jetzt kömmt der Fuggel. Der will in ui_becker\480_272\ui die von mir erstellte start 420 überschrieben haben mit seinen Daten, habs gemacht hat zur Folge das Becker original nicht mehr zu PMB geht und Fuggel reagierte garnicht auf den Button PMB sondern schaltet in standby. Natürlich auch in Fuggel aktiviert das PmB vorhanden ist.


    Einzige Möglichkeit wäre jetzt die start420 im Data.zip ordner von iGO8 abzuändern, aber da mag ih nicht so gerne dran gehen.


    Entferne ich die ui_becker\480_272\ui im iGO8 Verzeichnis gänzlich, dann funzt nur noch Joshua, weil ich den ja in seiner Zip die start 420 abgeändert habe.


    Der Button ist da beim Fuggel, es macht auch schön Klack wenn ich den bediene aber geht nur in Stand by und nicht zu PmB. Oder halt ausschalten und Gerät neu starten und dementsprechenden Skin auswählen. Alle drei zusammen scheint nicht zu funzenuckeln bei mir.

  • Also meine Empfehlung geht dahin das du in allen Skins die von mir beschriebenen Änderungen durchführst,aber wirklich in den eigentlichen Skins und achte dann darauf das keine doppellten Einträge in der .ui Datei vorhanden sind!


    Wenn du zusätzlich zu den aktivierten Skins noch den seperaten Ordner mit Unterstrukturen (ui_becker\480_272\ui) erstellst,kommt es zu überschneidungen!


    Ist schon korrekt die eigentliche Data.zip nicht anzupassen! Diese sollte man im Ursprungszustand belassen!

  • Habe es hinbekommen so wie es sein soll. Im Fuggel Skin.zip


    Die Line


    <BUTTON xxx template=btn_popup_1of4 text="Back to PmB" onrelease='EXIT' visiblemodel="interface.show_exit" nostress=1>


    in den Fuggel skin ui_becker\480_272\ui unten eingetragen und


    die Line


    <BUTTON xxx template=btn_popup_1of4 text="Back to PmB" onrelease='START_APPLICATION "\Storage Card\PMB\MortScript\CloseZ201.exe" ""' visiblemodel="ui.vPmBOnOff">


    entfernt.


    Habe zuerst geändert auf closez100.exe, aber hatte nichts genutzt. Okay beendet wohl nimmer über die MortScript, aber das ist mir egal.


    Den seperat erstellten Ordner im iGO8 Verzeichnis ui_becker\480_272\ui habe ich beibehalten, da hierüber ja die Original Becker PMB eingestellt ist.


    Nix mehr doppelt, alles funzt.


    Big thx samue für Deine Hülfe, manchmal sieht man vor lauter Bäumen ja den Wald nicht mehr. :thumbsup:

  • Klausss
    Habe mir grade mal den Thread durch gelesen. Wollte eigentlich nicht Antworten
    kann mir es aber doch nicht verkneiffen. Manche Diskussionen müstten nicht sein
    wenn man beim jeweiligen Skin-Thread die Beschreibung oder kurz Anleitung der 1 Seite liest.
    "Da der Skin ja auch Back to PmB hat. Die Leute die auch das PmB benutzen, bitte die Mortscript.zip


    (natürlich Entpacken) auch laden und ins PmB auf die SD-Karte kopieren.


    Läuft so stabieler beim Beenden und es verursacht keine Resets mehr."




    @samue

    Zitat

    Edit:
    Ja wird über MortScript realisiert,fand ich schon immer ein wenig
    unglücklich das so zu regeln,aber naja...angeblich läuft es
    stabiler,wobei ich auf die herkömmliche Art und Weise nie Probleme
    hatte!


    ich hatte dir irgend wo schon mal darauf geantwortet. Wenn ich über Mortscript beende bleiben die Änderungen


    die ich vorgemommen habe erhalten, zb. Sprache, Uhrzeit, Mem-Speicher für die SD-Card, Win-Ce einstellungen


    usw.


    Wenn ich es so beende wie du es beschreibst fährt es ja auch runter! nur es passiert mit einem Reset(bei mir) und


    alle einstellungen die ich vorgenommen habe sind dann futsch. Deswegen habe ich es über Mortscript geregelt.




    Wie ist es den bei dir mit dem Beenden?? Fährt es den bei dir zurück ins PmB ohne ein Reset?? und alle einstllungen


    bleiben erhalten??