Z100 und Routen tracken ON/OFF

  • Hallo,


    Wie von flipi beschrieben, wollte ich mir die Tracking on/off- Funktion ins Menü einbauen. Im Nav-Setting-Menü ist bei mir eine 4. Menüseite vorhanden (darin nur 2 Buttons / L1, R1) - daher wollte ich den Button in die 2. Zeile (L2) setzen.


    Funktioniert aber irgendwie nicht, kein Button da... (auch nicht bei GPS-Empfang) ??
    Hier mal meine Veränderungen in der "navset_480_272.ui" / habe ich vielleicht was übersehen?



    Danke, für einen Tipp!

  • Den machst am besten in die Layer


    ui_NavigateMapZoomControls2D
    ui_NavigateMapZoomControls3D


    ind die navigatemap480_272.ui. Damit sie im 2 und 3D Modus sichtbar sind.


    Kannst sie aber auch zu den ui_NavigateMapInfos einbauen auch in der Datei.


    Kannst es mal so testen:


    <BUTTON xxx template=txt bmp="icon_logon.bmp" onrelease='run sc_RecordOn' visiblemodel="!ui.vRecord">
    <BUTTON xxx template=txt bmp="icon_logoff.bmp" onrelease='run sc_RecordOff' visiblemodel="ui.vRecord">

  • .. geht leider nicht / Fehlermeldung: "</layer expected"


    Habe die Buttons jeweils unter layer:
    ui_NavigateMapZoomControls2D
    und
    ui_NavigateMapZoomControls3D

    eingefügt // danach folgt jeweils die Zeile "</layer>" ?


    Brauchen die Buttons vielleicht einen eigenen layer??

  • .. OK. unter ui_NavigateMapInfos funktionierts !!


    Könntest du mir nur noch ein paar Tipps geben, wie ich die Position des Buttons auf der Karte variieren kann (einfach x= y= z= ..?) - er ist jetzt nämlich z.T. von der Infobox verdeckt...


    Supi, Danke!