AVGPS Version 2.02 verfügbar

  • Hi Omega,


    nun hatte ich mal Zeit, mich mal mit der neuesten Version Deines Programmes zu beschäftigen. Als erstes fällt mir auf, dass wieder mal Pfad-Probleme bestehen (s.Bild). Gibt es denn kein besseres Verfahren, um Pfade zu verwalten ? Ich finde das vorhandene 'Pfadgewusel' nicht wirklch toll. Trotzdem habe ich natürlich auch versucht, mein Holux mit den selben Parametern auszulesen, wie es mit der Original-Software funktioniert. Geht aber nicht (s.Bilder). Schade. Warum geht eigentlich der Finden-Knopf nicht ? Wenn ich der DAU bin, dann erlöse mich :-)


    Gruß schmude

  • Ich habe hier von gestern ein Log; erstellt von Qstarz BT-Q1000X (MTK II). AVGPS kann im gegensatz zu den anderen vorliegenden Programmen die Dateien nicht öffen. ?(

    schwarz-weiß-blaue Grüße!


    Nur noch mit Festeinbau unterwegs, aber natürlich mit POIBase sowohl auf Smartphone mit Ansagen über Autolautsprecher und Musikunterbrechung als auch direkt im Navi (einfache Anzeige eines einheitlichen Icons mit Piep-Warnton).

    Einmal editiert, zuletzt von HSVMichi ()

  • Hi,


    ich habe heute mal eine kleine Testdatei erstellt (weit unter 5500 Punkte) und dabei ist aufgefallen, daß AVGPS die beiden enthaltenen Tracks nicht als einzelne Tracks darstellt, sondern alle Punkte in einem einzelnen Track zusammenfasst.


    Wenn ich die SBP Datei erst nach GPX wandle (z.B. mit Navilink II) und dann die GPX Datei in AVGPS einlese werden dagegen beide Tracks erkannt und man kann sie einzeln auswählen.


    Ciao,
    Steffen

  • Hallo zusammen!


    Mit Freude entdeckte ich dieses Programm, insbesondere, weil es die Daten meines Holux m-241 auslesen kann. Allerdings habe ich doch diverse Probleme damit, vielleicht kann jemand weiterhelfen:


    1. Beim Start erscheint bei mir eine Fehlermeldung: "file://p:\TMX\TEMP\TrackOnGoogleMaps.html wurde nicht gefunden. Stellen Sie sicher, dass der Pfad bzw. die Internetadresse richtig ist." Den Pfad gibt es tatsächlich nicht, aber was sucht AVGPS da und wieso gerade da?


    2. Das Auslesen funktioniert nur, wenn die Geschwindigkeit auf 38400 eingestellt wird. Ist das eine Hardware-Einschränkung des Holux?


    3. Wenn ich die Daten richtig einstelle (COM3, 38400, Holux M-241) und anschließend versuche, die Daten auszulesen, dauert es bei recht vollem Logspeicher über eine Viertelstunde. Anschließend erscheint wie beim Benutzer c.lange eine Exception (jederzeit reproduzierbar, bei Bedarf bitte melden). Die kann ich zwar wegklicken, aber ich schaffe es nicht, wieder ins Programm zurückzukehren, da sich das Programm entweder beendet (beim Blick auf "Beenden") oder aufhängt (beim Klick auf "Weiter").


    4. Ich kann .trl-Dateien, die vom Holux Logger Utility erzeugt wurde, zwar öffnen (über "GnavTRL-Dateien (*.trl)"), der Track wird auch angezeigt, doch dann schließt sich AVGPS plötzlich ohne Vorwarnung nach ein paar Sekunden. (Dazu genügt es, in der Trackliste nach unten zu scrollen - bald ist das Programm komplett weg.)


    Und was sind "Holux M-241 MTK-Dateien (*.bin)"? Wie kriege ich die erzeugt und das ist der Unterschied zu den .trl-Dateien?


    Wegen 3. und 4. ist das Programm für mich derzeit leider nutzlos, aber ich denke, dass die Probleme zu beheben sind, dann sieht es wirklich gut aus.


    BTW: Gibt es irgendwo eine Dokumentation?


    (Alles mit Version 2.02 unter Windows XP Professional, SP2.)

    Einmal editiert, zuletzt von Katerchen ()

  • Si können auch BT747 probieren für diese Funktionen.

  • Zitat

    Original von c.lange
    Beim auslesen der Logs aus meinem WBT-201 hängt die 2.02 nach der Erfolgsmeldung mit einer Exception:


    ************** Exception Text **************
    System.ArgumentOutOfRangeException: Year, Month, and Day parameters describe an un-representable DateTime.
    at System.DateTime.DateToTicks(Int32 year, Int32 month, Int32 day)


    Laß mir mal bitte die TK1 Datei zukommen... dann kann ich danach schauen... ;)


    Grüße


    Andreas

  • Zitat

    Original von schmude
    Als erstes fällt mir auf, dass wieder mal Pfad-Probleme bestehen (s.Bild). Gibt es denn kein besseres Verfahren, um Pfade zu verwalten ? Ich finde das vorhandene 'Pfadgewusel' nicht wirklch toll.


    Verstehe ich nicht ganz.... bitte konkretisieren und, wenn möglich, konstruktive Vorschläge...


    Zitat


    Trotzdem habe ich natürlich auch versucht, mein Holux mit den selben Parametern auszulesen, wie es mit der Original-Software funktioniert. Geht aber nicht (s.Bilder). Schade.


    Ich kann aus den Bildern nicht ablesen bzw. erkennen, was denn nun nicht ging. Bitte genaue Fehlerbeschreibung.
    Bitte denkt daran, dass ich kein Holux Gerät habe, ich muss alles "blind" programmieren und bin auf eure Hilfe angewiesen...


    Zitat


    Warum geht eigentlich der Finden-Knopf nicht ? Wenn ich der DAU bin, dann erlöse mich :-)


    Weil ich nicht weiß, nach was ich für den Holux suchen muß! Gebauer gesagt, wie heißt der Schnittstellentreiber für den Holux Logger!? Heißt der immer "slabser..."!? Dann kann ich das einabauen...


    Grüße


    Andreas

  • Zitat

    Original von HSVMichi
    Ich habe hier von gestern ein Log; erstellt von Qstarz BT-Q1000X (MTK II). AVGPS kann im gegensatz zu den anderen vorliegenden Programmen die Dateien nicht öffen. ?(


    Bitte stelle mir die Datei(en) zur Verfügung, dann schaue ich mal danach.... ;)


    Grüße


    Andreas

  • Hallo Steffen,


    Zitat

    Original von siebert
    ich habe heute mal eine kleine Testdatei erstellt (weit unter 5500 Punkte) und dabei ist aufgefallen, daß AVGPS die beiden enthaltenen Tracks nicht als einzelne Tracks darstellt, sondern alle Punkte in einem einzelnen Track zusammenfasst.


    Wenn ich die SBP Datei erst nach GPX wandle (z.B. mit Navilink II) und dann die GPX Datei in AVGPS einlese werden dagegen beide Tracks erkannt und man kann sie einzeln auswählen.


    Ich antworte hiermit auch auf Dein vorheriges Posting zu diesem Thema:


    Ich selbst habe den SBN Support anhand einer mir zur verfügung gestellten Datei programmiert und getestet. Deshalb kann es gut sein, dass ich nicht alle Details richtig interpretiere.


    Bitte schick mir Deine SBN Datei(en) zu, dann kann ich danach schauen. Nett wäre es, wenn Du mir gleich noch die (korrekten) entsprechenden GPX Dateien dazulegen könntest, dann muss ich die nicht selber konvertieren.


    Grüße


    Andreas

  • Hi Andreas,


    Zitat

    Original von omega
    Bitte schick mir Deine SBN Datei(en) zu, dann kann ich danach schauen. Nett wäre es, wenn Du mir gleich noch die (korrekten) entsprechenden GPX Dateien dazulegen könntest, dann muss ich die nicht selber konvertieren.


    die Dateien kommen per email.



    Ich habe jetzt auch mal eine SBP Datei mit AVGPS nach GPX konvertiert:


    Überhaupt nicht nachvollziehen kann ich den Wert für "course". Wird der von AVGPS aus zwei Punkten berechnet, oder der Wert COG aus der SBP Datei genommen?


    Als Wert für "fix" wird immer none ausgegeben, obwohl natürlich bei den meisten Punkten ein Fix vorhanden war.


    Die Geschwindigkeit in der Description als km/h anzugeben, macht sicher Sinn. Aber warum wird der Wert von "gpxx OrigSpeed" auch in km/h angegeben, statt in m/s wie er auch im SBP Format hinterlegt ist? Das GPX Tag "speed" ist auch in m/s. Gibt es übrigens einen Grund, daß Du das nicht benutzt?


    Und woher kommt das "gpxx OrigSpeed" Tag? In der angegebenen Schema Datei von Wintec (http://gps.wintec.tw/xsd/TMX_GpxExt.xsd) finde ich nur Definitionen der Tags Temperature und Pressure. Eine Schema Validierung sollte hier eigenlich meckern, bei meinem Test wurden allerdings schon die "desc" Tags angemeckert:


    Message: Element 'desc' is not valid for content model: '((ele,time,magvar,geoidheight,name,cmt,desc,src,link,sym,type,fix,sat,hdop,vdop,pdop,ageofdgpsdata,dgpsid),extensions)'


    Da "desc" eigentlich aufgeführt ist vermute ich, daß es hier ein Problem in der Tagreihenfolge gibt. Für weitere Infos zum Thema Validierung siehe http://www.topografix.com/gpx_validation.asp


    Ciao,
    Steffen


    PS: Auch das "gpxx SatsInView" Tag wirft Fragen auf, wenn es den Wert von SVIDCnt enthält ist der Name falsch und das Standard GPX Tag "sat" wäre die bessere Wahl, da es genau für diesen Wert vorgesehen ist. Wenn der Wert wirklich die sichtbaren Satelliten angibt, ist mir unklar wo der Wert herkommt.

    Einmal editiert, zuletzt von siebert ()

  • Zitat

    Original von omega
    Laß mir mal bitte die TK1 Datei zukommen... dann kann ich danach schauen... ;)


    Gerne, aber wo finde ich sie? Wenn ich den Track mit TimeMachineX auslese kann ich die Datei problemlos in AVGPS importieren. Beim auslesen des Logs mit AVGPS gibt es die Exeception und (anscheinend) keine Spur der Datei...

  • Zitat

    Original von c.lange


    Gerne, aber wo finde ich sie? Wenn ich den Track mit TimeMachineX auslese kann ich die Datei problemlos in AVGPS importieren. Beim auslesen des Logs mit AVGPS gibt es die Exeception und (anscheinend) keine Spur der Datei...


    Ich meinte auch die mit TMX ausgelesene TK1 Datei... AVGPS konnte diese ja nicht anlegen....


    Andreas

  • Zitat

    Original von omega
    Ich meinte auch die mit TMX ausgelesene TK1 Datei... AVGPS konnte diese ja nicht anlegen....


    Du hast Post

  • Zitat

    Original von siebert
    Überhaupt nicht nachvollziehen kann ich den Wert für "course". Wird der von AVGPS aus zwei Punkten berechnet, oder der Wert COG aus der SBP Datei genommen?


    Der Wert für course wird immer und für alle Formate von AVGPS aus zwei Punkten berechnet.


    Zitat


    Als Wert für "fix" wird immer none ausgegeben, obwohl natürlich bei den meisten Punkten ein Fix vorhanden war.


    Der Fix Modus wurde bisher nicht mit ausgegeben, da er explizit in der SBP Datei nicht enthalten war. Ich leite ihn aber jtzt aus den SatsInUse ab.


    Zitat


    Die Geschwindigkeit in der Description als km/h anzugeben, macht sicher Sinn. Aber warum wird der Wert von "gpxx OrigSpeed" auch in km/h angegeben, statt in m/s wie er auch im SBP Format hinterlegt ist? Das GPX Tag "speed" ist auch in m/s. Gibt es übrigens einen Grund, daß Du das nicht benutzt?


    1) "gpxx OrigSpeed" ist bislang ein interner Wert als GPX Extension, ignorier's einfach.
    2) Das GPX Tag "speed" gibt es nur in GPX 1.0, nicht in GPX 1.1.
    3) Ich schreibe keine GPX 1.0 dateien, deshalb kann ich das Tag "speed" nicht verwenden.


    Zitat


    Und woher kommt das "gpxx OrigSpeed" Tag? In der angegebenen Schema Datei von Wintec (http://gps.wintec.tw/xsd/TMX_GpxExt.xsd) finde ich nur Definitionen der Tags Temperature und Pressure. Eine Schema Validierung sollte hier eigenlich meckern, bei meinem Test wurden allerdings schon die "desc" Tags angemeckert:


    Message: Element 'desc' is not valid for content model: '((ele,time,magvar,geoidheight,name,cmt,desc,src,link,sym,type,fix,sat,hdop,vdop,pdop,ageofdgpsdata,dgpsid),extensions)'


    Da "desc" eigentlich aufgeführt ist vermute ich, daß es hier ein Problem in der Tagreihenfolge gibt. Für weitere Infos zum Thema Validierung siehe http://www.topografix.com/gpx_validation.asp


    Vergiss die Validierung. Ich habe bislang einfach den WinTec Namensraum misbraucht, in Ermangelung von Zeit, mir ein eigenes Schema zu erstellen.


    Zitat


    PS: Auch das "gpxx SatsInView" Tag wirft Fragen auf, wenn es den Wert von SVIDCnt enthält ist der Name falsch und das Standard GPX Tag "sat" wäre die bessere Wahl, da es genau für diesen Wert vorgesehen ist. Wenn der Wert wirklich die sichtbaren Satelliten angibt, ist mir unklar wo der Wert herkommt.


    Ist korrigiert: war noch ein Fehler aus der Zeit, wo ich SatsInView und SatsInUse nicht korrekt unterschieden habe.


    Grüße


    Andreas


    P.S. Das mit den 5500 Trackpunkten beim Einlesen von SBP Dateien ist ein dummer Fehler von mir, da ich vergessen habe, einen Debug-Code zu deaktivieren. Der Fehler ist behoben.


    P.S. Ich habe auch den Fehler rausgemacht, dass alle Trackpunkte als nur ein Track erkannt wurden.

    2 Mal editiert, zuletzt von omega ()

  • Zitat

    Original von Katerchen
    1. Beim Start erscheint bei mir eine Fehlermeldung: "file://p:\TMX\TEMP\TrackOnGoogleMaps.html wurde nicht gefunden. Stellen Sie sicher, dass der Pfad bzw. die Internetadresse richtig ist." Den Pfad gibt es tatsächlich nicht, aber was sucht AVGPS da und wieso gerade da?


    Im Ordner "Eigene Dateien" befindet sich die Konfigurationsdatei avgps.cfg. Dort gibt es einen Eintrag DirTMP, der auf diesen Pfad zeigt. Entweder diesen Eintrag komplett löschen oder ein gültiges Verzeichnis reinschreiben.


    Zitat


    2. Das Auslesen funktioniert nur, wenn die Geschwindigkeit auf 38400 eingestellt wird. Ist das eine Hardware-Einschränkung des Holux?


    Habe ich leider keine Ahnung, da ich diesen Logger nicht habe.


    Zitat


    3. Wenn ich die Daten richtig einstelle (COM3, 38400, Holux M-241) und anschließend versuche, die Daten auszulesen, dauert es bei recht vollem Logspeicher über eine Viertelstunde. Anschließend erscheint wie beim Benutzer c.lange eine Exception (jederzeit reproduzierbar, bei Bedarf bitte melden). Die kann ich zwar wegklicken, aber ich schaffe es nicht, wieder ins Programm zurückzukehren, da sich das Programm entweder beendet (beim Blick auf "Beenden") oder aufhängt (beim Klick auf "Weiter").


    Ich bräuchte den genauen Text der Exception.....
    Die Zeitdauer ist wohl OK! Versuche mit dem I-Blue haben gezeigt, dass das Auslesen ganz schön lange brauchen kann. Wie lange brauchen denn andere Programme!?


    Zitat


    4. Ich kann .trl-Dateien, die vom Holux Logger Utility erzeugt wurde, zwar öffnen (über "GnavTRL-Dateien (*.trl)"), der Track wird auch angezeigt, doch dann schließt sich AVGPS plötzlich ohne Vorwarnung nach ein paar Sekunden. (Dazu genügt es, in der Trackliste nach unten zu scrollen - bald ist das Programm komplett weg.)


    Kann ich nicht nachvollziehen.... ?(
    Kannst Du mir die entpsrechende TRL Datei zukommen lassen!?


    Zitat


    Und was sind "Holux M-241 MTK-Dateien (*.bin)"? Wie kriege ich die erzeugt und das ist der Unterschied zu den .trl-Dateien?


    Viele MTK Hilfsprogramme erstellen beim Auslesen des Loggers eine .bin Datei, die den kompletten Speicherinhalt enthält. AVGPS macht das ebenfalls.


    Grüße


    Andreas