MN 5.2 und Aufruf von TMC-Meldungen

  • Zitat

    Original von sagrotan
    .......
    Nö, seit der direkten Installation von 5.2 -ohne Drüberbügeln auf eine Vorversion- läuft´s gut.
    Null Frost und null Abstürze bisher.


    Hi


    Danke auch für dein Echo!


    Wechlen PDA verwendest Du?


    Weches Betriebssystem: PPC 2003 oder WM 2005


    vlG bab

    ;-) bab

  • Hallo,


    ja aber weiterhin gibt es das Problem, welches das ursprüngliche Problem war, dass beim MN 5.2 ohne POI-Warner die TMC Meldungen nach betätigung sofort angezeigt werden.
    Nach der Installation des POI-Warners (2.98) und des original MN5 Scrrens mit TMC und SAT Anzahl Anzeige die TMC Meldungen und auch die SAT-Meldungsanzeige beim betätigen mal schnell geht und auch schon mal 20-30 Minuten dauern kann bis Diese angezeigt werden.


    Das war mein ursprüngliches Problem.


    MN 5.2 mit Loox N520, WM5
    sonst keine Programme installiert !


    Gruß
    Sven

  • Zitat

    Original von sagrotan
    2003 auf MDA3


    Das sollte wohl WM 2003SE sein, oder etwa nicht ?(


    Sascha

  • Hi,


    hatte auch grad ein komisches Erlebnis.


    Hab mal einen Skin gebastelt für Sender, TMC und Sat-Balken. Allerdings immer wenn ich während der Simulation auf das TMC-Symbol klicke (ohne angeschlossenen TMC-Empfänger, denn ich habe keinen) konnte ich auf dem Navi-Bildschirm nichts mehr anklicken... gar nichts mehr.
    Nur ein Klick auf den grünen Punkt vom POI-Warner funktionierte. Als ich den damit dann beendet hatte, erschien auch die Startleiste vom Heute-Screen und ich konnte den MN5.2 durch klicken auf das rote Kreuz rechts oben beenden.


    Und da wars... beim Schliessen des MN5 erschien auf dem Heute-Screen das Meldungsfenster "kein TMC-Empfänger angeschlossen"


    Sollte also der MN5.2 doch einen Bug haben, so dass das TMC-Fenster nicht da geöffnet wird, wo es eigentlich hin sollte? Oder hing der in einer Schleife, aus der er erst beim abschalten des MN5.2 raus konnte?


    Vielleicht hilft euch das ja was.....


    LG doldi

    a program worth using is a program worth buying !!


    FSC Loox 720 (VGA, 2003SE) - Xaiox WondeXL (Nemerix) - MN|5.2.6 (modifizierter Standard-Skin) - No TMC!

    POI-Warner 2.98 - Balken-Sat-Anzeige - Mortscript - TMC-Light-Changer - SunCalc - Wetter-PlugIn2

    MDC - PocketPlus3 - PocketInformant2007


  • Hi


    Frage: ist das reproduzierbar ( bei dir ) ?


    ;) bab

    ;-) bab

  • Hi bab,


    dazu ein klares Ja.. allerdings mit der Korrektur, dass das fehlende TMC-Meldungsfenster dann nicht auf dem Heute erscheint, sondern auf der Kartenansicht. Ein Klicken auf den Screen brachte nur ein Tonsignal, nämlich das wenn man wo hinklickt wo man nicht darf.


    Direkt nach dem Beenden des POIW ist Grafikmüll genau an der Stelle wo das Fenster sein sollte. Man findet auch blind den Haken zum schliessen des Fensters, aber dann, wenn man nochmal aufs TMC-Symbol klickt, bleibt zum herauskommen nur noch ein reset.


    Da ich mal sehen wollte, wieviel Speicher noch frei ist, hab ich da mal nachgesehen, und nach dem Schliessen der Fenster erschien auf dem Navi-Screen wieder die Grafik des TMC-Fensters. Dieses geschlossen und MN5.2 lief ganz normal weiter wie auch während der falschen Anzeige. Da ja danach der POIW geschlossen ist, und es nach erneutem Klicken wieder so ist, denke ich dass es was mit MN5.2 zu tun hat.


    Es ist nicht so in der Kartenansicht, da isses korrekt. Während der Fahrt habe ich nicht gestestet, aber in der Simulation taucht es genau so wie beschrieben und auch reproduzierbar auf. Neuinstallation habe ich allerdings noch nicht gemacht. Werde ich aber bei Gelegenheit mal machen.


    Frei Auge würd ich mal sagen: Speicherkonflikt


    edit1: 10 Minuten nach dem zweiten Versuch ist dann das TMC-Fenster aufgetaucht...


    edit2: noch was... beim Anklicken des TMC-Symbols verschwinden die Anzeigen wie Sender und TMC-Anzahl für den Bruchteil einer Sekunde.


    edit3: Beim Erreichen des Ziels tauchte das lang vermisste TMC-Fenster dann auch auf.


    LG doldi

  • Hi zusammen,



    Nachdem Doldi geschrieben hat, dass das ganze auch in der Simulation auftritt, habe ich heute mal viele verschiedene Simulationen durchlaufen lassen. Zuerst habe ich vermutet, dass es mit den Einblendungen der Geschwindigkeitsschilder zu tun hat. Aber dem ist nicht so.


    Soviel vorweg: es scheint ein Speicherbelegungsproblem bzw. Resourcenproblem bei der Grafik beim MN 5.2 zu sein.


    Das ganze getestet auf meinem hx4700, zuvor Hardreset und nur MN 5.2 und vbar installiert, auch kein POI-Warner.
    Das Problem tritt verstärkt dann auf, wenn die Grafik mit der Karte viel zu tun hat, d.h. bei niedriger Geschwindigkeit auch in der Stadt (viele Straßen, Häuserblöcke, Sonderziele, Kreuzungen, dadurch auch Richtungspfeile in der Ansicht etc.)
    Sobald man entweder in der Simulation oder auch beim echten Routing das TMC-Symbol antippt, ist der Rest der Navioberfläche nicht bedienbar, bis irgendwann das TMC-Fenster aufgeht.


    Außerhalb von bebauten Gebieten bzw. Gebieten wo nicht soviel Grafik abverlangt wird, kommt das Problem erst zum Vorschein wenn man schneller fährt, und dadurch der Zoom eine größere Karte zeigt. Deshalb gibt es im Forum auch verschiedene Aussagen, einer sagt ab 100 km/h nicht mehr bedienbar, der andere sagt schon bei langsamen Geschwindigkeiten, der nächste sagt, dass er gar keine Probleme hat (derjenige ist vermutlich auf einer AB ohne Bebauung links und rechts gefahren).


    Daraus resultiert das Hauptproblem: Sobald man manuelle Umfahrung eingestellt hat, kommt bei einer entsprechenden TMC-Meldung zwar die Ansage " Bitte beachten Sie die Anweisungen auf Ihrem Bildschirm", aber das TMC-Fenster geht erst dann auf, wenn Ressourcen in der Grafik frei sind, bzw. frei werden.


    Übrigens freier Daten- und Programmspeicher zusammen während der Simulation: ca. 6-7 MB, also Speichermangel ist ausgeschlossen.


    Anschließend habe ich ansatzweise das ganze noch auf meinem 3970 mit WM2003 getestet. Das Ergebnis ist das gleiche.


    Kann jemand meine Theorie bestätigen bzw. wiederlegen?



    Gruß Berthold

    Navigon 8110 und MN7 Android auf HTC Desire

  • Ja,


    kann ich, mein hx4700 hat 60 MB frei und mein Loox 610 auch, gleiches Resultat wie bei Dir.



    Mfg


    Belongo

  • Zitat

    Original von nick1
    Übrigens freier Daten- und Programmspeicher zusammen während der Simulation: ca. 6-7 MB, also Speichermangel ist ausgeschlossen.


    Das ist für MN|5.2 schon sehr wenig


    Sascha

  • Zitat

    Original von SaBo


    Das ist für MN|5.2 schon sehr wenig


    Sascha


    Hi sascha,


    es ist nur MN 5.2 im Hauptspeicher installiert. Nach Softreset sind 37MB gesamt frei. Beim Navigieren noch 6-7 MB. Wo soll man den Speicher her nehmen, wenn MN 5.2 schon ca. 30MB nur fürs Arbeiten braucht.


    Übrigens: MN5.1 läuft bei mir auch mit 1-2MB freiem Speicher während der Navigation recht zuverlässig.


    Gruß Berthold

    Navigon 8110 und MN7 Android auf HTC Desire

  • Zitat

    Original von nick1
    .......


    Übrigens: MN5.1 läuft bei mir auch mit 1-2MB freiem Speicher während der Navigation recht zuverlässig.


    Gruß Berthold


    Hi


    Da darf aber kein rerouting dazwischen kommen. Oder?


    Weil, wo soll die neue Route ihren Platz finden, die alte ist ja auch noch da 8)


    vlG Kalli bab


    Upps


    edit


    @ berthold; Danke für dein posting! Deine Gedanken zu dem Problem!

    ;-) bab

    Einmal editiert, zuletzt von bab ()


  • Kein Problem. Aber das ist wahrscheinlich die Sonderkonstellation des hx4700. Der läuft zwar erst mit mind. 30MB vor Programmstart, dann aber relativ zuverlässig, auch über Strecken > 800km, Rerouting und mind. 50 TMC-Meldungen. Mein 3970 benötigt höchstens 25MB vor Programmstart.


    Gruß Berthold

    Navigon 8110 und MN7 Android auf HTC Desire

  • Ich denke, die Theorie, dass die "Blockade" bei einer konkreten Geschwindigkeit (100 km/h) einsetzt, können wir als hinreichend widerlegt betrachten. Und damit ebenso, dass es ein absichtlich von Navigon eingebautes "Feature" ist.


    Ich habe sehr stark den Eindruck, dass es mit der CPU-Auslastung zusammenhängt. Die kann man z.B. mit SuperTasks
    www.softwareandson.com/SuperTasks
    anzeigen lassen.


    Im Stillstand liegt die Auslastung bei mir recht nahe an 0, steigt dann aber mit zunehmender Geschwindigkeit recht schnell in die Nähe von 100% an. Im Detail haben darauf natürlich alle möglichen Faktoren (Hardware, andere Programme, Zoomstufe, Kompliziertheit der aktuellen Umgebung etc.) Einfluss, was die unterschiedlichen Beobachtungen der User erklärt.


    Ich bin mir nicht sicher, ob bei 5.1 die Auslastung signifikant geringer war. Ich könnte mir aber vorstellen, dass etwas an der Priorität verschiedener Prozesse geändert wurde, dass also z.B. die Aktualisierung der Kartenansicht Vorrang hat und für das Erkennen von Bildschirmklicks und die Reaktion darauf bei hoher Auslastung (= hoher Geschwindigkeit) nur noch selten eine Lücke bleibt. So ähnlich hatte ich das schon im Glopus-Thread zum gleichen Problem geäußert
    www.pocketnavigation.de/board/…ostid=1109893#post1109893
    ohne dass jemand darauf eingegangen wäre... :-D)

  • Hallo nick1, belongo, 944S2, bab,



    ich kann das beschriebene Phänomen von nick1 genau so bestätigen - hab mir zwar nicht die Mühe gemacht, das ganze nach einem Hard Reset neu zu installieren, bin aber bei dem Upgrade genau nach Anleitung vorgegangen.


    Bei mir ist auch genug Speicher frei wenn MN52, POIW und GLOPUS laufen - Wenn ich dann eine TMC Meldung auf den Schirm bekomme (lange nach der Ansage) bzw. im TMC Menu war, kommt auch GLOPUS mit seinen Einblendungen nicht mehr nach.


    Im Stadtverkehr geht es einigermaßen - Auf der BAB ist das ganze ein Graus !! :-D)


    Je nachdem, wie ich die Speicheraufteilung wähle sind bei mir bis zu 50MB frei - Ich denke, dass die hx4700 User wahrscheinlich wieder einmal das empfindlichste Systems haben und damit am meisten kämpfen


    Ich glaube ebenfalls nicht an eine geschwindigkeistabhängige Begrenzung durch Navigon.


    Die scheinbar veränderten Skins von navigating haben bei mir jedenfalls keine Abhilfe gebracht.


    Schade an der ganzen Sache ist nur, dass wir das Phänomen bereits einen Tag nach der Veröffentlichung des Verwirrungspatches bereits erkannt hatten und Navigon daraufhin bis heute nicht reagiert hat -


    Welchen Nährwert hat eigentlich das Update auf 5.2?


    Cebit hin und her, es kann eigentlich nicht sein, dass ein Softwarehersteller keine ausreichende Qualitätssicherung hat und zudem sich zumindest nichtmal diesem hervorragendem Forum bedient um dann die Versäumnisse zu beseitigen


    Entweder hätte der Patch zurück gezogen gehört oder es hätte mit Hochdruck einer nachgeschoben werden müssen !


    ein dreifaches SCHADE an Navigon


    Viele Grüße
    ceffi