Automatisches Weiterschalten der Zielpunkte (Fehler und Verbesserungsvorschläge)

  • Hallo an alle,


    habe immer noch das Problem, dass das automatische Weiterschalten der Zielpunkte nicht funktioniert.
    Im Forum habe ich leider noch keinen dienlichen Hinweis gefunden.


    Habe aktuell die reg. Version Glopus 2.04
    Benutze Glopus ohne zusätzliche Navigationssoftware!


    Das Weiterschalten ging früher mal, bei der letzten Glopus Version funktionierte es bei einer Radtour auf einmal nicht mehr !
    Mit der mittlerweile aktuellen Version hab ich es auch nicht mehr hinbekommen ?!?!?!?


    Einstellungen in der GoTo-Seite Auto > 30m.
    Hängt das noch mit einer anderen Einstellung oder Umständen zusammen ???


    Weiß jemand Rat


    Gruß Dirk

  • Hallo,


    habe am Wochenende noch mal einige Tests bezüglich des genannten Problems mit dem automatischen Weiterschalten der Zielpunkte gemacht.
    Ich habe mit hilfe der Lengenmessung eine neue Zielliste angelegt, diese habe ich dann zu Fuß abgelaufen und einige Sachen ausprobiert! :whistling:


    Folgende Punkte sind mir aufgefallen:


    1) Auf der GoTo-Seite stand im Feld für "auto bei >" eine 0 8| , diese Null muß irgendwie beim Herumspielen mit Ziellisten dorthingekommen sein.
    wissentlich hab ich sie dort nicht eingetragen, da bin ich mir ziemlich sicher.
    Okay, wenn dort eine Null steht, dürfte das mit dem Weiterschalten nicht so richtig funktionieren :!: :!: :!:


    2) Es scheint so als ob Glopus intern mit der Reihenfolge der Zielliste irgendwie durcheinander kommt, obwohl die Zielliste (Waypoints) in der Karte
    und in der Tabelle richtig angezeigt werden.
    Man kann es auch daran erkennen, das das manuelle Weiterschalten mit den Prev und Next Buttons nicht mehr richtig funktioniert.
    Wenn dieser Zustand erreicht ist, geht das Weiterschalten nicht mehr.


    Wenn der Endpunkt der Liste erreicht ist und Next betätigt wird, wird bei der Entfernung die Formatierung ":.02f km" ausgegeben (habe folgende Ausgabeformatierung %GoToDistance:.02f% km) :wacko:


    Wenn ein Punkt aus der Liste gewählt wird und auf die Goto-Seite übernommen wird, scheint der Ordnungs-Offset des Zielpunktes um eins daneben zu liegen,


    bei NEXT wird auf den übernächsten Punkt gesprungen :D ist auch bei NEXT in der GotoSeite so :!:
    bei PREV wird dann an den Anfang der Liste gesprungen :D ist auch bei PREV in der GotoSeite so :!:



    Frage: kann man sich eigentlich auch die Ordnungsnummer zusätzlich zum Namen des Zielpunktes in der Gotozeile anzeigen lassen :?:
    Ich meine früher wäre die Nummer irgendwie mitangezeigt worden.


    3) Das Weiterschalten scheint auch Probleme zu machen, wenn der Abstand der Zielpunkte kleiner als der unter "Auto bei >" eingegebenem Wert liegt.
    z.B. Eingabe Auto bei > 50m, ZP1 -> ZP2 = 30m, ZP2-> ZP3 = 100m
    keine Weiterschaltung ZP1 bleibt aktiv


    Verbesserungsvorschlag: Wenn sich das wirklich so herausstellt, dann sollte die Zielliste soweit durchlaufen werden, bis der aktuelle Abstand wieder größer
    dem eingegebenen Wert für "Auto bei > " ist.
    Und dies auch wenn der Wert für "Auto bei > " geändert wird.



    Hoffe ich konnte etwas positives beitragen. ;)


    Gruß Dirk

  • Hallo,



    Frage: kann man sich eigentlich auch die Ordnungsnummer zusätzlich zum Namen des Zielpunktes in der Gotozeile anzeigen lassen :?:
    Ich meine früher wäre die Nummer irgendwie mitangezeigt worden.


    Die Nummer werden angezeigt wenn man eine Zielliste ohne Text (was ja meist bei Routen so ist) verwendet.



    Ich weis ja nicht für was du die Funktion verwenden willst.


    Aber ich verwende meist diese Funktion zusätzlich zur eingebelndeten Route.


    Das heist ich las mir eine Route einblenden und zusätzlich hab ich eine Waypunktliste erstellt mit ein paar Punkten (meist 4-10) die ich auf jededenfall anlaufen will und hatte noch nie Probleme damit (gut ich hab auch nicht damit rumgespielt sondern nur verwendet).
    Einen Sinn eine Route mich von Punkt zu Punkt weiterschalten zu lassen hab ich für mich noch nicht gefunden - in der Regel liegen meine Waypunkte 1-5 km auseinander und dienen nur der groben Orientierung falls ich die Route verlasen hab/musste, Abstände unter 200-500m sind meist witzlos da ich diese ja auf der Karte sehe.



    Was für mich noch wichtiger als Neuerungen ist das die mommentan noch vorghadenen kleineren Bugs - wie z.B. vervollständigen Symbole der Toolleiste und das bei Fullscreen der POI-Text des ausgewählten POI's unter der Toolleiste verschwindet behoben werden.
    Aber da bin ich mir sicher das Peter das auch in der nächsten Version miterledigt!


    Gruß
    Silver

    Regioausflug.de Wandertourenplaner für Odenwald, Rhön, Mittelrhein und Taunus!!!!


    Ein Stau ist nur hinten blöd - vorne gehts !!!!

  • Hallo Silver,


    mhmmm das mit der Anzeige der Ordnungsnummer, wenn keine Name für den Zielpunkt eingegeben ist scheint nicht mehr zu funktionieren, hab das noch mal probiert, werde das aber noch mal genauer untersuchen. Benutze die Version 2.04
    Aber Du hast recht, es ging das auf jeden fall mal so wie Du es beschrieben hast.


    Zum Thema automatischen Weiterschaltung:
    Das mit den kürzeren Abständen zwischen den Waypoints kann sich ergeben, wenn
    man z.B. eine bei bikemap geplante Route als gpx in die Zielliste importiert.


    Okay, wenn ich eine Radtour mache und eine Route nachfahre, hab ich auch nur eine dicke Linie auf dem Display der ich folge, wenn man am radeln ist, erkennt man sowieso nur bedingt Kartendetails. :D


    Wenn man es aber verwendet, weil es ja nun mal möglich ist, sind die bgeschriebenen Probleme eben sehr störend :!:


    Da ich selber Programmierer bin, vermute ich, das sich die beschriebenen Bugs evtl. auch an andere Stelle im Programm auswirken und dort wiederum unerklärliche Auswirkungen haben.
    Deshalb denke ich, dass Peter für jeden Hinweis dankbar ist, und damit vielleicht Fehlerzusammenhänge aufgeklärt werden an die niemand gedacht hat. ^^


    Gruß Dirk