BT-GPS-8 Jentro, Kurzbericht

  • > Ist das Ding jetzt zerschossen und ich muss den Jentro jetzt "leer" machen oder fällt jemanden noch etwas ein?


    ... denke nicht, evt. hast du den Jentro unter Linux nur übergangsweise für die laufende
    Sitzung eingebunden ? - Wenn der immer eingebunden werden soll muss evt. noch was
    im /etc Verzeichniss gesetzt werden.


    Wenn du den Jentro in Reichweite bringst, was sagt dann die Konsolenausgabe ?


    ( Je nach Distri z.B. auf Konsole 10 - oder einfach den Befehl dmesg eingeben )


    existiert /dev/rfcomm0 denn auch , oder wurde es dito nur für die eine Sitzung
    kreiert ?


    Bzw. bei einer LiveLinux musst du eh alles neu einhacken, da du ja nicht die
    Daten auf der CD/DVD ändern kannst ( zumind. nicht so ohne weiteres - Customized Knoppix )


    Meiner tut seinen Dienst seit Modi mit SirfIIIDemo problemlos.


    Gruß Bernd

  • Hi,
    es war nur für die eine Sitzung und es hatte ja zu erst funktioniert.
    Beim zweiten Mal habe ich die LiveCD neu eingelegt und alles wieder wie vorher gemacht. Blaue LED leuchtet durchgehend.
    Wenn man den "cat /dev/rfcomm0" Befehl eingibt, sollten normalerweise die NMEA Daten in der Konsole zu sehen sein aber der Cursor bleibt einfach stehend und es passiert nichts.


    Unter Windows erscheinen weder in SirfDemo noch in VirtualGPS irgendwelche Daten. Außer die "á" Zeichen.


    Gruß

  • ... dann check mal alle Schritte Stück für Stück, evt. kannst du auch
    bei den Befehlen als Option -v eingeben, viele Befehle schalten dann
    den "Verbosty" Modus ein und geben mehr Info's aus.


    Wie hast du das gemacht, a la:


    http://blogs.srijan.in/2008/01…h-gps-devices-with-linux/


    mit hcitool cc devid ( die Hexkennung ) kannst du den GPS ja einbinden,
    das haben die auf der Seite gleich in /etc gemacht - für Livelinux geht das ja nicht.


    Achte auf die evt. Fehlermeldungen


    nach jedem Befehl auch dmesg eingeben, dort meldet er u.U. am Ende was grad so
    passiert ( oder eben nicht )


    Bernd

  • Nun wirds sonderbar:


    Mein Jentro war ja eingestellt und ein paar Tage im Testbetrieb, nun wollte ich das
    Einbinden unter Linux machen - und es kommt nur Datenmüll !


    Ich habe dann Windows getestet, dort ist ja alles eingestellt - UND es geht auch nicht !
    Die Navisoft findet den Jentro, beim Zugriff 'drauf stürzt die Navisoft AB !


    Scheint fast so als hätte sich der Jentro verändert / umprogrammiert OHNE das er an war (?!?).


    Er lag nur ein paar Tage ungenutzt rum - Accu ist rel. voll - das kann es auch nicht sein.


    Ein paar Tests mit SIRFDemo schlugen auch fehl, Verbindung klappt zwar aber ich bekomme ihn
    nicht in einen brauchbaren Modus geschaltet. Ich muss den wohl resetten.


    Ist es denn nötig das man dort einen Resetknopf einbaut - irgendwie billig das Teil aber
    wohl doch eher buggy bzw. für Bastler.


    Ich werd mal die anderen Softwarevarianten testen die hier kursieren, oder man versucht
    das Ding umzuflashen, damit er vernünftigt Grundeinstellung hat.


    Ich wollte den permanenter im Auto einbauen, aber so ist das unstabil, sonst verwende ich
    nur den Chipsatz, externer Accu ( bzw. 3.7 V vom Bordnetz runtergeregelt ) und der Rest kommt
    sonst wo hin, aber wenn der Betriebsmodus instabil ist lohnt das auch nicht.


    Fazit doch erst mal Vorsicht damit - ein sicheres Arbeiten wie mit sonstigen GPS-Geräten
    könnte mit dem Jentro nicht gehen - deshalb so billig ???


    Gruß Bernd

  • Nach Reset und neuprogrammierung mit SIRFDemo läufts wieder,
    Ich baue nun eine Resettaste ein - die den Accu kurz vom Gerät trennt.


    Wenn das Gerät öfter solch Spirenzchen macht... .
    Fehler könnte evt. auch bei aktivem WLAN sein ?


    BT und WLAN nutzen teils selbe Frequenz - meine Intel 4965 Karte
    verweigert bei aktivem BT z.B. das Senden.


    Bernd

  • So, wie bereits angedroht hier mal ein Paket, mit dem man ohne SirfDemo bzw. ohne Umschalten in den Sirf-Modus und wieder Zurückschalten nach NMEA - was oft zu Hängern führt - die Maus programmieren kann.


    Das Tool GPX-XOR ist ein quick&dirty-Tool. D.h. Anwendung auf eigene Gefahr und ohne Funktionsgarantie ;). Bei mir hat aber alles, was ich damit getestet habe, einwandfrei funktioniert.


    Mit GPS-Diag (Freeware) kann man den Empfänger ansprechen und über "Tools > Send command..." beliebige NMEA-Befehle an den Empfänger senden. Dabei sieht man im Hauptfenster von GPS-Diag sofort das Ergebnis unter "Received data".


    Die Checksumme der NMEA-Kommandos bzw. den kompletten Befehl kann man sich mit GPX-XOR berechnen lassen. Ich habe eine kleine Online-Hilfe in das Programm eingebaut, die man mit dem ?-Button aufruft. Das Tool stelle ich als Freeware zur Verfügung.


    Wenn man einen Befehl eingegeben und Calc geklickt hat befindet sich der Befehl inkl. korrekter Checksumme in der Zwischenablage. Dann kann man ihn direkt in GPS-Diag im Feld "NMEA command" einfügen und mit "Send NMEA" an den Empfänger senden.


    Die Beschreibung zu den NMEA-Kommandos findet man im "NMEA Reference Manual". Das konnte ich leider nicht mit in das Paket packen wegen dem Copyright. Wenn man aber nach "NMEA Reference Manual" googelt findet man viele Links direkt auf das PDF.
    Ich habe die Revision 2.2 vom November 2008, in diesem findet man unter 2-4 "103Query/Rate Control" z.B. den Befehl, wie man Protokolle aktiviert/deaktiviert und den aktuellen Status abfragt.

  • 'werd ich nachher gleich mal testen, und unter Linux habe ich merkwürdige Effekte,
    nach Verwendung von GPSD war die Maus wieder in undefinierten Zuständen.


    Ob das nun an Linux bzw. gpsd liegt weiß ich nicht 100% - cat /dec/rfcomm0 lief auf alle
    Fälle - bis zum Start von gpsd, danach kamen nur Sonderzeichen.


    Und nun ist die Maus wieder nicht mit SirfDemo umprogrammierbar - also wieder Reset.


    Die Erfolgreichen Tests liefen aber immer mit dem Netbook, und deaktivem WLAN, die
    Tests unter Linux liefen derzeit nur auf dem norm. Notebook - dort war zu BT auch WLAN an.


    Dein Programm wäre auf alle Fälle hilfreich - SirfDemo ist echt heikel.
    Ich baue nun definitiv einen Resettaster ein - wohl unumgänglich.


    Interessant wäre evt. auch ein Ändern der Defaultwerte auch sinnvolle Einstellung, dazu hat aber
    keiner Info's ?


    Bernd

  • Moin zusammen,
    tut mir leid das ich mich erst jetzt melde. Musste noch etwas arbeiten.
    Also unter Ubuntu bekomme ich bei ein- wie ausgeschaltetem WLAN immer weiße Fragezeichen mit schwarzen Hintergrund, wenn ich den Befehl "cat /dev/rfcomm0" eintippe. Wenn ich da ein "-v" hinter hänge, dann sind es "-`M"-Ketten.


    Unter Windows und VisualGPS sind es "à"-Zeichen. Also scheint sich das Ding wohl aufgehängt zu haben, vermute ich zumindest mal. Obwohl ich mit SirfDemo IMMER mit 57k baud gearbeitet habe.


    Werde jetzt mal das Tool von Candid ausprobieren. Vielleicht tut sich dort etwas.


    Auf gutes Gelingen :)

  • Hallo zusammen,
    danke erstmal für die bisherigen hilfreichen Beiträge. Hab damit den Jentro in verbindung mit Garmin Mobile PC zum laufen gebracht (mit sirfdemo).


    Würde aber gerne auch Microsoft Streets and Trips damit betreiben. Sollte wohl ähnlich sein wie Autoroute. GpsGate hab ich auch schon und das scheint auch zu funktionieren. Die ausgangsports kann ich z.B. mit VisualGPS verwenden.


    Streets and Trips nimmt den Comport auch an, bzw findet da ein GPS, aber wenn ich diesen dann verwende bekommt er keine Daten. Es kommt auch keine Fehlermeldung oder ähnliches.


    Hat damit (oder Autoroute) schon jemand Erfahrung?


    Danke schonmal.


  • Hallo und willkommen hier.


    Das könnte ein (NMEA-) Protokoll-Problem sein, was hast Du denn derzeit aktiviert?


    Normal wird zur Navigation GGA verwendet. Es gibt aber auch Progs, die möchten nur RMC. Prüfe das mal.

  • n'Abend, Leute...


    hab mir den jentro BT-GPS-8U auch bei reichelt bestellt.
    Dazu hab ich auf meinem Samsung SGH-C3050 bereits folgende Software:
    navigami, GPSJLite, vlkgps, GPSLog (c't edition), TO-Kompass, GPSViewer, Velox, eGPSTrack und TrekBuddy


    brauch ich natürlich alle nicht, aber ich hab versucht den Empfänger mit allem möglichen zu testen (auch PC-Software sowohl für Win XP als auch Ubuntu 9.04)
    Jedenfalls hat alles nicht funktioniert, selbst Satelliten wurden bei den Handyprogrammen nicht angezeigt, immer nur Position 0°0'0" N/E/S/W...


    Hauptsächlich benutze ich Ubuntu, für Windoof müsste ich bei meinem IBM Thinkpad R60 immer die Festplatte aus und 'ne andere einbauen...


    Und da praktisch das Halbe Internet bei der Suche nach Jentro BT-GPS auf diesen Forenartikel verweist, hab ich ihn mir von Seite 1-3 aufmerksam durchgelesen und sofort SiRFDemo geladen und bei meinem Windows installiert.
    Folgende Aktionen hab ich heut abend wohl schon zig-tausend Mal nacheinander durchgeführt:


    1. JENTRO BT-GPS-8U eingeschaltet
    2. Paarverbindung mit meinem WIDCOMM Bluetooth Treiber hergestellt (Pin: 0000)
    3. Serielle Verbindung des Empfängers auf COM7
    4. SiRFDemo gestartet
    5. Einstellung: COM7 mit Baudrate 57600 (hab auch schon alle anderen COMs getestet, weil hier irgendwo was von 2 verschiedenen COMs steht...)
    6. gemerkt, dass der Empfänger auf der Fensterbank bereits Satelliten gefunden hat (grüne LED brennt) aber noch keine feste BT-Verbindung besteht (blaue LED blinkt)
    7. Verbinden-Icon angeklickt -> blaue LED brennt
    8. bei SiRFDemo steht bei DebugView nichts... (siehe Bild 1 unten)
    9. SiRFDemo -> Action -> Switch to NMEA (Ja, wenn ich das Programm neu starte, steht da beim Verbinden immer nur "Switch to NMEA", außer wenn ich das anklicke, die Verbindung mit Klick aufs Icon trenne und genau so wieder herstelle...)
    10. Die Einstellungen dafür sieht man in dem Bild 2 unten
    11. Die blaue LED fängt wieder an zu blinken, aber SiRFDemo zeigt auf dem Verbinden-Button oben die verbundenen Stecker an...
    12. Handy -> eins der o.g. Programme gestartet -> Bluetooth suche -> Jentro BT-GPS-8 auswählen -> verbinden -> Blaue LED brennt durchgehend -> keine Satellitenanzeige am Handy, Position 0°N/E/S/W (bzw. mit einem PC Prog und ner Seriellen BT-Verbindung - GPSdrive, xgps etc bei Ubuntu, VisualGPS und GPS Diag bei Windows)
    13. Handyprogramm geschlossen, Empfänger ausgeschaltet und SiRFDemo beendet.


    Jedenfalls hab ich für heute erstmal keine Lust mehr, dass mich mein GPS-Empfänger so ärgert - jetzt ärger ich ihn heute Nacht mal, indem ich teste, was passiert, wenn ich ihn Tiefentlade... Falls das gefährlich sein sollte, bitte in den nächsten 10 min melden, solange bin ich vielleicht noch online... ;-)


    Die Bilder zu meinem Problem:
    Bild 1: Bild 2:


    Kann mir jemand helfen?
    Wie bekomme ich vernünftige Koordinaten und Sat-Infos von meinem GPS-Programm angezeigt?
    Was mache ich beim umprogrammieren falsch?
    Hab ich vllt. sogar nen falschen Bluetooth Treiber.....?
     ?( ?(


    Vielen Dank für eure Hilfe,
    flo


    p.s.: ich hab mich jetzt nur für diese Frage hier registriert - also gebt gefälligst vernünftige Antworten...!!! :gap

  • Guten Morgen ;-)


    Hab also jetzt über nacht den Empfänger mit meinem Bluetooth Handy und GPSLog gekoppelt und leerlaufen lassen (Ich konnte ihn heut morgen nicht mal mehr einschalten...) und es hat funktioniert:
    Hab den Empfänger nochmal so programmiert, nachdem bei SiRFDemo im Debug View Fenster endlich etwas angezeigt wurde und dann lief er mit allen Programmen auf meinem Handy!!
    Also funktioniert es auf jeden Fall mit Reseten...


    Danke nochmal fürs Tutorial,
    flo

  • Moin, ja Resettaster ist wohl nötig... .


    Das Tiefentladen ist nicht gut für den Accu, aber das schrieb ich ja schon einmal.


    Bei mir treten Probleme vor allem dann auf, wenn ich den GPS mit Linux nutze, ich
    weis noch nicht recht ob es ein Fehler von gpsd oder ähnlich ist - oder eben
    der Fehler beim Jentro liegt.


    Am interessantesten wäre für mich bald das umflashen, sofern möglich das der Jentro nach
    reset einfach mit vernünftigen nmea Einstellungen kommt, ohne umprogrammieren.


    Aber - erstaunlicher Weise: unter Winvirus mit MobilePC lief der in den wenigen Tests
    störungsfrei.


    Ich ordere heut den SMD-Schalter, und den baue ich dann ein = Resetschalter.


    Gruß Bernd


    ( zum Glück navigiere ich norm. mit nem anderen GPS )

  • Zitat

    Original von dl6bfl
    Das Tiefentladen ist nicht gut für den Accu, aber das schrieb ich ja schon einmal.


    Ich glaube nicht, dass der Akku, wenn man die Maus "leer macht", tatsächlich tiefentladen ist. Wenn ich mir den Akku näher anschaue ist dort eine kleine Schaltung verbaut, die sicher sowohl Überlade- als auch Tiefentladeschutz ist.


    Zitat

    Original von dl6bfl
    Am interessantesten wäre für mich bald das umflashen...


    Das dachte ich mir auch schon, nur leider wird das nicht wirklich trivial sein.