Kann keine Routen einbinden

  • Hallo Gemeinde,


    folgende Probleme mit dem o.g. Gerät. Softwareversion ist Premium Navigation in 3D 8.3.2.92111


    Es gelingt mir nicht, vorbereitete Routen einzulesen. Weder als track noch als Route, weder als gpx, noch als klm, noch als trk Format. Die trk Formate erkennt er zwar, aber die tracks haben dann 0km und auch sonst keinen Inhalt.


    Ich habe unter anderem diese Beschreibung gefunden:
    http://www.duesiblog.de/index.php?/arch ... -FAQs.html


    Auch hier (!)
    http://www.navifriends.com/phpbbForum/viewtopic.php?f=186&t=17712
    Ich habe das selbe Problem wie der User dieses Boards hier


    Zitat

    .Auf meiner SD gab es keinen Ordner Userdata. Ich habe einen mit dem Unterordener Routes angelegt aber auch dann werden die Routen von iGO nicht erkannt. 2. In iGO erstellte und dann abgespeicherte Routen werden im Ordner Save/Routes im Format *.dat abgespeichert. Kann mir da vielleicht jemand weiterhelfen?



    Zitat

    Ich habe Routeconverter benutzt um die Dateien zu konvertieren und habe auch unterschiedliche kml-Formate probiert. Aber es klappt nicht. Im iGO-Unterordner Content gibt es auf meiner SD-Karte keinen weiteren Unterordner Userdata. Da ich aber, wie gesagt, alles gebraucht gekauft hab weiss ich allerdings nicht, ob meine iGO Version eien offizielle ist. Vielleicht ist das ja was gecracktes!?




    Tja, aber ich habe meins vor ein paar Tagen bei Pearl bestellt, also nicht gebraucht.



    Weiteres Problem:
    Der Content Manager erkennt das Gerät nicht. Es ist verbunden und eingeschaltet. Wenn ich es connecte, erkennt der PC zwei LAufwerke. Es ist dann nicht mehr möglich, das Navgear zu bedienen.


    Vielleicht kann mir jemand helfen ? Leute, es gibt diese Ordner wirklich nicht auf meiner SD Card. Die routes werden als .dat unter "MobileNavigator\save\routes abgespeichert.


    Der Order Content enthält nur folgende Ordner:


    building, lang, phoneme, speedcam, dem, map, poi und voice. Keinesfall Userdata.


    ich habe diese ordner auch mal manuell angelegt, aber das wird vom S.Mate ignoriert.

  • .
    Hallo und willkommen im Forum.


    Das GT-35 kann Routen im .kml Format, z.B. aus dem Motoradtourenplaner, einlesen. Die Anzahl der Routenpunkte ist allerdings begrenzt (~ 30-40).


    Da die Navisoftware des GT kompatibel zu iGO8 ist (ist eine iGO8 OEM Version), können die .kml Dateien genauso wie in iGO8 eingelesen werden. Mit dem Unterschied, dass beim GT-35 die .kml Dateien in den Ordner \MobileNavigator\content\userdata\route der Speicherkarte kommen (bei iGO8 ist das eben \iGO8\content\userdata\route). Die letzten beiden Unterordner existieren standardmäßig nicht. Also die Unterordner ..\userdata\route einfach neu anlegen und in ..\route kommen die .kml Dateien (am einfachsten alles über Kartenleser am PC).


    Auch mal zum Thema hier einlesen und weiterführende Links:


    RoutenImport klappt nicht - zu viele Zwischenziele


    Routen import - erstes Ziel / Ausgangsposition
    .

  • danke, genau das klappt eben nicht.


    Das GT35 3D kann die .kml Dateien eben nicht einlesen, egal ob ich die Order manuell anlege und da reinkopiere, oder unter save/routes ablege.


    Die Funktion "Route laden" ist nicht wählbar.


    So weit war ich mit meiner Recherche nämlich auch schon.



    Aber vielleicht hast Du mal eine kml Datei, die verifiziert eingelesen werden kann ?

  • Verstehe ich das richtig? Der Menüpunkt "Route/ Route laden" ist nicht anwählbar (ausgegraut)?


    Dann sind zunächst auch mal keine mit iGO selbst angelegten Routen im Ordner \MobileNavigator\save\routes gespeichert. Also mal in iGO eine Route von A nach B planen und abspeichern. Dann ist auch der Menüpunkt Route laden anwählbar. Aber kml Routen im Ordner ..\save werden grundsätzlich ignoriert!


    .kml Dateien kommen in den Ordner-Pfad:
    \MobileNavigator\content\userdata\route


    Auf die Schreibweise achten (..\route nicht ..\routes) !!


    Im Anhang eine Beispielroute, die .txt Endung nach dem Download entfernen. Nach dem Einlesen wird von der letzten bzw. aktuellen GPS Position geroutet. Wie man diesen "falschen" Startpunkt entfernt, habe ich in meinen oben geposteten Links beschrieben.

  • Kommando zurück !


    Ich hatte userdata/routes eingerichtet, also plural.


    mit userdata/route konnte ich jetzt eine auf GPSies geplante route einlesen. nur ne kurze strecke, allerdings 207 wegpunkte :evil:
    habe die kml datei in google maps geöfffnet und habe auch hier die 207 wegpunkte.


    eigentlich müßte ich doch aus google maps eine kml datei erzeugen können. aber ich habe gelesen, dass man eine gpx datei erzeugen soll und dann per GPSBabel in eine kml umwandeln soll. diese dann einlesen. stimmts ?


    Allerdings weiß ich nicht, wie man auf google maps eine gpx datei erzeugt.


    Übrigens:
    Ich habe eine Reihe anderer kml dateien hier auf den rechner. beispielsweise habe ich diese gpx hier
    http://www.hausstrecke.de/atta…remen-stiege-uberland.txt


    (bitte von txt auf gpx umbenennen)


    mit GPSBabel in kml umgewandelt und der GT35 zeigt sie nicht an zum Laden.


    Irgendwie alles ziemlich störanfällig diese Geschichte.


    Aber vielleicht kann mir jemand diese Frage hier klären:


    Allerdings weiß ich nicht, wie man auf google maps eine gpx datei erzeugt.


    Eine Route habe ich gemacht, aber wie kriege ich die downgeloadet ald gpx ?

  • Zitat

    Original von desperate
    okay, danke. die ennstal habe ich vom txt befreit und in userdata/route kopiert. sie steht nicht zu Auswahl zur verfügung. Wird nicht angezeigt.


    Bei mir schon. Vorausgesetzt ist im richtigen Unterordner (siehe oben). ;)


    In der Auswahl steht bei mir "Hauptstrasse - Roseggerstraße, Gröbming -> Scheucher peter julius (Restaurant),....". Am Ende erscheint zur Unterscheidung immer ein kleines hochgestelltes KML, wenn es sich um eine .kml Route handelt.


    Übrigens ein einfaches Konvertierungsprogramm aus diversen Formaten u.a. nach .kml ist ITNConv:


    http://translate.google.com/translate?hl=en&ie=UTF-8&oe=UTF-8&langpair=fr%7Cen&u=http://benichougps.blogspot.com

  • Tja, dann siehts schlecht aus für mich. der richtige ordner ist es ja.


    spricht etwas gegen die Verwendung von GPSBabel ?


    kann mir sonst noch jemand sagen, wie man bei Google Maps eine gpx Datei erzeugt ?

  • Zitat

    Original von desperate
    Tja, dann siehts schlecht aus für mich. der richtige ordner ist es ja...


    Verstehe ich nicht. Die Dateiendung ist aber .kml?


    Da muss etwas mit dem Dateipfad bzw. Ordnernamen des ..\route Unterordners nicht stimmen. Gibt es doch garnicht. Du wärst dann der einzige, bei dem es nicht funktioniert, bei allen anderen schon. Also noch einmal alles überprüfen. ;)


    Die Beispielroute von mir kann ich problemlos auch wieder in ITNConv einlesen. Habe mit ITNConv auch schon diverse eigene Routen erzeugt, nach kml exportiert und in iGO importiert.


    EDIT: mach mal ein Softreset beim GT.

  • Ich schwöre, es ist alles korrekt. Ich bin jetzt echt kein DAU. Das problem mit dem "s" zuviel kann jedem mal passieren.
    Aber ne Datei umbenennen und in den richtigen Ordner kopieren ist kein Problem.


    irgendwas neues zu der gpx datei aus Google Maps ?


    Das wäre noch einen Versuch wert. Dann würde ich in KML umwandeln und das nochmal testen. Mit GPSies kann man keiine gescheite Route planen. Der zeigt immer Luftlinie an, oder man hat Trillionen waypoints.


    Aus Google Maps exportierte KML Dateien werden vom GT-35 auf jeden Fall nicht erkannt.

  • Zitat

    Original von desperate
    ..
    Aus Google Maps exportierte KML Dateien werden vom GT-35 auf jeden Fall nicht erkannt.


    Das kann stimmen. Installiere mal ITNConv (Link im Beitrag oben). Die kml Routen aus ITNConv funktionieren jedenfalls. Die .kml Formate sind eben doch nicht einheitlich.


    ITNConv verwendet übrigens ein Google Maps Frontend und man kann einfache Routen damit planen. Damit sparst du den Umweg über .gpx. Probiere es.


    Der Dateipfad zum route Ordner schaut jedenfalls OK aus. Nichts für ungut. ;)

  • okay, ich habe jetzt die kml von Dir ind ITNconv eingelesen und wieder exportiert und in den route ordner geladen.


    keine Chance. I Nav menue ist die Menuepunkt grau.
    Softreset habe ich gemacht.



    So, dann habe ich meine meiner gpx Dateien (die mit den 207 Wegpunkten aus GPSies) per ITNconv in kml konvertiert und aufgespielt. DIE kann ich wiederum sehen. Bleibt noch das Problem mit den 207 Wegpunkten.


    Jetzt sehe ich nur noch zwei Möglichkeiten:


    a) Entweder mit GPSies gescheite Routen planen, so wie in Google Maps, oder


    b) Ich kriege endlich raus, wie ich aus Google Maps eine gpx Datei rausquetsche. Die kann ich dann via ITNconv in kml verwandeln und aufspielen.


    uff.... oje, oha



    So, jetzt habe ich Deine Ennstal im kml fomat in GPSies eingelesen und als gpx wieder exportiert. diese wieder mit ITNconv in klm zurückverwandelt. Auch ohne Resultat. Wird nicht erkannt

  • Zitat

    Original von desperate
    ..
    So, jetzt habe ich Deine Ennstal im kml fomat in GPSies eingelesen und als gpx wieder exportiert. diese wieder mit ITNconv in klm zurückverwandelt. Auch ohne Resultat. Wird nicht erkannt


    Ich gebs auch auf. Bin mit meinem Latein am Ende. :(

  • Okay Friedrich, ich melde mich doch nochmal.


    Heute bin ich auf der Arbeit und ich hatte hier auf dem PC zwei gpx Dateien, die mir ein Bekannter mal gemailt hat.


    Diese habe ich mit INTconv in kml umgewandelt und ===> Funzt astrein.


    Also habe ich weitergegraben.


    Das Problem für mich ist die Ausgangs-KML Datei aus Google Maps. Aus Google Maps kommt nur Käse. Ich hänge eine Datei an.


    Versuch`die dann mal auf http://www.gpsies.com/convert.do in gpx zu konvertieren.


    Oder nimm ITNconv (der erkennt das Dateiformat auch nicht), oder nimm GPSBabel (das wirft zwar eine gpx Datei aus, aber die sieht dann so aus:


    <?xml version="1.0" encoding="UTF-8"?> <gpx version="1.0" creator="GPSBabel - http://www.gpsbabel.org" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.topografix.com/GPX/1/0" xsi:schemaLocation="http://www.topografix.com/GPX/1/0 http://www.topografix.com/GPX/1/0/gpx.xsd"> <time>2009-10-05T09:44:22Z</time> </gpx>



    Ist also quasi leer.


    Wie kriege ich denn einmal vernünftig ne Route auf Google Maps geplant und in ein sauberes gpx Format konvertiert ?