NAVIPOWM Stabilität

  • Hallo Gemeinde,
    ich nutze seit einiger Zeit NAVIPOWM, zuerst 0.2.3 jetzt 0.2.4 auf einem ASUS PDA 636N mit WM5


    Seit Anfang an habe ich Probleme mit der Stabilität. Während des Betriebes hängt sich das System auf, die Anzeige ist eingefroren, anhand der Uhrzeitanzeige lässt sich erkennen, wann das Programm eingefroren ist. Die Kontrolleuchte für den eingebauten GPS Empfänger blinkt aber weiterhin, und nur ein Aus-Einbau des Akku, mindestens ein Softreset beendet das Programm und lässt weitere Interaktionen zu.


    Das Programm ist auf der SD Karte installiert, zuerst 2 GB dann 4 GB mit dem Update von ASUS der Fehler trat in beiden Fällen auf.


    Der Fehler ist nicht regelmäßig, d.h. er kommt manchmal nach 2 Std oder nach 5 Minuten und nicht reproduzierbar. Aber während einer Fahrt von 4 Std taucht er mindestens 1 mal auf, kann aber auch nach 1 Std und dann alle 5 Min kommen.


    Wer hat (hatte) ähnliche Probleme und wie eventuell behoben?
    Oder funktioniert das bei Euch allen problemlos und ich bin der einzige Mohikaner mit Problemen?
    Habe mittlerweile auch sämtliche Energieeinspareinstellungen ausgeschaltet, Bildschirm etc.


    Ein Versuch mit GPSTacho, auch auf der SD Karte installiert , um die Stabilität des GPS Empfängers sowie Verbindung zur SD Karte zu testen ergab keine Ausfälle über Stunden. Also vermute ich, dass die Hardware läuft. Der Fehler softwareseitig zu suchen ist.

  • ich nutze seit einiger Zeit NAVIPOWM, zuerst 0.2.3 jetzt 0.2.4 auf einem ASUS PDA 636N mit WM5


    Hi, ich entwickle auf einem 632 mit WM5


    Zitat

    Seit Anfang an habe ich Probleme mit der Stabilität. Während des Betriebes hängt sich das System auf, die Anzeige ist eingefroren, anhand der Uhrzeitanzeige lässt sich erkennen, wann das Programm eingefroren ist. Die Kontrolleuchte für den eingebauten GPS Empfänger blinkt aber weiterhin, und nur ein Aus-Einbau des Akku, mindestens ein Softreset beendet das Programm und lässt weitere Interaktionen zu.


    Einfach das Programm mit dem Taskmanager beenden: "Einstellungen / System / Speicher / Ausgeführte Programme"


    Zitat

    Der Fehler ist nicht regelmäßig, d.h. er kommt manchmal nach 2 Std oder nach 5 Minuten und nicht reproduzierbar. Aber während einer Fahrt von 4 Std taucht er mindestens 1 mal auf, kann aber auch nach 1 Std und dann alle 5 Min kommen.


    Wer hat (hatte) ähnliche Probleme und wie eventuell behoben?
    Oder funktioniert das bei Euch allen problemlos und ich bin der einzige Mohikaner mit Problemen?
    Habe mittlerweile auch sämtliche Energieeinspareinstellungen ausgeschaltet, Bildschirm etc.


    Habe das Problem letzte Woche auch einmal gehabt. Ich benutze natuerlich die Entwicklerversion. Keine Ahnung woher es kommt. Ich weiss nicht einmal so richtig, wo ich mit der Suche anfangen soll.


    Zitat

    Ein Versuch mit GPSTacho, auch auf der SD Karte installiert , um die Stabilität des GPS Empfängers sowie Verbindung zur SD Karte zu testen ergab keine Ausfälle über Stunden. Also vermute ich, dass die Hardware läuft. Der Fehler softwareseitig zu suchen ist.


    Muss ein deadlock in der Software sein, weiss aber nicht woher der kommt.


    Julian

  • Einfach das Programm mit dem Taskmanager beenden: "Einstellungen / System / Speicher / Ausgeführte Programme"


    Hi Julian
    Das Dumme ist nur, der PDA reagiert auf überhaupt nichts mehr, weder eine der Funktionstasten wie Bildschirm drehen laut/leise etc, noch auf den Ausschalter. Erst recht nicht auf irgend welche Berührungen des Displays.
    Softreset oder Akku raus ist das Einzige was Wirkung zeigt.


    PS: Ich werde mal den Fullscreen Modus abschalten, vielleicht klappt dann das mit dem Taskmanager.



    Meine Vermutungen zielen in Richtung Verbindung zum GPS Empfänger. Letzthin half zwar Akku ausbauen um wieder das System zu starten. Nur klappte die Verbindung zum GPS nicht mehr, die Einstellungen mussten erst wieder korrigiert werden, erst dann war Empfang möglich. Vorher blinkte zwar die grüne Lampe vom GPS-Empfänger (genau wie beim Einfrieren) aber die Daten kamen offenbar nicht an.


    Wolfgang


    PS: auch die Anzeige der Uhrzeit in NAVIPOWM ist dann eingefroren, d.h. man sieht genau um welche Uhrzeit der Fehler auftrat ;-)

  • Fullscreen abgeschaltet, Fehler kam wie erwartet und reagiert wie erwartet auf keinerlei Eingaben auf dem Touchpad oder an irgendwelchen Schaltern außer der Reset Taste..


    Hallo,


    so ein Verhalten ist mir noch nicht ueber den Weg gelaufen. Meiner Meinung nach liegt es eher am Betriebssystem...


    Julian


  • Hallo,


    so ein Verhalten ist mir noch nicht ueber den Weg gelaufen. Meiner Meinung nach liegt es eher am Betriebssystem...


    Julian


    Hhm, hilft mir zwar im Moment nicht weiter, denn WM 5 haben wir ja wohl beide. Meines seit einiger Zeit mit dem Patch zur Verwaltung der SD Karten größer 2 GB. Aber der Fehler war vorher schon da.


    Ich teste nun mal weiter mit anderen GPS Anwendungen, z.B. GPSTacho ob diese im Langzeitversuch auch irgendwann mal ein derartiges Einfrieren zeigen. Wenn ja, dann wäre es ein Hinweis auf das Betriebssystem. Wenn nein, dann müsste der Fehler doch irgendwo im Zusammenspiel NAVIPOWM-WM5 liegen.


    Vielleicht liegt es irgendwo an Verstellungen im Betriebssystem, ich habe nämlich häufig das Problem, dass sich die Justierung des Touchpad von selbst verstellt. Plötzlich habe ich 1 bis max 2 Buchstaben neben dem Angetippten und muss die Justierung wiederholen.


    Vielleicht hängt es damit zusammen.


    Ansonsten versuche ich noch die Methode der Installation auf einem ASUS 636 (ohne N). Der hat die Probleme mit dem Touchpad nicht.

  • Hallo,
    meine Beobachtungen zum 'Einfrieren' des PNA in Verbindung mit NaviPOWM haben vielleicht einen anderen Grund als das bisher beschriebene Problem.
    Trotzdem will ich meine Beobachtungen beschreiben.
    Zumindest seit NaviPOWM 0.2.3 stelle ich fest - wenn bei NaviPOWM die Option ShowTrackLog = on gesetzt ist - die Postionsanzeige in der Kartenansicht mehr und mehr nachläuft und schließlich irgendwann die Kartenanzeige 'einfriert'. Dann hilft nur noch ein Softreset. Wenn ShowTrackLog = off gesetzt ist, tritt dieses Verhalten nicht auf. Das bisher Gesagte bezieht sich auf Fahrten mit dem PKW.
    Bei einer Fahrradtour habe bisher dieses Verhalten nicht festgestellt. Eigentlich sollte es doch egal sein, ob mit PKW (höhere Geschwindigkeit) oder Fahrrad gefahren wird.


    Gruß
    Dieter

  • Bei mir ist die Option


    ShowTrackLog = off


    Gut wäre die Möglichkeit einen Programmzeiger mitlaufen zu lassen, der permanent in eine Datei schreibt und nur die letzten 20 Schritte speichert, dann wieder den ersten überschreibt.


    Man könnte dann sehen an welcher Programmzeile er hängt und von da die Suche starten, bzw, wenn die Variablenwerte mit gespeichert werden, die Fehlersuche eingrenzen.


    Nur C++ programmiere ich nicht.

  • Hallo Gemeinde,


    nachdem ich mittlerweile auch verschiedene Entwicklerversion ausprobiert habe, waren die Nerven irgendwann am Ende. Zwar kamen in der Entwicklerversion (subjektiv gefühlt) weniger Situationen des "Einfrierens" vor, die nur mit der Reset Taste behoben werden konnten, dafür hat sich das Programm deutlich häufiger (vorher gar nicht) einfach selbst beendet. Nicht immer war es wirklich beendet und noch unter >>Einstellungen>>Speicher>>ausgeführte Programme zu sehen.


    In der Regel half dann aber ein einfacher Neustart von NAVIPOWM. Nervig war es dennoch, denn als "Absturzregel" konnte ich bislang nur wenig ausmachen, der erste Absturz erfolgt meist erst nach mehr als 1 Std (können aber auch 3 Std sein), folgende Abstürze dann aber fast im Minutentakt (1 bis 20 Minuten zufällig)


    Für weitere Tests habe ich zwar NAVIPOWM noch installiert, aber nur mit minimalen Kacheln meiner näheren Umgebung wegen des Speicherverbrauches.


    Bin nun nach einem Versuch mit Gosmore auf NAVIT umgestiegen. Das läuft über Stunden stabil, hat noch keinen Freeze verursacht und bietet die Möglichkeit des Routings sowie der Anzeige der Straßennamen auf der Karte.


    Näheres siehe separatem Thread. Leider ist das wohl hier total unbekannt, obwohl die Brandenburgische Polizei laut einem Bericht auf Heise.de damit arbeiten soll. Forenbeiträge finden sich nur wenige.