Komfortzoom V3b (Pimp it) Update 26.10.2009

  • @ veneto,
    mir ist beim V3-Einbau folgendes aufgefallen:
    <layer ui_NavigateMapZoomControls2D z=50 visiblemodel="ui.vQuickMenu_int=0&!ui.vToolbarSelected&ui.vMapMode_int=1&!u
    i.bLaneinfoSignpostValid">
    ;<BUTTON btnNMC2D_ZoomIn template=btnzoomcontrol x=466 y=49 bmp="ges_zoom1.bmp#3" onClick='START_STOP_ZOOM 0 1' onRelease='START_STOP_ZOOM 0 0' onMouseLeave='START_STOP_ZOOM 0 0'>
    ;<BUTTON btnNMC2D_ZoomOut template=btnzoomcontrol x=466 y=98 bmp="ges_zoom3.bmp#3" onClick='START_STOP_ZOOM 1 1' onRelease='START_STOP_ZOOM 1 0' onMouseLeave='START_STOP_ZOOM 1 0'>
    ; --- G.M. 08/09 Zoombuttons deaktivieren direkt den Smartzoom ---
    <BUTTON btn2dz1 x=418 y=70 z=0 bmp="ges_zoom1.bmp#3" onClick='run sc_GM_SmartZoomDisable, START_STOP_ZOOM 0 1, btnQZ2D.hide, btnAZ2D_Activate.show' onRelease='START_STOP_ZOOM 0 0' onMouseLeave='START_STOP_ZOOM 0 0'>
    <BUTTON xxx x=408 y=35 w=70 h=80 z=0 onClick='run sc_GM_SmartZoomDisable, START_STOP_ZOOM 0 1, btnQZ2D.hide, btnAZ2D_Activate.show' onRelease='START_STOP_ZOOM 0 0' onMouseLeave='START_STOP_ZOOM 0 0'>
    <BUTTON btn2dz2 x=418 y=130 z=0 bmp="ges_zoom3.bmp#3" onClick='run sc_GM_SmartZoomDisable, START_STOP_ZOOM 1 1, btnQZ2D.hide, btnAZ2D_Activate.show' onRelease='START_STOP_ZOOM 1 0' onMouseLeave='START_STOP_ZOOM 1 0'>
    <BUTTON xxx x=408 y=115 w=70 h=70 z=0 onClick='run sc_GM_SmartZoomDisable, START_STOP_ZOOM 1 1, btnQZ2D.hide, btnAZ2D_Activate.show' onRelease='START_STOP_ZOOM 1 0' onMouseLeave='START_STOP_ZOOM 1 0'>
    ; --- G.M. 05/09 zusätzlicher Quickzoom Button ---
    <BUTTON btnQZ2D template=btnzoomcontrol x=491 y=185 bmp="QuickZoom.bmp#3" alpha=21 onClick='START_STOP_ZOOM 1 1' onRelease='START_STOP_ZOOM 1 0, btnQZ2D.hide, run sc_GM_QZoom2D, btnAZ2D_Activate.show' onMouseLeave='START_STOP_ZOOM 1 0'>
    ; --- G.M. 08/09 Zusätzliche Button zum Autzoom ein- und Quickzoom wieder ausschalten.---
    ;<BUTTON btnAZ2D_Activate template=btnzoomcontrol x=491 y=184 bmp="AutoZoom.bmp#3" alpha=21 onClick='btnAZ2D_Activate.hide, btnQZ2D.show, run sc_GotoNavigateMap'>
    <BUTTON btnAZ2D_Activate template=btnzoomcontrol x=491 y=184 bmp="AutoZoom.bmp#3" alpha=21 onClick='btnAZ2D_Activate.hide, btnQZ2D.show, run sc_GM_SmartZoomEnable'>
    </layer>


    und zwar die o.a fettgedruckte zeile, die ist auskommentiert, ist das richtig?


    Gruß
    Max

  • @ veneto,
    so getestet, Resultat, so wie bei Fussel.., der DynZoom regelt in etwa zwischen Maßstab 4500 und 3000, ich dachte auch, dass bei Langsamfahrt in die Karte entspr. reingezoomt wird; übrigens taucht bei mir die rote DynZoom Anzeige nicht auf(inzwischen habe ich grün und rot auf schwarz gesetzt und durch DynZoomOn undOff ersetzt)


    scheinbar macht das V3 irgendwie was es will, (in Karte...., sind Haken Autozoom und Standardwerte gesetzt)


    Abei die beiden UIs

  • wmw
    Hallo,
    möchte mich auch malwieder einbringen.
    Dyn Zoom habe ich noch nicht eingebaut.
    Den Zwischenzielabbruchbutton habe ich genau auf das Ausklappfenster fürdas Zwischenziel gelegt. Geht bestens: Anzeige der Fahrzeit zuklappen und der Zwischenzielabbruchbutton ist sichtbar und kann gedrückt werden.
    Alternativ kann man auch das Zwischenzielzeitfenster wieder ausklappen durch Druck auf den Rand.


    Vielleicht ist das ja eine Anregung für "Skinner"


    Grüsse

  • veneto,
    noch was, wenn man im 2D Modus auf Quickzoom geht, wird auf den Wert, wie in der navigatemap.ui, eingegeben, ausgezoomt, aber nach 10 sek ist alles beim alten, soll heißen, wird wieder zurückgezoomt, soll das so sein?

    Zitat

    zu 5. IGo8\sys.txt Nur wenn zuvor Komforzoom V2 verwendet wurde. Timer wieder auf original Wert setzten! [smartzoom] auto_smartzoom_time=10


    Bleibt dann 2D-Quickzoom nicht mehr länger stehen?


    Beim 3D Quickzoom ists nicht so, der bleibt stehen.


    Was ist, wenn weder DynZoomOn noch DynZoomOff angezeigt wird (ich hab das abgeändert, da rot und grün so schlecht zu sehen waren)
    Irgendwie solltest Du vlt das Ganze genauer beschreiben was wie wann passieren soll ;D


    Gruß
    Max


    Update:
    habe das V3 jetzt ausführlich getestet, Resultat: jedesmal, wenn es eine Weile mal ohne abbiegen zugeht, wird herausgezoomt, egal, ob V > oder < 65 km/h, bei Anzeige DynZoom grün oder rot ist für mich kein System erkennbar, Quickzoom 2D bleibt die in der sys.txt geforderten 10 sek stehen und geht dann auf Default-Autozoom zurück!
    Wie kann ich das so einstellen, dass generll unter 65 km/h voll reingezoomt wird und so bleibt, egal ob Richtungsänderung oder nicht, und zwar solange, bis V > 65 Km/h erreicht wird?
    Das mit dem 2d Quickzoom habe ich gelöst, indem ich den sys.txt Wert wieder erhöht habe.


    oder macht hier SR2 doch ein Problem? (ich hab's drauf)
    Hast Du es drauf?




    Gruß
    M



  • ...rischtisch... Das ist ehem. V2

  • Hi mwm,


    DynZoom V3a kommt. Anfang n.W. Da funzt runterzoomen auch super. (bei mir zumindest).


    Das mit Deinem Autom. rückzoomen hattest Du auch schon vorher. Vielleicht hast in Deinem Skin irgendwo noch nen "Hacken"?
    Andere SR2ler habe die Probleme nicht.


    "dynZoom" ist nur 6 Sekunden sichtbar.


    Zu SR2 kann ich selbst noch nichts sagen. Habs noch nicht drauf... noch keine Zeit dafür.




    Gruß

  • Zitat

    Original von wmw
    @ veneto,
    so getestet, Resultat, so wie bei Fussel.., der DynZoom regelt in etwa zwischen Maßstab 4500 und 3000, ich dachte auch, dass bei Langsamfahrt in die Karte entspr. reingezoomt wird; übrigens taucht bei mir die rote DynZoom Anzeige nicht auf(inzwischen habe ich grün und rot auf schwarz gesetzt und durch DynZoomOn undOff ersetzt)


    scheinbar macht das V3 irgendwie was es will, (in Karte...., sind Haken Autozoom und Standardwerte gesetzt)


    Abei die beiden UIs


    Hallo MWM,


    Ähäm, Dein Script kann so nicht funktionieren! Du Hast ja meine Routinen verdoppelt. Mehrmals 2x der gleiche Scriptname! Das geht mal gar nicht.
    Woher soll das Programm wissen welche es nehmen soll!?


    Nutze mein original das funzt.
    Gruß

  • Zitat

    Original von arnoldsteiner
    Hallo Veneto!


    Kann das sein das das Ve mit SR2 nicht läuft (Z201)? ?(


    Hi Arnold,


    schicke mir mal Deine Dateien...


    P.S. Fussel hat ja auch SR2 und da gings. Nur manchmal mit dem Runterzoomen. Kommt aber...


    Gruß

  • Zitat

    Hallo MWM, Ähäm, Dein Script kann so nicht funktionieren! Du Hast ja meine Routinen verdoppelt. Mehrmals 2x der gleiche Scriptname! Das geht mal gar nicht. Woher soll das Programm wissen welche es nehmen soll!? Nutze mein original das funzt. Gruß


    Ich bin aber genau nach deiner Anleitung vorgegangen, wo ist die Verdopplung, du hast ja meine zwei Dateien



    Gruß
    Max


  • ... wie gesagt. Nutze mein original. Habe gesehen in Deinem Script hast Du meine Funktionen verdoppelt und den Namen somit auch. Das gibt Probleme da keine "Eindeutigkeit" mehr beim Aufruf der Befehle.


    Gruß


  • <script sc_GM_QZoom2D>
    ;.smartzoom.minzoom2d 100
    30 .map.zoom_level 25000
    30 .map.zoom_level 25000
    </script>


    ; --- G.M. 05/09 QuickZoom Aufruf von Button auf 3D Karte ---
    <script sc_GM_QZoom3D>
    30 .map.zoom_level 350
    30 .map.zoom_level 350
    </script>



    ; --- G.M. 05/09 QuickZoom Aufruf von Button auf Karte ---
    ; --- G.M. 08/09 mit direktem Smartzoom Disable ---
    <script sc_GM_QZoom2D>
    run sc_GM_SmartZoomDisable
    30 .map.zoom_level 4500
    30 .map.zoom_level 4500
    </script>


    ; --- G.M. 05/09 QuickZoom Aufruf von Button auf Karte ---
    ; --- G.M. 08/09 mit direktem Smartzoom Disable ---
    <script sc_GM_QZoom3D>
    sc_GM_SmartZoomDisable
    30 .map.zoom_level 350
    30 .map.zoom_level 350
    </script>

  • veneto,
    ich Blödian, habs gesehen, das ist dieser Mist mit "cut & paste" mit zwei Monitoren, kommt man irgendwann mal durcheinander, naja, vier Augen sehen eben doch mehr als zwei, danke für Deine Mühen, ich habs jetzt geändert, Morgen seh ich weiter, obs jetzt beim hochfahren wieder mal "bling" macht, oder nicht,
    Ganz am Ende der Datei war es nochmal drinnen


    hast Du eigentlich SR2 drauf



    Gruß und danke
    MAx