GPSTacho / Z 099

  • Hallo,


    wmw


    du hast den letzten Beitrag geschrieben,aber er erscheint nicht! ?( ?(


    Nochmal .Bitte!


    Edit: heeee was war das denn,erst als ich meinen Beitrag eingestellt habe ,wurde deine Antwort sichtbar! ?( ?(


    Na schön das es funzt und das beides nicht zusammen funktioniert ,erwähnte ich ja!!

  • Hallo Sascha ,
    Du schreibst das es evtl. mit einem Portsplitter funktioniert, (beides nebeneinander laufen zu lassen, wie bei anderen Naviprogrammen),
    Hatte ich auch gedacht und rumprobiert, leider ohne Erfolg.
    Becker-Igo hat sich darauf nicht eingelassen. Änderungen in sämtlichen dafür verantwortlichen *.ini Dateien und in der sys.txt führten nicht zum Erfolg.


    Sollte es jemandem gelingen wäre ich um Mitteilung dankbar


    Gruß Marcel

  • Hallo Marcel,


    ich hatte es auch mal kurz probiert,es aber sehr schnell wieder verworfen,da ich nicht unbedingt die Notwendigkeit gesehen habe beides paralell laufen zu lassen!!

  • das wäre praktisch für die Aufzeichnung von kml- Dateien oder aktuellen Gps-Daten, da die mir die Standortspeicherung im Nachherein keine GPS Daten/ Koordinaten ausspuckt,
    Und wäre auch für den GPS Tacho interessant gewesen.


    Das hat sich ja dank dem GPS on/off von Joshua03 (Joshau Style 1.5) halbwegs erledigt. Dieser ist bei mir installiert und in Ihm befindet sich derSchalter GPS on/off


    Es sollte eigentlich auch möglich sein den GPS Tacho im Z099 (hier gibts ja keinen Games-Ordner) aus Igo heraus nach dem deaktivieren des GPS zu starten, käme auf einen Versuch an.
    ________
    Edit:"ES IST MÖGLICH" wie man auf den Bildern sieht
    ________


    wenn man da (Totalcommander und andere "Systemprogramme" einbinden) mal nachliest, wird man feststellen das ganz unten Blaue Zeilen mit auskommentierten Schaltern zu finden sind.


    wenn man die erste blaue Zeilewie folgt ändert:


    ; <BUTTON xxx template=SettingsMenu_L2 text="Calibration" iconspr="icon_navigation_calibration.bmp#3" onrelease='run sc_SysSetCalibration' nostress=1>


    in


    <BUTTON xxx template=SettingsMenu_L2 text="GPS Tacho" onrelease='START_APPLICATION "\my flash disk\GPSTacho\GPSTacho.exe" ""'>


    Dann sieht das wie unten auf den Bildern aus.


    Für alle die kein PMB und einen anderen Skin installiert haben, und trotzdem den GPSTacho ausprobieren möchten, schreibe ich mal die Zeilen die Ihr ändern müsst aus dem Skin von Joshua03 style1.5 heraus,


    in der ui_becker\480_272\sysset_480_272.ui hizufügen:


    <layer ui_SysSetMenu2 z=30 visiblemodel="ui.vSysSetMenu_Page=2">


    <BUTTON xxx template=SettingsMenu_R1 text="Information" iconspr="icon_navigation_information.bmp#3" onrelease='run sc_ShaderFadein_Nextstate st_SysSetInformation'>
    ;**************************GPS-on/of von Joshua03
    <BUTTON xxx template=SettingsMenu_L1 text="GPS on/off" iconspr="icon_gps_off.bmp" onrelease='run sc_GPSOnOff_On' visiblemodel="!ui.vGpsOnOff">
    <BUTTON xxx template=SettingsMenu_L1 text="GPS on/off" iconspr="icon_gps_on.bmp" onrelease='run sc_GPSOnOff_Off' visiblemodel="ui.vGpsOnOff">
    ;************************************************

    <BUTTON xxx template=SettingsMenu_L2 text="Factory reset" iconspr="icon_navigation_reset.bmp#3" onrelease='run sc_SysSetFactory'>


    und in der ui_becker\common\sysset.ui


    <script sc_AutoOnOff_Off>
    obs_AutoOnOff.STOP
    vSysSetAutoOnOff.SET 0
    .other.becker.power_wakeup_ac_power 0
    </script>


    ;********GPS-on/of von Joshua03
    <script sc_GPSOnOff_On>
    vGpsOnOff.SET 1
    GPS_START
    </script>


    <script sc_GPSOnOff_Off>
    vGpsOnOff.SET 0
    GPS_STOP
    </script>

    ;------------------------------------------------------
    ; Battery



    die angehängten Bitmaps sind ebenfalls von ihm und gehören in den erstellten Ordner "igo8\ui_becker\480_272\

  • Hallo Marcel,


    nehme dir mal "meinen" Skin für den GPSTacho,dann sitzt er auch schön mittig!


    Naja,war klar das man ihn aus igo starten kann,aber ob das sinnvoll ist?! Genauso der TC,wenn ich in den Dateien von iGO etwas ändere,sehe ich das eh erst beim nächsten neustart von iGO,da stellt sich die Frage ob es über ein PmB nicht besser ist!
    Aber das ist wahrscheinlich dann Geschmacksache! ;)

  • Ich persönlich habe ja auch das PMB Megamenü drauf, und bräuchte die Starterei aus igo heraus ja nicht, aber wie das nun mal so ist weißt Du ja selber, dann packt einen der Ehrgeiz wenn man sich eine Vorstellung gemacht hat.


    Man macht sich komischerweise auch den Kopf für andere mit, die Änderungen sind Hauptsächlich für die, die kein PMB drauf haben, und die sachen ausprobieren wollen.
    Ich hab mir das PMB ja aus diesem Grunde draufgetan weiles eben aus IGO heraus nicht möglich WAR.
    Skin wird zu Gemüte geführt thx."Edit":hab ich und Screenshot davon oben dazu getan.

  • Zitat

    Original von samue
    nehme dir mal "meinen" Skin für den GPSTacho,dann sitzt er auch schön mittig


    Hallo Sascha, ich hatte endlich mal wieder etwas Zeit zum Experimentieren und hab nochmal einen Anlauf mit GPS Tacho gewagt. Ja, auf Com2, mit 56700 Baud und RMC als Protokoll und wenn ich vorher GPS in der Navi-SW ausschalte, bekomme ich ein Bild vom GPS Tacho!
    Aber: Alles was ich dann an Untermenüs aufrufe, bleibt irgendwie als verstümmelte Overlays hängen und man weiß bald nicht mehr, wo man überhaupt klicken kann. Beende ich den GPS Tacho sanft und will ihn erneut über den CE Commander starten, hängt sich mein Z099 komplett auf.


    Haste vielleicht noch eine Idee für mich?

  • Hallo Christian,


    das hört sich seltsam an! Nehme dir doch mal den GPS Tache aus meinem PmB,dort ist alles enthalten was normalerweise von nöten ist!


    Da du ja den GPS Tacho aus dem Becker iGO heraus startest,kann es aber auch ein Arbeitsspeicher problem sein! Ich starte den Tacho aus dem PmB und habe keinerlei Probleme damit!!

  • Hallo zusammen,
    ich bin neu und habe mal folgende Frage zum GPSTacho, vielleicht kann ja jemand helfen...


    Programm ohne Probleme auf "Navigon Starter" installiert.
    Empfang alles Super (7-8Sats), leider wird die Geschwindigkeit nicht angezeigt...
    Protokoll der Geschwindigkeit ist VTG.
    Dann habe ich das Protokoll auf RMC (siehe Posting von samue vom 19.02.09) geändert.
    Und... siehe da die Geschwindigkeit wird angezweigt.
    Aber - und das ist jetzt mein Problem - im Stand springt die Tachonadel bis zu Geschwindigkeiten die keiner nachvollziehen kann..., teilweise
    38487705,6 km/h...


    kann mir jemand helfen, bin ich der einzige mit diesem Problem...


    Gruß Willy

  • hallo, hier gehts um IGO software. "Navigon Starter" hört sich sehr stark nach "Navigon" an schau doch mal da rein.





    chk &samue,
    hallo chk,
    Also bei mir läufts aus Igo heraus.
    war das ein Schreibfehlerteufel oder hast du es da so bei Dir stehen?
    baud=56700 dann mach mal baud=57600

  • Hallo Marcel,


    ich denke er hat auch die geänderte GPS.ini benutzt und somit wäre das wahrscheinlich ein schreibfehler!
    Das Problem wird wahrscheinlich sein das er auch den TC aus iGO heraus startet und wenn das System einmal "überlastet" ist,kann es dann ,wenn er versucht dem GPS Tacho aus dem TC zu starten,zum total crash führen!Ist aber nur ne Vermutung!


    willi 1205,


    Möglicherweise hat dein Navi in dem Moment keinen eindeutigen Satfix und somit kommt es zu extremen geschwindingkeitsschwankungen!

  • Zitat

    Original von samue
    ich denke er hat auch die geänderte GPS.ini benutzt und somit wäre das wahrscheinlich ein schreibfehler!


    Danke für den Hinweis, es ist zum Glück nur ein Schreibfehler im Posting, nicht in der ini-Datei.
    Das mit der Systemüberlastung klingt plausibel, aber wenn ich im iGO erst GPS abschalte, dann über TC Resinfo starte um iGO zu beenden und dann denGPS Tacho anwerfe, meckert er jetzt wieder ständig, er könnte COM2 nicht öffnen.


    Schade, ich dachte diesmal klappt es... Soll bei mir wohl nicht sein... :)

  • Zitat

    Original von samue
    willi 1205,


    Möglicherweise hat dein Navi in dem Moment keinen eindeutigen Satfix und somit kommt es zu extremen geschwindingkeitsschwankungen!


    @samue
    hast Du vielleicht eine Idee für mich die ich dieses Problem lösen kann?
    Gruß Willy