.txt - Files automatisch mit Editor verküpfen

  • Hallo,


    wie kann ich die Dateiendung .txt automatisch mit einer Anwendung z.B. UKEditor verknüpfen.
    Registry-Editor habe ich, nur was muss wo wie eingetragen werden ?


    Oder hat jemand 'ne .reg-Datei, die ich importieren kann ?


    Danke Im Voraus

  • Habs nun selber geschafft, die .txt -Files z.B. mit UKEditor zu verknüpfen (über Registry).
    Es wird auch das ICON des UKEditors bei den TXT-Dateien angezeigt.
    Beim Doppelklick auf eine TXT-Datei wird auch der Editor gestartet, aber der bringt ein Popup auf Chinesisch (eckige Kaestchen) und öffnet die Datei nicht. Wenn ich aber mit File-Open das ganze öffne gehts.
    Dies habe ich mit 3 anderen Editoren auch versucht, aber es ist immer dasselbe. Die Meldung sagt immer in etwa, dass die Datei nicht geöffnet werden kann, weil sie evtl. eine Systemdatei o.ä. etc. sei. MitFile-Open gehts aber immer.
    Nur GVPad öffnet die Datei. Der hat aber den Nachteil, dass beim Start immer der Info-Screen eingeblendet wird, welcher einen ewig langen Timeout hat.


    Kennt jemand Abhilfe ??


    Gruss
    Joe

  • Hi,


    also bei mir läut der verknüpfte Editor ohne Probleme und öffnet auch die Datei, die man im Explorer anklickt, mit Notepad und mit UKEditor.


    Welche Eintragungen in die Registry hast du den bis jetzt gemacht ?


    Hast du auch den Default-Text-Editor eingetragen ?
    HKCR
    textfile\Shell\Open\Command
    Default = "UKEditor.exe %1"
    textfile\Shell\OpenDoc\Command
    Default = "UKEditor.exe %1"


    (Hinweis: bei einigen PDA's steht startt textfile nur txtfile )


    Gruß Kuckuck

  • Kuckuck !


    Trage das ganze mit MORTSCRIPT ein :


    1.) "HKCR", ".txt", "default", "txtfile"
    2.) "HKCR", "txtfile", "default", "Text Document"
    3.) "HKCR", "txtfile\DefaultIcon", "default", "\program files\ukeditor\ukeditor.exe,-0"
    4.) "HKCR", "txtfile\Shell\Open\Command", "default", "\program files\ukeditor\ukeditor.exe %1"


    Den Eintrag OpenDoc habe ich nicht !


    Die Anwendung (Editor) wird ja gestartet, nur uebernimmt er mir das Textfile nicht in den Editor !
    Nur bei GVPAd funkts, aber der hat wie gesagt den doofen VersionScreen zu Beginn.


    Gruss
    Joe

  • ich habe den Editor ins \Windows\-Verzeichnis kopiert, ansonsten habe ich die Einstellungen wie oben beschrieben.


    Ich habe das auch mal auf meinem Loox N100 PNA installiert und es läuft problemlos, die Textdadei geht sofort auf und es ist alles zu sehen (und es kommen keine zusätzlichen Fenster).


    Vielleicht ist das bei dir eher ein Problem der zusätzlichen Dll-Versionen (z.B. aygshell) der Desktop-Freishaltung.


    Hast du den wenigesten den fehlenden Eintrag für OpenDoc nachgetragen.