Beiträge von diwo

    Hallo Carsten,


    Zitat

    Original von Northman
    Gab es diese Verfäschungen nicht nur bei MapMerge? (Habe jetzt keine Lust zu suchen... :-) )


    MapMerge und Img2Ozf werden diesbezüglich wohl den selben Code verwenden.


    Ich habe gerade noch mal im Thread geblättert - u.a. hatte Norbert mit BMPs und Img2Ozf Farbprobleme - mit Tif ging es.


    schöne Grüße
    Dieter

    Hallo Carsten,


    Zitat

    Die Kachel-BMPs haben 24bit Farbtiefe. Das MapStitcher-BMP hat nur 8bit Farbtiefe. 8bit ist immer indexed. Die Umwandlung ist nötig, damit das Resultat nicht dreimal so viel Speicher belegt.


    mhm - klingt logisch .....


    Allerdings wird in diesem Thread immer wieder über sporadische Farbverfälschungen durch Img2Ozf geklagt (blättere mal einige Seiten zurück) - als Abhilfe hat sich offensichtlich das TIF-Format bewährt. Rationale Gründe gibt es hierzu nicht - ist eine Eigenart des Img2Ozf.


    Ich wandle die Mapstitcher-PMB nach RGB um und speichere dann als TIF (ist dann wirklich ca. 3x so groß). Ist trotzdem noch x-mal schneller als über MapMerge.


    schöne Grüße
    Dieter

    Zitat

    Original von fjung
    Mein Ansatz ist:
    1. Umwandeln nach RGB .......


    Nach kurzer Pause habe ich nun wieder mit dem Kartenexport fortgesetzt .....
    hatte aber nun massive Farbfehler (obwohl ich mit TIFs arbeite). Erst dachte ich, dass IMG2OZF Probleme mit großen Dateien hat, aber .......


    carsten
    Die von Norbert erzeugten Kachel-BMPs haben das Farbmodell RGB - die vom Mapstitcher gestitchten BMPs sind "Indexed Colors"!


    Nach dem Wandeln des Farbmodells und speichern als TIF, stimmen bei Img2Ozf die Farben wieder.


    Wie kommt das geändert Farbmodell zustande?


    ciao
    Dieter

    Hallo *.*,


    ich habe nun ausgiebig mit der "Straßen meiden"-Funktion gearbeitet.


    Die Kategoreienverwaltung ist ziemlich buggy!


    Ich kann nicht nachvollziehen ab wann es eingesetzt hat - Kategorien umbenennen oder löschen ....


    Jedenfalls steht danach die Kategorienverwaltung auf dem Kopf - es ergibt sich folgendes Fehlverhalten:


    1. In der Kategorienübersicht sind Kategorien vorhanden, die aber beim Ändern der Straßen in der Klappliste der Kategorien nicht mehr auftauchen


    2. Werden Straßen/Objekte dieser "defekten" Kategorien geändert, so sieht man, dass sie der Kategorie "Standard" zugeordnet sind, wobei sie unter der "defekten" Kategorie aufgelistet sind.


    3. Normalerweise wird beim Ändern der komplette Kartenobjektname angezeigt. Nachdem die Kategorien angeknackst sind, werden entweder nur noch die Koordinaten, einige Hochkommas oder der Objektname der Hometaste angezeigt.


    Die Sperrung der Objekte scheint weitestgehend auch noch zu funktionieren, wenn als Kartenobjektname nur noch Hochkommas angezeigt werden.


    Ich habe schon alle Objekte und danach die Kategorien geslöscht - anfänglich war noch alles OK aber nach X Einträgen geht das Theater wieder los.


    Update? - wozu Update? - Sorry, aber soviel Sarkassmus muss sein!


    Warum gibt es keine FAQ, in der man aufgeklärt wird, dass man von den Kategorien besser die Finger weglassen soll?


    ciao
    Dieter

    Hallo *.*,


    ich habe nun ausgiebig mit der "Straßen meiden"-Funktion gearbeitet.


    Die Kategoreienverwaltung ist ziemlich buggy!


    Ich kann nicht nachvollziehen ab wann es eingesetzt hat - Kategorien umbenennen oder löschen ....


    Jedenfalls steht danach die Kategorienverwaltung auf dem Kopf - es ergibt sich folgendes Fehlverhalten:

    1. In der Kategorienübersicht sind Kategorien vorhanden, die aber beim Ändern der Straßen in der Klappliste der Kategorien nicht mehr auftauchen


    2. Werden Straßen/Objekte dieser "defekten" Kategorien geändert, so sieht man, dass sie der Kategorie "Standard" zugeordnet sind, wobei sie unter der "defekten" Kategorie aufgelistet sind.


    3. Normalerweise wird beim Ändern der komplette Kartenobjektname angezeigt. Nachdem die Kategorien angeknackst sind, werden entweder nur noch die Koordinaten, einige Hochkommas oder der Objektname der Hometaste angezeigt.


    Die Sperrung der Objekte scheint weitestgehend auch noch zu funktionieren, wenn als Kartenobjektname nur noch Hochkommas angezeigt werden.


    Ich habe schon alle Objekte und danach die Kategorien geslöscht - anfänglich war noch alles OK aber nach X Einträgen geht das Theater wieder los.


    Update? - wozu Update? - Sorry, aber soviel Sarkassmus muss sein!


    Warum gibt es keine FAQ, in der man aufgeklärt wird, dass man von den Kategorien besser die Finger weglassen soll?


    ciao
    Dieter


    Oh Sorry - Ich habe diesbezügliche Beiträge gesucht und gefunden und geantwortet - jetzt registriere ich, dass ich im "Destinator PN"-Forum antworten wollte.

    Hallo Norbert,
    Hallo Carsten,



    Zitat

    Original von diwo
    Das Speichern könnte sich möglicherweise als etwas gefährlich erweisen, falls man nicht die HD-Kontollleuchte beachtet und das Fenster schließt, denn NH-Top50trans meldet, dass der Export beendet wäre. Vielleicht lässt sich hier noch etwas einbauen - entweder wartet NH-Top50trans bis der Mapstitcher vollkommen fertig ist, oder im DOS-Fenster wird noch ein eindeutiger Text angezeigt.


    Das Speichern des Mapstichers ist noch aus einem anderen (ernsthafteren) Grund gefährlich.


    Bei mir wurde der Kartenexport wieder mit "Konnte Karte nicht erstellen" (oder so ähnlich) abgebrochen. Ein Blick auf die Zeitstempel der Dateien zeigte, dass NH-Top50trans bereits während des Speicherns der Mapstitcher-BMP mit dem Export eines neuen Kartenteils und den entsprechenden Kacheln beginnt. Wenn nicht Power bis zum Abwinken zur Verfügung steht, ist dies natürlich problembehaftet. Es sieht aus, als ob hier das handshaking zwischen NH-Top50trans und dem Mapstitcher verbessert werden muss.


    nichtsdestotrotz bin ich begeistert :D


    schöne Grüße
    Dieter

    carsten ,

    Zitat

    Original von Northman
    Wenn es eins gibt, daß ich hasse, dann sind es Programme die viel machen, aber nicht angeben, wieviel sie schon geschafft haben und wie lange es ungefähr noch dauert :-)


    Genau dieses Problem kann man beim Speichern großer gemapstitchter Karten haben. Das Speichern meiner 81x75km Karte dauerte ungefähr 5 bis 8 Minuten. :gap


    LeGro

    Zitat

    Original von LeGro
    Wäre es dir - vielleicht zusammen mit EnHa - nicht auch möglich, aus den vielen *.map Dateien eine *.ini Dateierstellung mit aufzunehmen. Dann könnten wir MapMerge endgültig in den Bytehimmel schicken.


    Mhm - die Ini-Datai wird doch erzeugt - oder meinst du etwas Anderes?


    ciao
    Dieter

    Hallo Norbert,
    Hallo Carsten,


    für mich ist nun der Durchbruch erreicht : drink


    Mit der Developmentversion kann ich nun die Option "normal" (schnell) nutzen - für die Verhältnisse meines PCs geht NH-Top50trans nun ab wie Schmitts Katze :)


    .... und dazu der Mapstitcher von Carsten ......... :]


    Habe gerade eine Karte 81x75km exportiert (32.288x29.948 Pixel).
    Der Mapstitcher hat dazu 16 Minuten 52 Sekunden gebraucht - dazu kommt aber noch die Zeit zum Speichern der 1,1GB-Datei und noch Img2Ozf - aber alles kein Vergleich zur MapMerge :D


    Das Speichern könnte sich möglicherweise als etwas gefährlich erweisen, falls man nicht die HD-Kontollleuchte beachtet und das Fenster schließt, denn NH-Top50trans meldet, dass der Export beendet wäre. Vielleicht lässt sich hier noch etwas einbauen - entweder wartet NH-Top50trans bis der Mapstitcher vollkommen fertig ist, oder im DOS-Fenster wird noch ein eindeutiger Text angezeigt.


    Ich bin schlichtweg begeistert - merci : drink
    Dieter

    Editiert ....
    Bitte alles vergessen - ich habe die OVLs nicht als ASCII gespeichert :wand


    @All,


    ich habe mir meine Top200-Karten herausgekramt und dort Overlays für meinen MagicMaps-Export eingezeichtet und gespeichert.


    So wie ich es verstanden habe, sind in der OVL-Datei die Koordinaten der entsprechenden Rechtecke eingetragen.


    Diese OVL-Datei möchte ich nun für den MagicMaps-Export verwenden.


    In NH-Top50trans wähle ich deshalb den Menübefehl Eingang > Top50 OVL und wähle das Overlay aus. Bei der Anzahl der "eingelesenen Flächen" steht "0" - die Auswahl einer alternativen Karte ändert nichts ....


    Was mache ich falsch - oder habe ich einen falschen Ansatz?


    ciao
    Dieter

    Hallo Norbert,
    Hallo Carsten,


    ich nehme an, die korrekte Einstellung in NH-Top50trans ist:


    ++++++++++++++++++++
    Karten exportieren mit:


    NH-Top50trans


    x Ozi MapMerge -- x MapStitcher !?!?


    .......
    ++++++++++++++++++++


    Der Ozi MapMerge spielt nun aber gar nicht mehr mit!


    Logisch wäre doch nun, den MapSticher nicht über eine Check-Button sondern über einen Options-Button (NH-Top5trans, Ozi MapMerge, MapStitcher, Photoshop) auszuwählen?


    schöne Grüße
    Dieter


    PS: Hallo Norbert ....
    Könnte man den Textzusatz (siehe Anlage) wieder löschen?
    Ich hab diesen Wert anfänglich eisern auf 1 belassen und keinen Erfolg gehabt.

    Hallo Northman / Carsten,


    Zitat

    Original von Northman
    Generell: um mein Tool benutzen zu können brauchst Du die Developerversion von NH-Top50Trans, denn nur diese erzeugt die neuen INI-Dateien, mit denen Du mein Tool fütterst.


    das war mir schon klar .....


    Zitat

    Original von Northman
    Es tut mir leid, aber Du mußt Deine Karte nochmal exportieren um mein Tool benutzen zu können.


    Nun - die Entscheidung zu 20x20km-Karten war eher ein Kompromiss wegen der langen MapMergezeiten - so glücklich bin ich mit den kleinen Karten nicht.


    Also MUSS ich nicht - ich WILL eher :D



    Zitat

    Original von Northman
    TIFs werden nicht zusammengesetzt .......


    Ist ja kein Problem - die gestichte Karte lässt sich ja auch danach bearbeiten.



    Zitat

    Original von Northman
    Ich hoffe, ich konnte mich verständlich ausdrücken :-) Wenn nicht: einfach nochmal nachfragen :-)


    aber claro


    merci
    Dieter

    Hallo Cartsen,


    ... jetzt muss ich wieder von vorn anfangen ...... ;)


    NEIN - ich will von vorn anfangen ... :D


    Ich mühe mich seit Wochen herum die Bayern3D-Karte zu exportieren. Da ich kein Photoshop CS habe, schlage ich mich mit dem grottenlahmen MapMerge herum, dass auf meinem System gerade mal 20x20km Karten in einigermaßen vernünftiger Zeit zusammenfügt. Ich habe trotz Einsatz von bis zu drei Rechnern gerade mal 1 / 4 von Bayern geschafft - auch ist die Verwaltung der vielen 20x20km Karten ziemlich mühselig.


    Da kommt mir dein Tool gerade recht - ich fang also noch mal an.... werde am Wochenende mal testen :D


    Da ich nicht mit Photoshop CS arbeite, kenne ich auch nicht den diesbezüglichen Ablauf.


    Soweit ich aus den Forumsbeiträgen entnommen habe, kann NHTop50Trans in diesem Fall TIFs erzeugen, die von Photoshop zusammengefügt werden. Fügt dein Programm auch TIFs zusammen oder nur BMPs?


    schöne Grüße
    Dieter

    Zitat

    Original von roland110
    Hat jemand Ahnung - ich konnte im Forum nichts konkretes finden !


    Liegt möglicherweise daran, dass es keine Probleme mit dem DeltaX und DPN gibt (so wie bei mir).


    Viel hast du noch nicht erzählt:


    Was läuft sonst noch auf dem DeltaX?
    Hast du schon einen Hardreset durchgeführt?
    Wo hast du Desti installiert?
    Auf welcher Karte du die Desti-Karten installiert?
    Mit welchem Cardreader Hast du die Karten installiert?


    ciao
    Dieter

    Zitat

    Original von Klaus-M
    geht ganz einfach: Einmal im Menüpunkt "Str. meiden" bei Kategorie Standard auf meiden drücken und anschließend wieder auf nutzen. Damit werden auch temporäre Sperrungen wieder aufgehoben.


    mhm - ist aber der gleiche Effekt, als wenn ich die Route lösche und neu anlege - es werden immer alle Teilsperrungen gelöscht - nicht nur die letzte Sperrung.


    ciao
    Dieter