Beiträge von siyman

    Ist zwar alt, aber ich empfehle den MapFactor Navigator free. Mittels MortScript funktioniert das ganze wunderbar, ohne direkt am System rumfummeln zu müssen. Damit rennt das PNA wie eh und je mit aktuellen Karten. Und sollte einem die Navigation nicht ausreichen (manchmal eingeschränkt/keine Adresssuche), so kann man sich die proprietären Karten dazukaufen. Im Vergleich zu einem neuen System allemal günstiger.

    Ist zwar schon etwas älter, aber du hast folgende Vorgehensweisen:


    Wenn du das Gerät mit deinem PC verbindest, aber keine Verbindung entsteht, so liegt das sicherlich daran, dass der Hersteller die ActiveSync-Schnittstelle deaktiviert hat. Du kannst dennoch versuchen, ActiveSync (XP, unter Vista und 7 glaube ich Mobility Center oder so) zu installieren und zu testen, ob du auf das Gerät kommst. Sollte dem nicht so sein, gibt es für die meisten Hersteller aber trotzdem eine Alternative. Bei meinem Becker muss ich dreimal auf das Navigon-Logo in den Systeminformationen klicken und komme so in die Windowsoberfläche.
    Bist du dort angelangt, kannst du bspw. versuchen, dir von MapFactor den Navigator Free 11 herunterzuladen. Ansonsten müsste aber auch Garmin oder iGo auf deinem Gerät funktionieren.

    Liebes Forum,


    ich bin im Besitz es hornalten Becker TA Pro 7916 und wollte das Gerät wenigstens halbwegs Autotauglich machen, weswegen ich versucht habe, MapSource Navigator Free darauf laufen zu lassen. Weil dies nicht geklappt hat, war ich in der Hoffnung, mittels MioPocket 4.0 entsprechende Bibliotheken nachladen zu können, sodass alles läuft - aber Fehlanzeige.
    Leider war ich nicht ganz so schnell beim Lesen, weshalb ich vergessen habe, das automatisch generierte Registry-Backup vom MioPocket 4.0 zu sichern, sondern habe es gelöscht. Beim Becker ist aber die Windows-Registry beschreibbar, weshalb ich nun vor einem halbwegs unbenutzbaren System stehe, bei welchem nach gut einer Minute Benutzung die komplette WinCE-Oberfläche einfriert.


    Daher meine Frage/Bitte: Besitzt jemand hier im Forum das gleiche Navi und könnte ein Backup der Registry ziehen und es mir zur Verfügung stellen? Insofern wäre dies kein Rechtsbruch, da ich das Gerät selbst besitze, um etwaigen Anfragen vorzubeugen. Ich bin mir nur zu 99% sicher, dass Becker diesen Service für mich nicht erledigen möchte.



    Ich wäre euch wirklich überaus dankbar!
    Grüße
    siyman :whistling:

    Also ich habe nun nach einem Paket Namens 'Windows_CE_5.0_system_files.rar" ausschau gehalten, die DLLs hieraus kopiert und in's Programmverzeichnis NavFree gehauen. Hier bekomme ich abermals die Meldung, dass die Anwendung keine WinCE-Anwendung wäre. Lösche ich die entsprechenden Libs aus dem Verzeichnis, so fehlen einige Dateien.
    Ich kann mir keinen Reim darauf machen, welche exotischen Versionen/Bibliotheken die navigator.exe benötigt, wenn es bspw. auf Medien GoPals läuft, welche vom Kern nahezu identisch zu meinem Becker 7916 sind. Könnte denn einer mal ein DLL-Paket schnüren, in welchem alle Libs sind, mit welchen das Programm läuft, damit ich das testen kann, ob es tatsächlich daran liegt? Das wäre wunderbar, da man das Becker nicht mit einem Custom Rom flashen kann.


    Übrigens ist ein HardReset auch beim Becker nicht möglich - die MioPocket 4.0 Installation residiert teilweise im System, was für mich völlig unverständlich ist, da man eigentlich nichts ins Rom schreiben kann. Derzeit habe ich also eine Reihe an verschiedenen Softwaretastaturen, welche ich nicht entfernt kriege, sowie den Maus-Ladecursor, welcher auch nicht mittels Deinstallation entfernt werden kann. Irgendwie nervt das alles nur noch. Auch kann ich die core_dl.dll aus dem MioPocket aus meinem Interal Storage nicht entfernen, obwohl dieser eigentlich beschreibbar ist.

    Mittels CEE-Explorer habe ich herausbekommen, dass die Libs aus dem MioPocket 4.0 Paket alle als Architektur ARM Thumb stehen haben - sicherlich kann ich hier schon einmal etwas umändern. Allerdings sind derzeit ein paar DLLs in meiner Windows Verzeichnisstruktur und ich weiß leider nicht, wie ich diese da wieder herausbekomme.
    Vielen Dank für die nützlich Tipps - sobald ich etwas neues erfahre, melde ich mich!

    Vielleicht etwas alt, aber ich renne mit einem Becker 7916 herum und habe ebenfalls WinCE 5.0. Nachdem ich mir die entsprechenden DLLs aus einem alten Diskdump gezogen habe, meckert mich der Navigator trotzdem an, dass er keine WinCE-Anwendung wäre. Ich hab ebenfalls schon versucht, mittels UPX die Datei entsprechend zu verkleinern, was bei iGO8 zum Erfolg führt, aber hier ändert sich nichts - die Software kann nicht ausgeführt werden.
    Jemand eine Idee/Alternative?