Beiträge von cyc1982

    Zitat

    Original von aurum97
    es scheint nicht möglich zu sein, den PoiWarner mit der Software des 8110 zu starten. Mir ist es jedenfalls bisher nicht gelungen. Deshalb ist wohl der Weg, der von BohrokKaita vorgeschlagen wurde der einfachere und deshalb bessere Weg.
    Es tut mir leid, dich auf eine Fährte gelockt zu haben, die dir nur Arbeit für wenig bis nichts einbringt. :-D)


    Sicher ist das der einfachere Weg! Und wenn du damit leben kannst, stelle ich erleichtert weitere Arbeiten ein. Auf den ersten Blick schien es für mich ganz einfach zu sein deinen Wunsch zu realisieren. Doch jetzt, wo ich schon etwas weiter gedacht habe, stellen sich doch ein paar kleine Probleme ein, welche nicht so einfach zu lösen sind.



    Zitat

    Original von Ladgaz
    weiss hier jemand, wie ich das Tools-Menü dazu bringe, nach Start einer Anwendung wieder komplett einzufahren?


    Wieder mit einem Script:


    If (ProcExists("SystemInformation.exe"))
    Kill("SystemInformation.exe")
    EndIf
    RunWait("\PFAD\PROGRAMM.exe")
    Run("\Storage Card\MNChoice\SystemInformation.exe")



    Daran denken, hinterher in der tools.ini die script-EXE einzutragen.


    Funktioniert aber nicht, wenn man z.B. die autorunce.exe von Navigon aufruft, weil diese nur eine oder mehrere andere EXE-Dateien startet und sich dann sofort selbst beendet. Folglich wird das Menü gleich wieder gestartet.


    Mit MortScript kann man eine Menge machen...einfach mal in die Dokumentation von MortScript schauen.



    Zitat

    Original von andy1
    kann denn bitte einer die beiden Bilden sprich BMps machen von Restart und Poweroff.exe


    Ja gerne, stelle ich morgen rein.



    Zitat

    Original von Dizzy74
    Kann man denn nur das toolsmenü in das haupt-navigonmenü einbinden?


    Das ist mit den einfachen Mitteln, die uns zur Verfügung stehen, leider nicht möglich.




    Gruß


    cyclone

    aurum97


    Muss jetzt leider los, deshalb wird das heute nix mehr. Hab aber schon mit den Buttons angefangen...ist morgen fertig, OK?




    Zitat

    Original von Ladgaz
    Kann man eigentlich die Position des winzigen Vierecks, um zum Auswahlmenü zurückzukommen auch verändern?


    Nein, das ist leider nicht möglich...ich gehe davon aus, dass sowohl die Position, als auch die Darstellung in irgendeiner der *.res-Dateien definiert ist. Leider sind diese Dateien nicht so einfach zu knacken :(



    Zitat

    Original von Dizzy74
    Das würde mich auch interssieren. Ich komme aus der navigonsoftware nicht mehr zurück, ohne einen softreset mit dem stylus durchgeführt zu haben.


    Steht in dem von dir zitierten Beitrag und ein paar Beiträge weiter...einfach weiterlesen.



    Zitat

    Original von Ladgaz
    Suche selbst noch eine Möglichkeit, die Tastatur gemeinsam mit TC zu starten.


    Probiere Folgendes:


    1. Erstelle im Ordner .\MNChoice\Scripts eine Textdatei mit einem bestimmten Namen z.B. "tc_keyb.txt"
    2. Öffne die Datei im Notepad
    3. Füge folgende Zeilen hinzu:


    Run("\Storage Card\MNChoice\...\ToggleInputPanel.exe") (Die Punkte "..." durch den entsprechenden Pfad ersetzen!)
    RunWait("\Storage Card\MNChoice\Tools\TotalCommander\TotalCommander.exe")
    Run("\Storage Card\MNChoice\...\ToggleInputPanel.exe")


    4. Speichern unter... wählen und im Dialog ganz unten bei Codierung "Unicode" wählen.
    5. Die Datei in "tc_keyb.mscr" umbenennen.
    6. Nimm eine der vorhandenen *.exe-Dateien (außer MortScript.exe!) erstelle eine Kopie
    7. Benenne die Kopie um in "tc_keyb.exe"
    8. Wenn du jetzt die "tc_keyb.exe" aufrufst, wird das Script ausgeführt, also...
    9. In der tools.ini im entspechenden Eintrag die Zeile bei Command das Verzeichnis \Storage Card\MNChoice\Scripts\tc_keyb.exe eintragen.
    10. Fertig


    Nicht getestet, sollte aber den gewünschten Effekt erzielen.



    Gruß


    cyclone

    Zitat

    Original von aurum97
    Die Startdatei liegt nornalerweise im Root und heißt bisher immer Updateme.exe.


    OK, aber ich glaube diese UpdateMe.exe des POIWarners ist in wirklichkeit nur eine kompilierte Batchdatei. Irgendwo muss ja auch ein POIWarner-Verzeichnis sein, in welchem die POI-Dateien liegen. Dort müsste die richtige POI-Warner EXE liegen.



    Gruß


    cyclone

    Zitat

    Original von aurum97
    Das müsste doch mit wenig Aufwand zu perfektionieren sein, man braucht eben jeweils die Updateme.exe, die den PoiWarner für das 8110 startet und die UpdateMe.exe für das 8310.
    Für Könner müsste das doch elegant zu realisieren sein.


    Ich mach das gerne für euch...aber ich habe den POI Warner nicht :(


    In welchem Ordner liegt die auszuführende EXE normalerweise und wie heißt sie genau? Ich werde das dann direkt auf die großen Buttons legen. Der POI-Warner wird dann also direkt mitgestartet.


    ODER


    Soll wollt ihr einen neuen Tools-Eintrag für den POI-Warner, mit neuem Icon etc.?




    Zitat

    Original von Ladgaz
    Wenn Du nichts dagegen hast, würde ich die Dateien als MNChoice_4.zip hochladen für alle, die diese Variante wünschen.


    Warum sollte ich was dagegen haben? ;D


    Aber wenn möglich, nenn die Datei irgendwie anders, meinetwegen MNChoice_Ladgaz1.zip oder so ähnlich. Dann kann ich meine Versionierung weiterführen.




    Gruß


    cyclone

    Zitat

    Original von BohrokKaita
    Auch nicht in "\My Flash Disk\MN Settings"? Dort liegt sie zumindest bei meinem Upgrade 8310.


    Dort liegt sie definitiv...hatte es in meiner Anleitung leider falsch angegeben - hatte es eilig, Sorry. Ist nun aber berichtigt.



    Gruß


    cyclone

    Hab es gerade getestet und funktioniert.


    Folgendes hab ich gemacht:


    1. Datei heruntergeladen
    2. Auf dem PC ausgeführt
    3. Die CAB Datei auf dem PC mit MSCEInf (WinCE CABs Analyzer) geöffnet
    4. Im MSCEInf ist in der Toolbar ein Button, auf welchem ein Ordner (mit einem blauen Schriftzug "SEL") abgebildet ist. Darauf klicken.
    5. Alle Dateien wählen
    6. Extrahieren
    7. Zielordner wählen und bestätigen
    8. Die Dateien im Ordner <Zielordner>\Program Files\TCPMP nach .\MNChoice\Tools\Player kopieren.
    9. tools.ini entsprechend anpassen ("Command = \Storage Card\MNChoice\Tools\Player\Player.exe")
    9. Reset
    10. funzt!



    Gruß


    cyclone

    Zitat

    Original von andy1

    Nee hilft nicht mache immer resets grundsätzlich bei solchen sachen und laut meldung isses auch kein nicht rest Fehler nur weiss ich nicht weiter weil ich keinen Player kenne der drauf läuft


    Dann wirst du die falsche Version haben, ober die Datei ist beschädigt.

    Zitat

    Original von cyc1982
    Habe es mit der 8310SW noch nicht getestet, aber bei der 8110SW erscheint im Hauptmenü oben links ein kleines Quadrat. Wenn man einmal darauf tippt, wird es Orange...beim zweiten Mal wird die Soft beendet. Denke, dass es beim 8310 ähnlich ist.


    Ach ja, zusätzlich muss in der UserSettings.xml beider SW-Versionen der XML-Knoten <DevModeState> auf 1 gesetzt werden, sonst wird nichts angezeigt!

    Zitat

    Original von andy1
    vieleicht kannst du mir ja weiter helfen in dem neuen >Script 3 is ein Button MediaPlayer aber im ordner MNChoice kein Ordner dergleichen sind dieselben drei wie in der 2 drin nun habe ich nen ordner MediaPlayer benannt und die exe des Proggis TCPMP Player in Player und auch in MediaPlayer.exe versucht aber es kommt doie fehlermeldung das eben kein Programm gefunden wird wenn ich im Menü auf den Player Button klicke


    Das ist gar nicht so schwer:


    Im Ordner .\MNChoice\Config liegt eine Datei namens tools.ini.
    Dort den entsprechenden BITMAPBUTTON-Eintrag suchen. Derzeit steht da "Command = \Storage Card\MNChoice\Tools\Player\Player.exe". Einfach in "Command = \Storage Card\MNChoice\Tools\MediaPlayer\MediaPlayer.exe" ändern und speichern.



    Gruß


    cyclone

    Entschuldige.


    Habe es mit der 8310SW noch nicht getestet, aber bei der 8110SW erscheint im Hauptmenü oben links ein kleines Quadrat. Wenn man einmal darauf tippt, wird es Orange...beim zweiten Mal wird die Soft beendet. Denke, dass es beim 8310 ähnlich ist.



    Gruß


    cyclone

    Ein weiteres Update:


    - Scripte ein wenig angepasst
    - Bisherige Tool-Buttons etwas überarbeitet
    - Zusätzliche Buttons im Ordner .\MNChoice\Images\ExampleButtons hinzugefügt



    Zitat

    Original von Ladgaz
    könnte man nicht auch eine BMP-Datei mit Videoplayersymbol statt 8110-Symbol bekommen?


    Liegt in der aktuellen MNChoice_3.zip im Ordner .\MNChoice\Images\ExampleButtons



    Zitat

    Original von BohrokKaita
    Einen kleinen Verbesserungsvorschlag hätte ich noch zur Anleitung unten. Ist zwar eigentlich selbstredend, aber sicher ist sicher...


    Vielen Dank. Habs aktualisiert.



    Zitat

    Original von digi-daddler
    beim ersten Starten der Optionsanwendungen habe ich gesehen, dass unten eine Leiste auftauchte, mit der man z.b. umschalten konnte und eine Tastatur aufrufen, auch waehrend der Navianwendung.
    Dies habe ich nicht wieder reproduzieren koennen, finde diese Moeglichkeit einfach nicht mehr.


    Wie macht man das ?( Und welches Programm ist dafuer verantwortlich?


    Das kann ich mir nicht erklären, aber es gibt ein Tool von Daniel Schumann (ToggleInputPanel.exe) auf der Webseite www.ultimatelaunch.de. Zusammen mit QuickLaunch (Ebenfalls von Daniel Schumann) ließe sich das realisieren.



    Zitat

    Original von andy1
    Gibts auch andere Tachos ,habe sowas mal ich glaube auf Medion Geräten gesehen also Digitale und Grafisch ein bischen mehr ?


    Und lässt sich der Tacho garnicht auf komplett nur DIGI Tacho Umstellen ?


    Ich habe mich leider noch nicht so sehr mit GPSTacho beschäftigt, aber dieser lässt sich durch Bearbeiten der INI-Dateien und eigenen Grafiken ebenfalls optisch aufwerten. Wenn es bereits fertige Skins gibt, dann weiß ich leider nicht wo. Sorry.



    Zitat

    Original von Ladgaz
    Wie komme ich aus der jeweiligen Navisoftware-Version 8110/8310 wieder zurück in das Auswahlmenü?


    Entweder durch einen Softreset oder, und das erfordert etwas technisches Verständnis, durch bearbeiten der ApplicationSettings.xml beider Softwareversionen. Die XML des 8110 liegt auf der Flashdisk unter .\NAVIGON\Settings und die des 8310 unter .\NAVIGON\MN Settings.
    Dort den vorhandenen XML-Knoten <ExitBehaviour>...</ExitBehaviour> durch <ExitBehaviour>3</ExitBehaviour> ersetzen.



    Bearbeiten auf eigene Gefahr!


    EDIT:
    Sorry, natürlich liegt die usersettings.xml des 8310 auf der Flashdisk unter .\NAVIGON\MN Settings .



    Gruß


    cyclone

    Hmmm...ich vermute, deine Sicherung hast du mit Fresh erstellt?


    Auf der SD-Karte sind definitiv mehr Ordner. Hast du mal eine manuelle Sicherung gemacht, also die SD-Karte mithilfe des Explorers komplett auf die Festplatte kopiert? Oder hast du evtl. noch die original SD-Karte?


    Das Menü wird ohne die Ordner zwar trotzdem funktionieren, aber du wirst die 8110SW entweder gar nicht starten können, oder es werden Fehler auftreten. :(


    Gruß


    cyclone

    UPDATE


    Auf Wunsch einiger User, habe ich ein paar Änderungen vorgenommen und stelle sie euch im ersten Beitrag dieses Threads zur Verfügung (MNChoice_2.zip).


    Viel Spaß




    Zitat

    Original von Navikind
    womit hast du die silbernen Buttons aus dem 8110 fotografiert oder extrahiert?


    Mit einem Screenshottool (psc.exe; ist in der MNChoice_2.zip aus meinem ersten Beitrag enthalten) geschossen und mit Photoshop zu einem Blanko verarbeitet.



    Zitat

    Original von Ladgaz
    könnte man nicht auch eine BMP-Datei mit Videoplayersymbol statt 8110-Symbol bekommen?


    Ich werde bei Gelegenheit die Blanko-Buttons (BMP & PSD) hier hereinstellen, aber nicht mehr heute - sorry.




    Gruß


    cyclone

    Zitat

    Original von Bubber
    Könnte das Menu auch beim 7210 / 7310 funktionieren ?
    Oder ist das absolut nur für die 8xxx Geräte ?


    Diese Version ist nur für 8310 Upgrade User. Für das 7210/7310 müssten sicher ein paar Dateien angepasst werden. Da ich aber leider kein 7210 mit Upgrade besitze, kann ich das nicht bewerkstelligen. :(



    Zitat

    Original von Kalle51
    Wieviel Speicherbedarf ergibt sich bei dieser Anwendung insgesamt?


    Das kann ich dir leider noch nicht sagen, aber ich habe bisher noch keine Performanceprobleme festgestellt, jedoch bedeutet dies nicht, dass dies noch auftreten kann.



    Gruß


    cyclone