Beiträge von PC-Mike

    Hallo,


    bin gerade schier am Verzweifeln mit diesem Ovi-Programm.


    Hintergrund: ein Freund hat mich gebeten, für sein schon etwas älteres N95 (nicht N95 8GB) die Navigation einzurichten, er bekommt es nicht hin.
    Also gut, kann ja nicht viel schwieriger sein, als bei den Standalone-Navis und Nokia bietet ja zum Handy den entsprechenden Download an.
    Der nennt sich "OVI Karten 3.0" und enthält eine 5 MB große Datei namens: "nokia_maps_3.01_09wk44_b01_s60_3.1_lm_rom.sis"


    Hä? Karten und nur 5 MB???
    Ach so, da stehts ja recht davon ganz klein, dass die Karten separat heruntergeladen werden müssen.
    Ok, also erstmal heruntergeladen und mittels Ovi Suite installiert, ging auch alles klar, nun gibts tatsächlich im Handy einen Menüpunkt "Karten".


    Wird der ausgewählt, startet auch das Programm "Karten".
    Aber - da ist nur eine Weltkugel, die kann man drehen etc und hineinzoomen, aber ab einer gewissen Zoomstufe wird es pixelig und dann nur weiss.
    Ok, inzwischen, also nach diesem ersten Start von "Karten" auf dem Handy, tauchte ja nun in der Ovi Suite ein Menüpunkt "Karten öffnen" auf.


    Super!
    Oder auch nicht, denn wenn man den anklickt, kommt:
    -> Verbindung mit Kartendienst wird hergestellt
    -> Es konnte keine Verbindung zum Dienst hergestellt werden


    So geht das nun schon seit 5 Tagen. Auch bei einem testweise angeschlossenen Nokia 6210 Navigation kommt immer nur die gleiche Meldung. Dieses hat übrigens eine funktionstüchtige Navigation bereits drauf.


    Diverse Tipps aus dem I-Net, wie Firewall deaktivieren, Ovi Suite de- und neu installieren etc., haben nichts gebracht.


    Daher mal die Frage hier: verarscht uns da Nokia mit der angeblichen kostenlosen Navigation oder ist einfach nur der Server down oder sind die nur mal wieder zu blöde, was korrekt aus dem finnischen ins deutsche zu übersetzen?


    Und/oder gibts sonst noch eine legale Möglichgkeit, die Karten auf das Handy zu bekommen?


    Grüße
    Mike


    Bitte keine Ratschläge: wie Standalone-Navi nehmen oder so, damit ist mir nicht geholfen...

    Ich hab dann mal die System_AutostartRunOnReset.mscr um die Zeilen:


    KOORD_PATH = "\My Flash Disk\Programme\Koord\Koord465.exe"
    Run(KOORD_PATH , "window=0 explorer=1 sip=1")


    ergänzt.


    Die letzten 2 Zeilen hab ich weggelassen, da der Pause-Eintrag einen Error bewirkt und nach dem automatischen Schließen der Taskbar der Coreplayer beim Start aus der Karte heraus dann doch nicht ganz so funktioniert, wie ich möchte. Das macht er nur, wenn die Taskbar in den Hintergrund rutscht, was sie ja beim Aufruf von Gopal automatisch macht.


    Ich hab auch noch die System_Standby.mscr ergänzt um:


    XCOPY("\ROOT\Application Data\*.*", "\Storage Card\Backup\ROOT\Application Data\", TRUE, TRUE)


    das sorgt dafür, dass bei jedem Standby die config-Datei des Coreplayers, die ja u.a. auch die aktuelle Playlist enthält, ins Backup-Verzeichnis auf der Karte kopiert wird, für den Fall, dass im Standby mal der Akku leer wird und das Gerät komplett abschaltet. Dann kopiert Dein Script die Config-Datei zurück an die richtige Stelle und der Coreplayer macht mit der richtigen Playlist und den richtigen Einstellungen weiter.




    So, da nun das P5430 mit GoPal 5.5 und Deinem Skin genau so funktioniert, wie ich es gerne hätte, hält das Teil nun endlich Einzug in meine Signatur.


    Danke nochmal für Deine Bemühungen und den tollen Skin!


    Grüße


    Mike

    Ist schon ok, es gibt ja auch noch ein Leben neben dem Skinning.


    Inzwischen hab ich soweit in Erfahrung gebracht, dass das von mir beschriebene Problem mit Taskbar/Explorer Geräte-spezifisch ist (X-Serie und auch P5430) und daher wohl auf Deinem 4410 nicht auftreten wird, bzw. nicht aufgetreten ist.


    Gelöst hab ich das momentan so: ich hab in Deiner menu1.ini den Eintrag

    Code
    1. Command = "\My Flash Disk\Programme\MortScript\FC\MortScript.exe", "\My Flash Disk\Programme\MortScript\FC\System_ShowHideTaskBar.mscr"


    ersetzt durch:

    Code
    1. Command = "\My Flash Disk\Programme\Koord\koord465.exe" parameter="param= explorer=1 sip=1 window=0"


    Nach einem kompletten Ausschalten oder Hardreset drücke ich dann zuerst 1x den Button für die Taskbar, der Explorer poppt auf, schliesst sich wieder, die Taskbar bleibt sichtbar. Wenn ich dann Gopal starte, verschwindet die Taskbar (in den Hintergrund?). Danach funktioniert auch der Aufruf und die Bedienung des Coreplayers von der Gopal-Kartenansicht aus wie gewünscht und von Dir beschrieben.
    (mein Wunsch dazu: das zu automatisieren, als beim Start den Explorer automatisch 1x öffnen und sofort wieder im Hintergrund verschwinden lassen)


    Den Coreplayer hab ich jetzt auch im Griff, ich musste nur einmal den Geräte-Ordner \ROOT\Application Data\Coreplayer in das von Dir angelegte Backup-Verzeichnis in MFD kopieren, dann wird nach einem Hardreset bzw. Komplettausschalten dieses wieder mit zurückkopiert und der Player startet in der zuletzt eingestellten Ansicht und mit der letzten Playlist, da er seine Konfigurationsdatei dort ablegt.


    Grüße
    Mike

    Pumuckel : Du sprichst auf Seite 6 dieses Threads von einem "Taskbarpatch".


    Zitat: "Das hängt mit dem Taskbarpatch zusammen. Bei deinem Navi ist es doch so, daß Du die Taskbar nicht aufrufen kannst bevor Du nicht einmal den Explorer geöffnet hast. Dies habe ich eliminiert ... "


    Nach dem Lesen aller 36 Seiten diese Threads und intensiver Suche im Forum, Wiki und im I-Net, wo ich leider keinerlei weitere Hinweise zu dem von Dir erwähnten Taskbarpatch gefunden hab, wüßte ich gerne: WIE genau hast Du das emliminiert???

    Was fummelt Ihr hier in meinem Biete-Thread rum, hehe :D


    Danke Ralf für den Link, genau das ist das Paket.
    Und klar bin ich Optimist, dennn es ist ein bekanntermaßen gutes und zuverlässiges Gerät und für ein Aktuelles mit Craddle und Fernbedienung löhnt man immer noch mindestens das Doppelte.
    Ausserdem ist es ja VHB.
    Und bei Interesse/Bedarf gibt es eine originale GoPal 4.7 AE mit Gesamt-Europa 2008 dazu..


    TeeSteinchen : auf der Rückseite des Gerätes steht eben:
    P4410
    Model: MDPNA 470T


    Das Paket wurde Mitte 2008 gekauft (Beleg über 399 Euro ist vorhanden)
    Die Akkulaufzeit wurde nicht explizit getestet. We
    nn es mal ausserhalb des Autos war (Diebstahlprevention) und dabei vergessen wurde, es komplett abzuschalten, dann hielt es im Standby immer eine gute Woche durch.


    Hier mal noch ein aktuelles Bild:
    [Blockierte Grafik: http://img204.imageshack.us/img204/3787/md962051.jpg

    Na dann monologiere ich mal alleine weiter:


    Also man benötigt einen Coreplayer mit einer dazu passenden config.xml, dann klappt zumindest mal der Start des Players ohne irgendeine Fehlermeldungen.
    So hätte das zumindest mit in der pdf stehen können, das würde manche Verärgerung oder unnötige Nachfragen wegen Fehlermeldungen vermeiden, denn nicht jeder weiß das und die Info im I-Net zu bekommen, ist auch nicht sooo einfach.


    Warum wird eigentlich um diese config.xml so ein Geschiss gemacht? Verstößt das Erstellen oder Verändern einer solchen Datei und/oder die Benutzung der Datei in Verbindung mit dem Coreplayer gegen Lizenzrechte?




    Was nach wie vor bei GoPal 5.5 Build 87821 und 92473 nicht funktioniert:
    - Taskbar-Button im Startmenü ohne Funktion
    / funktioniert erst dann, wenn man 1x auf der Seite Extras mit einem Klick in die Ecke oben links den CE-Explorer gestartet hat, dann kann man die Taskbar mit dem Button im Startmenü beliebig öffnen und schließen,
    - Zurück-Schließen-Button des Coreplayers (der Button ganz unten links)
    / solange man nicht, wie vorstehend beschrieben, den CE-Explorer 1x gestartet hat, funktioniert der Zurück-Schließen-Button nur, wenn die Wiedergabe gestoppt ist
    - nach einem Aus- und Einschalten erstellt der Coreplayer beim Starten wieder neue Default-Einstellungen und die Musik-Titel müssen neu ausgewählt werden und auch die eigenen Wiedergabe-Einstellungen (Shuffle etc.) sind weg
    /sollte da nicht ein Script dafür sorgen, dass alle benutzerdefinierte Einstellungen nach dem kompletten Ausschalten wieder geladen werden?


    Wär schön, wenn man diese Problemchen noch ausmerzen könnte.

    Kann es sein, dass der Skin eine ganz bestimmte Version des CorePlayers vorraussetzt???


    Ich habe es jetzt mal mit der Version 1.2.0 versucht.


    Da zeigt er zwar bei jedem Start an: erstelle Default-Einstellungen und dann bekomme ich 2x einen ERROR "PNG: This type of PNG Image format is not supported" und es öffnet sich ein Help-Fenster vom Explorer, aber wenn ich die Errors mit OK wegklicke, dann startet der CorePlayer mit dem Skin genau wie bei den Screenshots hier im Post.
    Und die Zurück-Schaltfläche funktioniert wie gewünscht: schließt den Player, wenn keine Wiedergabe läuft und versetzt ihn in den Hintergrund, wenn eine Wiedergabe läuft.


    Nur die Media-Schaltfläche bringt einen Fehler und der Corplayer wird beendet, aber das wär egal.


    Wie könnte ich den Start sauberer, also ohne Errors und Helpfenster, hinbekommen?
    Google hat mir bezüglich der Errors nicht weitergeholfen.


    Gruß


    Mike

    Hallo FC,


    ein paar Antworten zu Deinen Fragen stehen ja schon in meinem Post weiter oben:
    GoPal 5.5 92473 - frische, funktionierende Installation


    Hab gerade nochmal eine frische Installation mit dem Build 87821 gemacht und dabei den originalen MP3-Player nicht installiert, sondern über "Flex-Skin konfigurieren" den Videoplayer als MP3Player eingebunden.
    Die Meldung kommt auch hier.


    /EDit:
    Wenn ich meinen CorePlayer auf die SD-Karte kopiere und dann bei einer originalen, ungeskinnten GoPal-Installation über den CE-Explorer aufrufe, erhalte ich keine solche Fehlermeldung.


    Ich hab übrigens den CorePlayer v1.0.0 build 1838 for ARM mit der Standard-Oberfläche (Screenshot in diesem Post: [Allgemein] FM-Transmitter: Ansagen + Musik ?)


    Wenn ich nach der Installation des Flex-Skins die skin.cps aus Deinem Flex-Skin-Paket (Verzeichnis SKIN_CorePlayer) in das CorePlayer-Verzeichnis kopiere, dann startet der Coreplayer mit einem komplett schwarzem Bildschirm, wo nichts weiter steht als der Schriftzug "Ingram Player".
    Ich musste dann alles komplett neu aufsetzen, da ich das nicht mehr wegbekam, denn die Taskbar und selbst der originale CE-Explorer-Aufruf funktionierten nach Installation des Flex-Skins garnicht nicht mehr (hier bei Build 87821).


    Also nochmal zum Verständnis (Deine pdf kenn ich inzwischen fast auswendig):
    1. Frische GoPal-Installation / mit oder ohne originalen MP3Player - oder egal?
    2. einmal den GoPal-Navigator starten (auch mal navigieren?)
    3. Flex-Skin installieren (hab ich mal mit, mal ohne Startmenü probiert)
    4. alle Dateien des CorePlayers in das Verzeichnis MFD\Programm\CorePlayer kopieren
    5. Config.xml und skin.cps aus dem Skin-Paket Verzeichnis \SKIN_CorePlayer ebenfalls in das Verzeichnis MFD\Programme\CorePlayer kopieren


    6. CorePlayer starten, dann müßte die Oberfläche eigentlich so aussehen, wie auf den Screenshots hier im Post?
    Da das bei mir nicht so ist, ist da meine Verfahrensweise falsch?




    Beim Player mit der OriginalOberfläche hab ich ja grundsätzlich das Problem, dass ich nicht zur Navigation wechseln kann, ohne dass sich die Wiedergabe beendet, weil es in der Original-Oberfläche dafür keinen Button "Zurück" gibt, wie beim originalen MP3Player.


    Gruß


    Mike

    OK, das bin ich gerade mal am testen...


    Aber der TCPMP sieht so Sch... aus, die Oberfläche des originalen MP3Players gefällt mir da wesentlich besser. Er läßt sich auch nicht mit den Fingern bedienen, nur mit dem Stift. Da brauche ich wohl noch eine andere Oberfläche für den, oder?
    Mal schauen, ob ich da was Passendes finde.


    Daher hab ich jetzt mal meinen CorePlayer genommen und mit Hilfe des FC-Flex-Skins als MP3-Player eingebunden. Da hab ich dann das Problem: wie komme ich denn aus dem MP3-/Videoplayer zurück zur Navigation? Da gibt es keinen Zurück-Button, nur das Kreuz oben rechts, was ihn schließt, wobei er die Wiedergabe beendet.



    Gruß


    Mike


    Den Warner benutze ich natürlich nicht, war ja nur ne Testfahrt ;)

    Ich sehe das als Ausblendung der Musik, zwar eine ziemlich abrupte, aber eben eine Ausblendung, da der MP3Player weiterläuft. Bei einer Unterbrechung würde der Titel nach der Navi-Durchsage an der unterbrochenen Stelle weiterspielen, was nicht der Fall ist.


    Aber darum gehts mir nicht: egal ob Ausblendung oder Unterbrechung - beides nervt mich jetzt nach ein paar Testfahrten tierisch. Da piepst ja auch der Warner dauernd mit dazwischen und gelegentlich auch mal ein (falsches, weil Straße noch mit weniger kmh eingetragen ist) "Bitte beachten ... Geschwindigkeitbeschränkung".


    Wenn es wenigstens die Möglichkeit gäbe, die Lautstärke der Musik für die Dauer einer Navi-Durchsage um einen einstellbaren Wert absenken zu können und damit Musik und Ansagen echt gemischt werden, wär das nicht so dramatisch.


    Falls es so eine Lösung nicht gibt, geht das P5430 innerhalb der Rückgabfrist wieder zurück zum Händler.


    Wenn ich nur den Post wiederfinden würde, ich vermute inzwischen, der befindet sich garnicht in diesem Forum.
    Da hatte jemand geschrieben, dass bei einer neuen Geräte- oder Softwareserie die Naviansage nicht mehr mit über den FM-Transmitter geht, sondern nur noch über den internen Lautsprecher des Navis...


    Gruß


    Mike

    Hi,


    hab hier im Forum mal was gelesen, dass der FM-Transmitter bei bestimmten Geräten nur noch die Musik des MP3-Players überträgt und die Navi-Ansagen nur über den integrierten Lautsprecher kommen.


    Ich finde aber leider trotz intensiver Suche den Post nicht mehr.


    Vielleicht kann sich jemand an so einen Post erinnern und mir den mal verlinken?


    Oder hab ich da was falsch in der Erinnerung und alle Geräte mit FM-Transmitter übertragen immer Ansagen und Musik (die dann während der Ansage automatisch ausgeblendet wird)?


    Oder ist das softwareabhängig und bei der GoPal-Version 6 anderst, als z.B. bei 5.5?


    Grüße


    Mike

    Rückmeldung zum Skin auf P5430 / GoPal 5.5 92473 - frische, funktionierende Installation


    Erstmal Danke für den Skin - ist von der Funktionalität genau das, was ich suchte und der direkte Zugriff auf den MP3Player ist Klasse!


    Ein paar kleinere Probleme treten bei mir auf:


    - Startmenü: nach Neu- oder Kaltstart ist der Button "Schaltet TaskBar Ein/Aus" ohne Funktion (auch nicht auf Menüseite2)
    wenn ich einmal die Navigation gestartet hatte, funktioniert der Button


    - Videoplayer: nach dem Start aus dem Startmenü oder aus der Navigation höre ich nach 2-3 Sekunden einen Fehler-Signalton, der Player startet und funktioniert aber erst mal ganz normal.
    Nach dem Beenden sehe ich folgende Meldung:
    ERROR
    Window ´CorePlayer´ could not be found
    Line 92 (\My Flash Disk\Programm\MortScript\FC\Main_CorePlayer.mscr): WaitFor ("CorePlayer", 5)


    Ist zwar nur ein Schönheitsfehler, aber könnte/sollte man da etwas ändern?


    Gruß


    Mike