Beiträge von SpaceRat

    Zitat

    Original von sokobana
    Was von uns kommt:
    - Tutorial Serilot-Einbindung in Varioskin 3
    - Serilot HD und FF sicher machen.


    - Automatischer Softreset, wenn mal versehentlich drei Programme gleichzeitig auf den virtuellen Port zugegriffen haben (Koord, Glopus und GoPal)


    Sorry, konnte einfach nicht widerstehen.


    Dieses Spielchen ist einfach zu köstlich. Sicher, der POI-Warner hat ggü. POI-Observer nicht nur Nachteile, aber die Benutzung von serilot zu propagieren, wenn VirtCom das kostenlos besser kann - auch ohne daß man deswegen den POIObserver nutzen müsste - ist wie der Versuch, einem Eskimo einen Kühlschrank anzudrehen.
    Da wird ein totes Pferd geritten.


    Ich frage mich, ob hier überhaupt jemand noch über serilot reden würde, wenn ich es nicht durch Entfernen aus dem von mir erstellen Glopus-CAB interessant gemacht hätte.

    Zitat

    Original von der randharzer
    Navi aus Standby "wecken" während Verbindung zum PC besteht,
    Null Problem :] !!
    Verbindung wird aufgebaut.


    Der Fehler tritt nicht immer auf. Mach das mal ein paar Mal.

    Zitat

    Original von TeeSteinchen
    Hallo rohoel,
    gratuliere, da sind wir schon zwei! Mir kam Storage Card2-Fehler noch nie unter. Weder mit R22 noch mit R23. Ich tippe da schon lange eher auf eine Ursache, die in den Eigenschaften der verwendeten SD-Card zu suchen ist. Bei mir Transcend 150x 4GB.


    Tja, genau die habe ich auch und ich habe den SC2-Fehler auch.


    Die Beobachtung, daß es mit dem Aufwecken des Navis aus dem StandBy - während es am PC eingestöpselt ist - zu tun hat, kann ich hingegen bestätigen.


    Das Navi hat wohl keinen großen Bock, eine ActiveSync-Verbindung aufzubauen während es sich noch den Schlaf aus den Augen reibt. ;) :D

    Damit dürfte endgültig klar sein, wer hier Streß macht.


    Nun denn:
    Bei mir funktioniert die StatNav-Umschaltung mit denselben Scripten nicht, die bei athos funktionieren.


    Ich habe so oder so kein Pfeilzittern und es werden unter 9km/h keine Geschwindigkeiten angezeigt.
    Laufe ich die Straße rauf und runter, wird die veränderte Position ruckartig mit 9km/h angepaßt.


    Möglicherweise gibt es unterschiedliche GPS-Chipsätze in den Geräten.
    Ich habe einen MDPNA 470T mit R23 und 256MB.


    Mehr werde ich dann hier nicht mehr dazu sagen.

    Also irgendwie nimmt die Verschieberei hier langsam Überhand.


    Es sollten schon klare Definitionen her, was jetzt in welchen Thread gehört. So ist keine klare Linie erkennbar... StatNav startet jetzt drüben und endet hier.


    Eine klare Linie wären z.B.:
    Im VarioSkin 3.4-Thread nur Fragen und Antworten zu dem, was in VarioSkin 3.4 ohne Änderungen Dritter und zukünftiger Experimente vom Team schon drin ist,
    hier alles andere, also Mods, Vorschauen zukünftiger Entwicklungen, Testzone, etc. pp.


    Für die technisch weniger versierten Benutzer wäre das wohl auch einfacher nachzuvollziehen, denn wenn im 3.4er Thread über Sachen diskutiert wird, die erst in 3.5 oder so kommen, dann zieht das nach 3 Seiten zwangsläufig Fragen der Art "Wo finde ich die Option/den Button? Bei mir klappt das nicht." nach sich.


    Oder, noch konsequenter:


    1. VarioSkin 3.4 offizieller Support-Thread zur offiziellen Version
    2. VarioSkin-Labor (A la AVM-Labor ;) ): Thread mit Basteleien, Tests usw. des offiziellen Teams, wo die Leser dann sehen können: Daran wird gearbeitet und ist evtl. in der nächsten Version mit drin.
    3. VarioSkin-Modding: Basteleien anderer User, Mods, Inoffizielle Ergänzungen etc.
    Würde auch klar machen: Tampering with Skins voids warranty. .. für die dort vorgestellten Änderungen kann das Team Sokobana keine Garantie mehr übernehmen und keinen Support leisten.

    Kleiner technischer Hintergrund:


    Es gibt zwei übliche Ansätze, die Splitter zu konfigurieren:


    1.
    Ursprünglicher Hardware-Port -> Splitter -> neuer virtueller Port


    2.
    Ursprünglicher Hardware-Port wird auf einen anderen Port verlegt
    -> Splitter greift auf den verlegten Hardware-Port zu
    -> neuer virtueller Port wird als identisch mit dem ursprünglichen Hardware-Port konfiguriert


    Der 1. Ansatz hat den Vorteil, daß es minimal weniger Konfigurationsaufwand ist, aber den Nachteil, daß der von der Software zu benutzende GPS-Port auf jedem Gerätetyp ein anderer ist, denn mal hat man COM5 frei für den neuen, virtuellen Port, mal COM0, usw.
    Außerdem muß in diesem Fall die Navisoftware umkonfiguriert werden, was bei nacktem GoPal schon garnicht geht.


    Bei 2. hat man zwar beim Einrichten etwas mehr Arbeit (Hardware-Port verlegen), dafür findet alle andere Software die GPS- und TMC-Ports genauso vor, wie ohne den Splitter auch.


    Die 1. Methode scheint von StefanDausR favorisiert zu werden (Jedenfalls sind seine koord465-Beispiele immer darauf ausgelegt).


    Die 2. Methode ist die, die auch von Schmischis altem 1-Klick-Installer und dem Nachfolgeprodukt, GPW-POIObs-Install verwendet wird. Ich habe sie auch für meinen POIObserver-CAB-Builder übernommen.
    Erstens weiß Schmischi schon, was er tut, zweitens bin ich auch selber davon überzeugt, daß es für den Benutzer einfacher ist, das Ergebnis ähnelt dem Original als es mir minimal einfacher zu machen den Splitter zu konfigurieren und drittens haben somit alle Benutzer, die GPW-POIObs-Install, den CAB-Builder (oder den antiken 1-Klick-Installer) verwenden, dieselben Einstellungen, einen solchen de-facto-Standard finde ich sehr benutzerfreundlich.


    Meine StatNav-Scripte sollten aber mit beiden Methoden funktionieren, da der verwendete COM-Port ermittelt und nicht mit dem GoPal-Standard angenommen wird.

    Zitat

    Original von athos


    Nur mal ne Frage, wenn man den Virtuellen Com-Port auf com 2 hat müßten doch auch die Orginalen gehen, oder?


    Nein, denn die machen ja immer einen Neustart, egal ob mit oder ohne.
    Naja gut, solange der Neustart für die Umschaltung außer Acht gelassen werden kann schon.


    Es sind eigentlich drei Änderungen enthalten:


    1. Der von GoPal benutzte COM-Port wird durch das Script ermittelt, statt COM2: anzunehmen.
    Zumindest StefanDausR hat VirtCom so konfiguriert, daß der von VirtCom erzeugte virtuelle COM-Port nicht derselbe ist wie der ursprüngliche originale, bei einer solchen Konfiguration würde es nicht gehen, weil versucht wird, am Splitter vorbei auf dem Hardware-Port umzuschalten und der ist ja noch belegt, vom Splitter nämlich :)


    2. Der von GoPal benutzte Port wird mit dem eingestellten Ausgabeport von VirtCom verglichen.


    3. Die Skriptteile Vorbereitung der Umschaltung und Neustart werden nicht abgearbeitet, wenn die unter 1. und 2. ermittelten Ports identisch sind. Sind diese nämlich identisch und virtcomng.dll liegt noch im Windows-Verzeichnis, muß (naja, in aller Regel) der benutzte Port ein virtueller sein, dann kann ohne Neustart umgeschaltet werden.

    Zitat

    Original von athos


    Du weißt doch, was bei Dir geht muß bei mir noch lange nicht gehen. ;D


    Stimmt auch wieder. Eigentlich gilt sogar der Umkehrschluß: Was bei Dir geht, müsste dann endlich bei allen gehen. Als Betatester bist Du somit unverzichtbar. :D


    Zitat

    Original von athos
    PS.: war auch so, ich mußte erst mal suchen wo das Bluetooh am Coputer einzuschalten war :gap


    Siehste, das Problem hab ich nicht, weil ich eine Blauzahn-Maus habe :)

    Zitat

    Original von athos


    Auf deine Aussage hier hab ich das auch mal versucht, und es geht bei mir auch > is ja geil. :gap


    Auf meine Aussage hin versucht ... ist ja schon nicht nett.
    Wenn Ihr mir nicht blind glaubt, brauche ich Euch ja auch nichts mehr vorlügen :gap

    Zitat

    Original von TeeSteinchen


    Na wenn Du die R22 hast, könntest Du doch jederzeit wieder auf diese zurück.


    Eben, vor allem weil da m.W. der SC2-Fehler eh schon drin ist, dann kann man wenigstens den Mehrspeicher mitnehmen...