Beiträge von dflesch

    Hallo Argasha und Oldtimer,


    hatte beim ersten Test leiden etwas übersehen.Man wird langsam Betriebsblind oder einfach alt.
    Das Script läuft erst mal.Die Umschaltung der Beleuchtung braucht etwas mehr Zeit.Habe mal folgende Werte geändert und Intensiver getestet.Die Umschaltung hat jedesmal geklappt.


    Auszug aus dem Beta Navirunner unter:


    ### Backlight-Steuerprogramm starten


    ...
    Timer = Timer +1
    If (Timer > 20)
    Message "Backlight-Steuerprogramm konnte nicht gestartet werden.^NL^Bitte Preset BKL_Prg prüfen!^NL^Beende Script."
    Exit
    EndIf
    Endwhile
    Sleep 2000
    If (BKL_Prg eq "Backlight.cpl" or BKL_Prg eq "ctlpnl.exe")


    Der Wert für dunkel sollte "20" sein.Bei "0" sieht man nichts mehr!

    Probiere es mal damit.


    Gruß Dflesch

    Zitat

    Original von binfredusa


    .. ja aber genau das ist der Punkt;
    natürlich hatte ich das gelesen, aber 1. funzt es beim Yak 300 GPS nicht, und 2. ist beim Yak... die LED zweifarbig ausgelegt (rt/gn); also welche Farbe kann ich mit welchem Befehl ansteuern?


    p.s. ... und bitte, halte Deine Umwelt nicht für dümmer als --- na ja.



    Hallo binfredusa,


    Man kann nicht gezielt eine Farbe der LED ansteuern!Entweder es kommt eine Reaktion oder nicht.Meine LED ist dreifarbig gelb/grün/rot und bei dem Befehl leutet die Anzeige rot.


    Ich halte die Umwelt nicht für dümmer,als ich selber bin.Sollte nur ein Hinweis sein,weil viele Leut sich das Mortschript installieren und nicht wissen was manchmal passiert.


    Kömisch,man gibt einen Hinweis und andere fühlen sich auf den Schlips getreten.Das war aber nicht mein Anliegen!!!


    Das BacklightCheck Script kann ich erst morgen testen.Gebe also noch bescheid.


    Noch einen schönen Tag

    Hallo Corx,


    Habe einen ASUS 632N ohne TMC.Meine Eindrücke sind folgende.


    1.) Läuft der 3D-Modus flüssig, d.h. sitzt der Pfeil recht genau dort, wo man sich befindet?
    - Der Start ist mit 18 Umdrehungen des Navipfeils zu ertragen.Der Pfeil sitzt nicht korrekt,aber nach Korrektur ist alles o.K.


    2.) Gibt es noch immer das Speicherproblem mit Abstürzen?
    - Speicherabstürze habe ich seit 6.15 nicht mehr gehabt.


    3.) Läuft das TMC-Modul einwandfrei?
    - zur Zeit noch nicht vorhanden


    4.) Gesamteindruck der Software: Flüssig, träge, zäh?
    - Alles läuft sehr flüssig.Bedienung ist ok.


    5.) Weitere Anmerkung von eurer Seite.
    -Der Kauf hat sich für mich persönlich gelohnt.Wichtige Straßen und neue Autobahnen sind für mich verfügbar.Das verschieben vom Programm hat keine Geschwindigkeitsvorteile gebracht.Habe daher alles auf der Speicherkarte gelassen.


    Ich denke,das mit MN6 ein Programm vorhanden ist,was man nutzen kann und sollte.Auch wenn zu Beginn viele Fehler und Probleme auftauchten.


    Kann die Leute eh nicht verstehn,die immer etwas zu meckern haben.Allen Leuten recht getan,geht nun mal nicht.
    Wenn ich mir die Probleme bei anderen,wie TomTom und wie sie alle heisen
    anschaue,merke ich das auch diese Programme nicht fehlerfrei und perfekt sind.

    Hallo binfredusa,


    Die Mortscript Beschreibung oder Hilfe im PDF Format sollte für alle Pflicht sein.Dort werden alle Befehle aufs feinste erklärt.


    Hier ein Auszug für "Vibrate":


    Vibrate( Millisekunden )
    Lässt das Gerät die angegebene Anzahl Millisekunden vibrieren.
    Bei der PC-Version wird statt dessen gepiept.
    Bei PPCs wird der Vibrator wie eine LED angesprochen, hat aber leider keine einheitliche Nummer. MortScript geht davon aus, dass er die letzte Nummer hat, was bei den meisten Geräten zuzutreffen scheint. Es kann aber (je nach Gerät) auch sein, dass statt dessen eine LED aufleuchtet oder gar nichts passiert.


    Beim ASUS 63X leuchtet die Ladeanzeige,oder besser gesagt blinkt rot.

    Hallo Leute,


    es ist immer noch besser konstruktiv mitzuhelfen,als mit komischen Bemerkungen die Arbeit zu kritisieren.


    Damit wieder zum Thema !!!


    Habe mir Gedanken gemacht (und das schon ab Navigator 5)ob das Script im täglichen Einsatz noch am Leben ist.


    Die Idee kam mir,als ich mich intensiver mit den Scriptbefehlen auseinander gesetzt habe.Da der Status Netz/Akkubetrieb nur einmal pro Minute durchlaufen wird,habe ich einfach folgende Zeile eingefügt.


    ### Abfrage Status Netz/Akkubetrieb. Aufruf nur ein mal pro Minute.
    If {%P_SwitchMode% eq "auto" AND %Timer1% <> %MinsFromMidnight%}
    Set Timer1, %MinsFromMidnight%
    vibrate 2000
    Call Switch_BAT_POW
    EndIf


    Somit erhalte ich über die Ladeanzeige ein rotes blinken und erkenne,daß das Script noch aktiv ist.

    Habe es auf ASUS 632 getestet.
    Nach Einstellung vom dunkelsten Wert erscheint "Comma expected".
    Den dunkelsten Wert(der ist 0) kann man nicht einstellen,da die Anzeige total verschwindet.Der Maximalwert beim Asus 63x ist 255.
    Habe im Script einfach feste Richtwerte eingtragen.
    Dunkel=20
    Mittel=80
    Hell=255


    Hier macht es einfach Spaß mitzudenken!Es wird nicht nur gemeckert,sondern
    gegenseitig geholfen.Habe bis jetzt meine eigene "Suppe gekocht",aber hier bin ich der Meinung,daß ich anderen helfen kann und mir geholfen wird.


    Danke an alle,auch wenn die Hilfe noch so klein ist!


    Macht einfach alle so weiter !!!!


    Kann das ewige gejammere in andernen Themen eh nicht mehr ertragen.


    :respekt :respekt :respekt

    Erst mal Danke !!! an Argasha .
    Nutze das Script schon seit Navigon 5.Hat mir mir viel Arbeit und Nerven gespart.
    Habe mir damals schon alles für den ASUS 632N umgebastelt.


    Damit meine Arbeit auch anderen etwas nützt,werde ich ein Liste der Befehle
    für den ASUS 63X anhängen.


    ** für asuscpl.cpl und für cplmain.cpl **


    Vielleicht kann es jemand gebrauchen,um es in ein Script einzubinden.


    Aufruf wie folgt:


    run /Windows/ctlpnl.exe, "ASUSCpl.cpl,X,Y"


    oder


    run /Windows/ctlpnl.exe,"cplmain.cpl,X,Y"


    Die Werte X und Y einfach aus der Tabelle entnehmen und eintragen.

    Beim Asus 63X muß man folgende Befehlszeile angeben,um die Helligkeit zu ändern.


    regwritedword hklm,hardware\devicemap\backlight,acbacklightintensity,200
    (Registry Wert Helligkeit bei Netzbetrieb-von 0-255)


    regwritedword hklm,hardware\devicemap\backlight,backlightintensity,104
    (Registry Wert Helligeit bei Akkubetrieb-von 0-255)


    run /Windows/ctlpnl.exe, "ASUSCpl.cpl,1,0"


    sleep 3000
    (Wartezeit)


    close Einstellungen
    (Übernahme der Werte)


    Eine Zeit unter 3 sek hat gezeigt,daß es öffter mal Probleme gab,denn Wert sauber zu übernehmen.

    Das problem zwischen Navigon und Heute Bildschirm habe ich mit einem Script gelöst.So kann ich jederzeit von Navigon auf den Heute Bildschirm umschalten und automatisch wieder zurück.
    Wer Lust hat kann es ja ausprobieren.Wäre über eine Antwort erfreut,ob es auf anderen PDA`s auch geht.Habe es auf einen ASUS 632N getestet.Das Script auf eine Hardwaretaste legen und los gehts.

    Vielleicht zu TMC-Light oder suncalc.
    Sorry,aber ich bin im Forum ziemlich neu und wollte nur zum Thema Hintergrundbeleuchtung meine Erfahrung weitergeben.
    Wenn ihr kein Interesse habt,dann kann ich ja in zukunft meine Erfahrungen auch für mich behalten.Da gibt mir wenigsten keiner eine dumme Antwort.
    Zum Glück macht Ihr ja keine Fehler !!!
    Sollte Euch vielleicht mit Herr Gott anreden.