Beiträge von Daniel S.

    Zitat

    Original von micha2802
    Die bezieht sich jetzt aber nur auf den Schriftzug km/h oder? (Wie) kann ich die Anzeige der Geschwindigkeit ändern?

    Oh, da hab ich dich falsch verstanden. Die digitale Darstellung der Schrift kannst du in der Sektion DigitalMetrics ändern, dort kannst du folgende Attribute angeben:

    • x = [Zahl]
      Abstand der Digitalgeschwindigkeit von links (negativer Wert: rechts), in Pixeln


    • y = [Zahl]
      Abstand der Digitalgeschwindigkeit von oben (negativer Wert: unten), in Pixeln


    • DigitSize = [Zahl]
      Schriftgröße in Pixeln


    • Transparent = [Bool]
      bei Wahr hat die Digitalgeschwindigkeit keinen eigenen Hintergrund


    • Center = [Bool]
      bei Wahr bezeichnen x und y die Abstände für die Mitte, bei Falsch sind es die Abstände für die linke, obere Ecke


    • FontWeight = [Zahl]
      gültig sind Werte zwischen 0 (schmal) und 1000 (fett)

    Beispiel:


    Zitat

    Schönen Gruß und schönes Wochenende

    Danke, dir auch.

    Zitat

    Original von DanielJackson
    das tool zeigt beim druck auf die einzige hardwaretaste nichts weiter an. ob es da noch eine Lösung gibt?

    Hallo, tut mir leid, da kann man nichts machen.



    Zitat

    Original von Locke67
    wie hast Du es hinbekommen das wenn MN6 läuft Du den GPS Tacho per QuickRunner öffnen kannst ?
    Komme bei mir immer com2 kann nicht geöffnet werden.
    Wenn ich dann auf cancel klicke kommt er mit GPS Einstellungen --> ohne
    gültige GPS-Ini funktioniert das Programm nicht.
    Vom Desktop läuft der Tacho einwandfrei.

    Hi, mit einem Portsplitter kann man die GPS Daten teilen, so dass sie von der Navisoftware und von GPSTacho empfangen werden können. Concor hat dazu mal einen Thread (glaube im MN6 Forum) erstellt.



    Zitat

    Original von micha2802
    Hi Daniel,
    ich habe ein HTC Tytn II (Kaiser) und muß dafür die Skins (Tacho) anpassen. Die Skala an sich paßt jetzt soweit nur müßte ich jetzt noch die Anzeige unten (km/h ) verschieben bzw, die Grösse ändern. Wo/ wie kann ich das machen? Hab mir schon einen Wolf durch die ganzen ini's gesucht aber keinen passenden Eintrag gefunden.....

    Hallo Micha, da musste ich jetzt selbst erstmal schauen, es geht aber. In der entsprechenden Tacho-Ini musst du in der Sektion AnalogMetrics den Eintrag XUnit = 20 und YUnit = 20 hinzufügen, damit gibt man den Abstand von links unten an, wenn beide Werte auf 0 stehe ist der Text also ganz links unten im Eck. Mit ShowUnit = no kann man die Anzeige auch entfernen. Die Schriftgröße ist die selbe wie bei den Tachozahlen und lässt sich nicht getrennt einstellen.

    Zitat

    Original von dmanhard
    Hallo
    ...
    Wie kann ich die virtuelle Tastatur aufrufen??
    Ich weiss es nicht was soll ich tun, damit die Tastatur hochkommen würde.


    Gibt es eine Datei, die ich aufrufen sollte?

    Hallo,
    hat der Loox keine Taskleiste über die man die Tastatur aufrufen kann? Alternativ kannst du das Programm ToggleInputPanel von mir benutzen, das zeigt die Tastatur an, wenn es ausgeführt wird. Aufrufen kannst du es zum Beispiel auch über QuickLaunch oder du bastelst dir mit SystemInformation eine kleine Toolbar oder ein kleines Menü.

    Zitat

    Original von heinz57g
    hallo, hab auf meinem NAVGEAR GP-35 den GPSTacho installiert, und nach einer langen nacht klappts nun auch.


    fast: ich bekomme, egal wieviele satelliten eingebucht sind, kein zeitsignal. die uhr laeuft zwar, aber eben irgendwann
    mal bei 12:00 los, und stellt sich nicht ein.


    beim auf dem gleichen geraet laufenden navi prog (nicht gleichzeitig) braucht es kaum 2 satelliten, und schon geht
    die uhr richtig.


    Hallo, puh so viele Fragen ;)
    Die Uhr zeigt die Systemzeit an. Standardmässig ist sie nicht so eingestellt, dass sie die Systemzeit mit der Zeit der GPS-Satteliten synchronisiert. Das kann man aber in der Uhr-Ini einstellen. Dazu in der Datei Inis\Overlays\Uhr.ini die folgenden beiden Zeilen hinzufügen:
    [Clock]
    SetSystemTime = 1


    Zitat

    was kann das sein? COM 7 / 4800 muesste stimmen, oder? ein zeichen das 'etwas' nicht ganz stimmt sind auch die
    sat-finde zeiten: das navi prog braucht ca eine minute um 3-5 satelliten zu finden, wenn ich GPSTacho suchen lasse,
    an genau der gleichen stelle, dauerts 6-10 minuten.


    hat dies beides nicht evtl miteinander zu tun?


    Die GPS-Satelliten bewegen sich ja, deshalb kann es zu verschiedenen Zeiten unterschiedlich lange dauern, bis genug Satelliten gefunden sind. Wenn du ein Programm direkt nach dem Beenden des anderen startest, solltest du feststellen, dass dann sofort (zumindest deutlich schneller) Satelliten gefunden werden. Ausserdem suchen die Programme nicht selbst die Satelliten, sondern das macht der GPS-Empfänger von allein, darum ist die Zeit bis zum sogenannte Satfix unabhängig vom genutzten Programm.


    Zitat

    PS: doch noch was kosmetisches. ich taete gerne hinter die hoehenangabe ein 'm' setzen, um dies auf meinem
    recht vollen display deutlicher zu machen. den einen TEXT baustein in der INI verwende ich schon, wie kann ich einen
    zweiten erstellen?

    Einfach die Ini mit dem Textbaustein kopieren, den Inhalt entsprechend ändern und dann die neue Ini über das Menü laden (Overlays->Text->Ini Laden).


    Zitat

    PPS: ergaenzung nach weiterem probieren: wenn ich uebers GPSTach menu (GPS) RMC einstelle, geht die uhr,
    der rest der anzeigen schwankt jedoch staendig rauf/runter, als ob ich am fahren bin auch wenns steht. die
    hoehenangabe zeigt unsinnswerte.


    stelle ich (wieder im menu) auf VTG um, geht die uhr nicht, alles andere stellt sich richtig, aber sehr langsam, ein.


    hilft dies zur fehlersuche?

    Manchmal springt die GPS-Position anfangs etwas, solange sich der Empfänger noch nicht ganz sicher ist, wo er sich befindet. Die Höhenangabe der Navis ist leider etwas ungenau, nach einer weile sollte sie allerdings in etwa stimmen (evtl. trotzdem noch ~40m zu viel oder zu wenig). Ich glaube dein Empfänger sendet die VTG-Zeile nicht, du musst also RMC für die Geschwindigkeit verwenden. Die Uhr verhält sich wegen der Performanz nämlich passiv und wird nur aktualisiert, wenn sich etwas anderes (Geschwindigkeit, o.ä.) geändert hat.


    Zitat

    ist es denn richtig, dass bei korrektem beenden die aenderungen uebers menu dann auch in die entsprechende
    INI datei zurueckgeschrieben werden?

    Ja, beim Beenden die GPSTacho.ini und die Konfiguration (Standard: Daniel.ini) neu geschrieben. Wenn das beim nächsten Beenden nicht so sein soll, musst du das Automatische Speichern im Menü unter GPSTacho->Konfiguration->Auto. speichern deaktivieren. Wenn die Inis nie gespeichert werden sollen, muss nach dem Deaktivieren noch einmal manuell im selben Menü gespeichert werden.

    Hallo,
    wenn du den korrekten Port und die Baudrate hast (wie Alfred schieb, am besten trotzdem nochmal posten) dann kannst du diese Dinge einfach in der GPSIni ändern. Im Verzeichnis von GPSTacho findest du die Datei GPSTacho.ini. In dieser steht der Pfad zur GPSIni (GPSIni = ...). Bei der Transonic-Version ist es zum Beispiel "Inis/GPSIni/Transonic5000.ini". In dieser Datei (Transonic5000.ini) änderst du die Daten dann entsprechend und kopierst die Datei wieder auf deinen PNA und es sollte gehen. Alternativ kannst du die Datei natürlich auch unter einem anderen Namen speichern, auf das Gerät kopieren und in der GPSTacho.ini den Namen entsprechend ändern. Wenn das alles soweit stimmt, kannst du GPSTacho starten. Hierfür sollte der "Desktop frei" sein, das heißt die Navigationssoftware darf nicht automatisch starten, da sonst, wie Alfred schon schieb, der ComPort belegt wird und GPSTacho nicht darauf zugreifen kann. Als Lösung kann man hier auch einen ComPort-Splitter verwenden. Von Concor gibt es hierzu eine Anleitung in diesem Forum, einfach nach Port Splitter suchen.


    Tipp: Im Allgemeinen ist es sehr nützlich die genaue Fehlermeldung/Fehlerbeschreibung zu nennen, damit kann dir schneller geholfen werden.

    Zitat

    Original von webboycam
    hallo,
    hab das md96310 und einen samsung processor, aber wenn ich gps tacho starte komt die sanduhr und weiter passiert nichts was mache ich falsch?

    Wahrscheinlich benutzt du die falsche Baudrate oder den falschen ComPort, wenn du an den Inis noch nichts geändert hast. Schau mal ob du irgendwie herausfinden kannst, wo bei deinem Gerät der GPS-Empfänger angeschlossen ist und vergleiche die Daten mit der verwendeten GPSIni, welche GPSIni verwendet wird steht in der GPSTacho.ini.




    Hallo Sven, ich vermute du hast eine Skin-Ini selbst über den Datei-Auswahl-Dialog ausgewählt? Die mitgelieferten Skins können auch direkt über das Menü ausgwählt werden. Bei dir war das scheinbar nicht möglich, weil du eine andere Anzeige ausgwählt hast. Es gibt vier Arten von Anzeigen: Tacho, Diagramm, den zurückgelegten Weg (weiß nicht mehr wie ich die Anzeige genannt habe) und Leer. Je nach Anzeige kann man unterschiedliche Skins laden und wenn du nicht in der Tacho-Anzeige einen Tacho Skin lädst kommt es zu dem Fehler. Die Anzeige kannst du im Menü über Anzeige->Tacho ändern, dort sollte der Skin dann korrekt geladen werden können.


    Zitat

    Achja, ist es richtig wenn der Desktop frei ist und ich ein Programm starte immer
    unten ca. 1 cm vom Hintergrundbild zu sehen ist ?
    Heißt es wird nicht der volle Bildschirm genutzt.


    thx
    Sven

    Dieser Bereich ist scheinbar für die Taskleiste reserviert. Mit dem Programm SetFullscreen, von mir, kannst du diese Reservierung aufheben, einfach ausführen und der ganze Bildschrim wird genutzt. Du kannst auch ShowTaskbar benutzten, dann siehst du in dem Bereich wahrscheinlich die Taskleiste.

    dicker182 : Mit SystemInformation 1.6 kannst du eigentlich ziemlich einfach eine WinXP-Oberfläche (oder gleich Vista?) erstellen.
    Um die Oberfläche zu erstellen brauchst du noch nichtmal deinen PNA, mit der Win32-Version kannst du alles am PC machen und ausprobieren. Wenn du 32Bit-Icons verwendest (würde ich empfehlen) sieht es sogar so aus, wie auf dem echten XP-Desktop. Damit hast du auch die Möglichkeit später evtl. mehrere "Desktops" zu verwenden.
    Ich bin allerdings noch nicht dazu gekommen ein Tutorial zu schreiben..., mmhh, vieleicht könnte ich genau dazu ein Tutorial schreiben oder hast du Lust ;)

    Zitat

    Original von Nnamreh
    nu habe ich keine Scala für die Geschwindigkeit mehr, ist das normal, muß ich die in das Bild integrieren?


    Wenn die Skala bei einem eigenen Hintergrundbild angezeigt werden soll, kannst du das mit DrawSpeedo = yes (auch in der AnalogMetrics Sektion) wieder aktivieren.

    Scheinbar installiert Masware WeaterPanel eine neue Schriftart auf dem Gerät. Windows Mobile denkt aus irgendwelchen Gründen, dass diese neue Schriftart wohl besser zur Darstellung von GPSTacho geeignet wäre. Das Problem ist mir schon bekannt. Man könnte es eigentlich relativ einfach lösen, indem man in den Inis explizit die zu verwendende Schrift angeben würde (Font = Tahoma), leider habe ich aber einen kleinen Fehler in diesem Zusammenhang gemacht, so dass man die Schriftart nicht selbst bestimmen kann. Zur Lösung würde also nur helfen die neue Schriftart zu löschen. In der nächsten Version von GPSTacho, wenn sie endlich mal fertig wird, wird es das Problem nicht mehr geben.

    Nein, das geht in der aktuellen Version noch nicht.


    Aber würde dir ein Programm helfen, das GPSTacho in den Vordergrund holt? Das würde dann natürlich nur funktionieren, wenn GPSTacho schon gestartet ist.

    Ja so ist es richtig, das Bild müsste dann in das selbe Verzeichnis, wie die Ini. Schau mal, ob es auch den richtigen Namen hat und ob du auch die Ini mit dem eingetragenen Bild in GPSTacho geladen hast.


    Zitat

    Eine PDA.ini kann ich im Archiv GPSTacho1.0_Samsung.zip nicht finden, das man über die Inis auch das anpasen kann ist ebenfalls genial, hatte gedacht das es vielleicht eine Variable gibt bei der man die Ausrichtung angeben kann.


    Stellt sich natürlich die Frage ob es unbedingt nötig ist das zu integrieren, irgendwo habe ich mal gelesen das es ein Programm Rotate gibt welches den Bildschirm drehen kann und damit ist das Problem direkt für weitere Anwendungen gelöst.


    Gruß, Hermann

    Die Datei heißt "DunkelBlau_PDA.ini". Das ganze Bild wird dadurch aber nicht gedreht, das müsste man vorher, wie du schon sagst, mit einem Programm wie ScreenRotate machen. Es wird nur die Tacho-Skala so angezeigt, dass sie ganz drauf passt.
    Alternativ könnte man auch die Angaben für x, y, und die Winkel in AnalogMetrics entfernen, dann sollte der Tacho von Form und Größe der Standard-Anzeige entsprechen.
    Hier gibt es auch noch einen Tacho Skin für PDAs.

    Zitat

    Original von Nnamreh
    Hi Leutz, habe GPSTacho auf einem Compasseo 300 kopiert und es funktioniert 8) , das anpassen über die ini-Dateien ist einfach nur genial.

    Das freut mich.


    Zitat

    Was ich nicht schaffe ist es den Hintergrund mit "Transparent = Bool" zu entfernen, versucht habe ich ja, nein, 0, -1 und 1, leider ohne Erfolg.


    Es ist doch so das wenn es transparent ist man den Desktop sehen sollte, oder habe ich da etwas falsch verstanden?

    Also mit der Angabe von Transparent = 1 in der Sektion DigitalMetrics innerhalb einer Tacho-Ini kann man nur angeben ob die Digitalanzeige einen Hintergrund haben soll, im Anhang sind zwei Bilder, die den Unterschied zeigen. Den ganzen Tacho transparent machen, so dass man den Desktop sieht, geht nicht. Man kann aber ein eigenes Hintergrundbild für die Tachoanzeige verwenden, falls das dein Ziel sein sollte.


    Zitat

    Gibt es eine Möglichkeit die Ansicht von Quer auf Hoch zu ändern?


    Gruß, Hermann

    Wenn der Bildschrim, wie bei einem PDA, im Hochformat ist, braucht man spezielle Inis, die den Tacho im Hochformat zeigen, bei GPSTacho ist auch eine PDA-Ini dabei, die den Tacho im Hochformat anzeigt, ausserdem sollte die standard Tacho-Anzeige immer auf den Bildschirm passen.

    Wenn bei dir schon Satelliten angezeigt werden, liegt es daran, dass die Geschwindigkeit von GPSTacho standardmässig aus der VTG-Zeile ausgelesen wird. Diese wird aber scheinbar nicht von allen GPS-Receiver gesendet.
    In diesem Fall kannst du einfach über das Menü "GPSTacho"->"GPS"->"Einstellungen..." die Verwendung der RMC-Zeile für die Geschwindgkeit einstellen.