FFUI Error

  • Hey ihr,
    ich verzweifel langsam.


    Egal was ich versuche an meinem Navi, nem Z099 von Saturn zu ändern, ich bekomme ständig die Fehlermeldung :


    FFUIERROR: Parse error [</layer> expected]


    Ich habe versucht den Joshua Skin zu installieren, alle richtigen verzeichnisse beachtet, die sys.txt bearbeitet. Strikt nach anleitung. Alles mitm Wordpad, NICHT mitm Editor.


    Dann versucht die Blitzen auf Knopfdruck zu deaktivieren. Selber fehler.
    Dann natürlich geschaut, ob evtl. wirklich ein </layer> fehlt, aber da fehlt nichts.


    Hat einer von euch eine Idee?


    viele Grüße


    SJF!

  • Solche fehler kommen wenn etwas falsch eingefügt oder ersetzt wurde.Ein Layer evtl dadurch aufgehoben etc.dann erwartet das Programm die schließung des layers.
    Ist ne schöne sucherei wenn man nicht mehr weiß was man gemacht hat.

  • Es kann viel einfacher sein.
    Ich hatte genau diese Meldung jedesmal, wenn ich mit dem Notepad eine ui-Datei abgespeichert hatte. Alle Änderungen waren korrekt, aber mein tolles WinXP hat dank Unicode, trotz Notepad, in der Textdatei Metadaten mit abgespeichert, die im Editor nicht zu sehen waren. (Grund waren Umlaute meinerseits in den Kommentaren, wer die konsequent vermeidet, hat vermutlich nie Probleme...)


    Das Z099 hingegen liest solche Dateien nur teilweise oder auch gar nicht ein, d.h. es fehlen dann eine Menge Definitionen.


    Jetzt nehm ich Wordpad anstelle vom Notepad und speichere ausdrücklich als "Textfile" (und vermeide Umlaute).

  • Okay, dann werde ich es nochmal probieren ;-)


    wünscht mir Glück


    edit:


    Grade hab ichs mitm Joshua Style 1.5 Blue versucht. Außer die Sys.txt muss man ja nicht bearbeiten, hab ich mir gedacht, das wäre der perfekte Anfang... aber direkt wieder ein fehler:


    Code
    1. FFUI ERROR: Unknown object identifier
    2. Identifier=[sc_ShowCountryInforAutomatic]
    3. Script "st_Start_init" command 37


    Was will er denn jetzt schon wieder?


    Danach habe ich versucht den Pattersson Skin zu installieren. Genau das gleiche Procedere, andere Fehlermeldung:


    Code
    1. FFUI ERROR: Unknown layer referenced
    2. Identifier=[ui_MainMenuNoRoute]
  • Mein Tipp an solch einer festgefahrenen Stelle: Setz noch mal alle Dateien, die du je angefasst hast im Original auf. bzw. spiel dein letztes funktionierendes Backup zurück.


    Ich hatte in einer ui-Datei trotz Wechsel von Notepad auf Wordpad einige hartnäckige und unsichtbare Zusatzbytes, die irgendwann mal reingerutscht sind (s.o.) und die trotz konsequentem Speichern als Textfile nicht mehr raus wollten. Als ich mit der original ui wieder frisch angefangen hatte, lief alles wunderbar, inkl. aller nachträglichen Änderungen.

  • Hmm, glaubste das hilft was? Denn wenn ich die Skins einfach rausnehme, die Sys.txt wieder zurückändere funktioniert alles wieder einwandfrei.


    Naja, ich werde es aber mal probieren ;-)


    Ich stelle dann alles auf Werkeinstellungen.


  • Hallo,


    warum musst du die sys.txt nicht bearbeiten? Wie soll den die Software wissen das sie den Skin nutzen soll?!


    Edit: Sorry gerade erst gesehen...die sys.txt kannst du ruhig mit dem Editor öffen,dann ändern und einfach auf speichern gehen! Dazu bedarf es nich WordPad!

  • Hallo, ich hoffe Ihr könnt mir helfen. Habe ein Z099, ich wollte mir die Blitzerdaten von der Becker Homepage instal. Beim Neustart geht nichts mehr. Was mach ich falsch. Habe das Forum durchsucht aber nichts gefunden. Hoffe auf ein Paar Tipps. Danke im voraus.

  • Hmmm, schwer zu sagen, was du in Zukunft tun oder lassen solltest, wenn du uns nicht verrätst, was du genau angestellt hast. Einfach nur den POI Finder auf dem original, unveränderten, ungeskinnten Z099 installiert, POIs inkl. EU-Blitzer runtergeladen und nach dem Abstöpseln vom PC ging nix mehr?

  • Genau, der Bildschirm reagierte nicht mehr. Vieleicht hast Du einen Link wo alles step by step beschrieben wird wie ich andere Skins und Blitzerdaten auf das Gerät bekomme.